summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-07-13 22:33:35 +0000
committerDan Armak <danarmak@gentoo.org>2001-07-13 22:33:35 +0000
commit9b2bd994d9b98480c37cbb346ded9e6129e800e6 (patch)
treec6b004db34d38a3ee436fcbb8f1b6dc3f1df3574 /x11-libs/Xaw3d
parentfix (diff)
downloadhistorical-9b2bd994d9b98480c37cbb346ded9e6129e800e6.tar.gz
historical-9b2bd994d9b98480c37cbb346ded9e6129e800e6.tar.bz2
historical-9b2bd994d9b98480c37cbb346ded9e6129e800e6.zip
Xaw3d is a drop-in replacement for the X11 Xaw widget set. Many comments in the ebuild - people managing the X ebuilds might want to take a look. Used by gv.
Diffstat (limited to 'x11-libs/Xaw3d')
-rw-r--r--x11-libs/Xaw3d/Xaw3d-1.5.ebuild94
-rw-r--r--x11-libs/Xaw3d/files/Xaw3d-out-of-tree.diff11
-rw-r--r--x11-libs/Xaw3d/files/Xaw3d-xfree86.diff21
-rw-r--r--x11-libs/Xaw3d/files/digest-Xaw3d-1.51
4 files changed, 127 insertions, 0 deletions
diff --git a/x11-libs/Xaw3d/Xaw3d-1.5.ebuild b/x11-libs/Xaw3d/Xaw3d-1.5.ebuild
new file mode 100644
index 000000000000..3d78e19cb128
--- /dev/null
+++ b/x11-libs/Xaw3d/Xaw3d-1.5.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <ermak@netvision.net.il>
+# /home/cvsroot/gentoo-x86/skel.build,v 1.3 2001/07/05 02:43:36 drobbins Exp
+
+# !! IMPORTANT NOTE !!
+# The Xaw3d widget set is meant to be built as part of the X Consortium's
+# official R6.x tree. Building it against XFree86 creates a problem,
+# hence Xaw3d-xfree86.diff. Building it out-of-tree (i.e. without the
+# entire X source present) creates another problem because, like X,
+# Xaw3d uses Imakefiles which fit into the X hierarchy. Hence Xaw3d-out-of-tree.diff
+# (The problem it takes care of is a missing widec.h)
+# This implementation of the build process, together with the 2 patches,
+# comes from Slackware with very slight modifications introduced. If you
+# want to see the original, go to ftp.slackware.com and into the source -
+# it has standard shell scripts in text files for compiling.
+# Another (similar) set of instructions can be found at the gv homepage:
+# http://wwwthep.physik.uni-mainz.de/~plass/gv/Xaw3d.html
+#
+# NOTE: I did not write these patches. I did rename them, and have a lurking
+# suspicion I confused them and switched the names arond. Someone who is
+# better versed in compiling X and the structure of its Imakefiles might
+# want to take a look at it. But it does work :-)
+
+S=${WORKDIR}/xc/lib/Xaw3d
+
+DESCRIPTION="the Xaw3d is a drop-in 3D replacement of the Xaw widget set
+ which comes with X. It is used e.g. by gv the ghostcript frontend."
+
+# All full ftp.x.org mirrors can be added here.
+SRC_URI="ftp://ftp.x.org/contrib/widgets/Xaw3d/R6.3/${P}.tar.gz
+ http://ibiblio.org/pub/X11/contrib/widgets/Xaw3d/R6.3/${P}.tar.gz"
+
+# None so far as I know.
+#HOMEPAGE="http://"
+
+# There _might_ be something else, but I doubt it.
+DEPEND="virtual/x11"
+
+src_unpack() {
+
+ unpack ${P}.tar.gz
+ cd ${S}
+
+ # For some reason it isn't automatically patched.
+ # That's why I manually override the source_unpack function.
+ patch -p0 <${FILESDIR}/Xaw3d-xfree86.diff
+ patch -p0 <${FILESDIR}/Xaw3d-out-of-tree.diff
+
+}
+
+src_compile() {
+
+ # convoluted process for out-of-tree building
+ mkdir ./X11
+ cd ./X11 ; ln -sf ../../Xaw3d . ; cd ..
+
+ try xmkmf
+ try emake
+
+}
+
+src_install () {
+
+ # There is no install target in the Makefile.
+ # We have to copy everything by hand.
+ # Note: I don't understand dodoc, dobin, dodir...
+ # What happens if I just copy things?
+
+ cd ${S}
+
+ # library
+ mkdir -p ${D}/usr/X11R6/lib
+ cp libXaw3d.so.6.1 ${D}/usr/X11R6/lib/libXaw3d.so.6.1
+ # library version links
+ cd ${D}/usr/X11R6/lib/
+ ln -sf libXaw3d.so.6.1 libXaw3d.so.6
+ ln -sf libXaw3d.so.6 libXaw3d.so
+ cd ${S}
+
+ # docs
+ mkdir -p ${D}/usr/doc/Xaw3d
+ cp -a README.XAW3D ${D}/usr/doc/Xaw3d
+ chown root.root ${D}/usr/doc/Xaw3d/README.XAW3D
+ chmod 644 ${D}/usr/doc/Xaw3d/README.XAW3D
+
+ # headers
+ mkdir -p ${D}/usr/X11R6/include/X11/Xaw3d
+ cp -a *.h ${D}/usr/X11R6/include/X11/Xaw3d/
+ chown root.root ${D}/usr/X11R6/include/X11/Xaw3d/*
+ chmod 644 ${D}/usr/X11R6/include/X11/Xaw3d/*
+
+}
+
diff --git a/x11-libs/Xaw3d/files/Xaw3d-out-of-tree.diff b/x11-libs/Xaw3d/files/Xaw3d-out-of-tree.diff
new file mode 100644
index 000000000000..41af529025e2
--- /dev/null
+++ b/x11-libs/Xaw3d/files/Xaw3d-out-of-tree.diff
@@ -0,0 +1,11 @@
+--- Imakefile.orig Thu Apr 30 19:50:26 1998
++++ Imakefile Thu Apr 30 19:50:43 1998
+@@ -41,7 +41,7 @@
+
+ # EXTRA_DEFINES = -DARROW_SCROLLBAR -DUSEGRAY
+
+-# EXTRA_INCLUDES = -I.
++EXTRA_INCLUDES = -I.
+
+ HEADERS = \
+ AllWidgets.h \
diff --git a/x11-libs/Xaw3d/files/Xaw3d-xfree86.diff b/x11-libs/Xaw3d/files/Xaw3d-xfree86.diff
new file mode 100644
index 000000000000..a7665e36e7c2
--- /dev/null
+++ b/x11-libs/Xaw3d/files/Xaw3d-xfree86.diff
@@ -0,0 +1,21 @@
+--- XawI18n.h.orig Tue Aug 29 07:00:21 1995
++++ XawI18n.h Tue Nov 19 02:22:09 1996
+@@ -27,12 +27,18 @@
+
+ ********************************************************/
+
++#if 0
+ #ifdef HAS_WCTYPE_H
+ #include <wctype.h>
++#if !defined(__linux__)
+ #include <widec.h>
++#endif
++#endif
+ #define wcslen(c) wslen(c)
+ #define wcscpy(d,s) wscpy(d,s)
+ #define wcsncpy(d,s,l) wsncpy(d,s,l)
++#if 0
++#endif
+ #endif
+
+ #ifdef HAS_WCHAR_H
diff --git a/x11-libs/Xaw3d/files/digest-Xaw3d-1.5 b/x11-libs/Xaw3d/files/digest-Xaw3d-1.5
new file mode 100644
index 000000000000..2f89de8c301b
--- /dev/null
+++ b/x11-libs/Xaw3d/files/digest-Xaw3d-1.5
@@ -0,0 +1 @@
+MD5 a77aa4ebe3be7964e4dbbc351e48277f Xaw3d-1.5.tar.gz