summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-01-15 19:43:53 +0000
committerMichał Górny <mgorny@gentoo.org>2011-01-15 19:43:53 +0000
commitcef7f586a134be4ca907ecdf812b8b94c9885112 (patch)
treef5a99895e575fd3d2a2caa9f2b86e0b9ec68fa39 /x11-libs/libaosd/libaosd-0.2.7.ebuild
parentFix building with >=media-gfx/exiv2-0.21. (diff)
downloadhistorical-cef7f586a134be4ca907ecdf812b8b94c9885112.tar.gz
historical-cef7f586a134be4ca907ecdf812b8b94c9885112.tar.bz2
historical-cef7f586a134be4ca907ecdf812b8b94c9885112.zip
Add a new ebuild for libaosd, as requested per bug #351741. Thanks to Erik McNellis for the initial ebuild.
Package-Manager: portage-2.2.0_alpha15_p1/cvs/Linux x86_64
Diffstat (limited to 'x11-libs/libaosd/libaosd-0.2.7.ebuild')
-rw-r--r--x11-libs/libaosd/libaosd-0.2.7.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-libs/libaosd/libaosd-0.2.7.ebuild b/x11-libs/libaosd/libaosd-0.2.7.ebuild
new file mode 100644
index 000000000000..9c192ba29b32
--- /dev/null
+++ b/x11-libs/libaosd/libaosd-0.2.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libaosd/libaosd-0.2.7.ebuild,v 1.1 2011/01/15 19:43:53 mgorny Exp $
+
+EAPI=3
+inherit autotools-utils
+
+DESCRIPTION="An advanced on screen display (OSD) library"
+HOMEPAGE="http://www.atheme.org/project/libaosd"
+SRC_URI="http://distfiles.atheme.org/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="pango +tools xcomposite"
+
+RDEPEND="x11-libs/cairo
+ x11-libs/libX11
+ x11-libs/libXrender
+ pango? ( x11-libs/pango )
+ tools? ( dev-libs/glib:2 )
+ xcomposite? ( x11-libs/libXcomposite )"
+DEPEND="${RDEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+DOCS=( Changelog )
+
+src_configure() {
+ myeconfargs=(
+ $(use_enable tools glib)
+ $(use_enable pango pangocairo)
+ $(use_enable xcomposite)
+ )
+
+ autotools-utils_src_configure
+}