summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2006-10-07 06:13:56 +0000
committerMart Raudsepp <leio@gentoo.org>2006-10-07 06:13:56 +0000
commit2e4e9f37978e938268655ff428f09db162272209 (patch)
tree8a4ce583db08975518fb1d3ddc891d159c96ea6b /x11-libs/pango
parent+ruby (diff)
downloadhistorical-2e4e9f37978e938268655ff428f09db162272209.tar.gz
historical-2e4e9f37978e938268655ff428f09db162272209.tar.bz2
historical-2e4e9f37978e938268655ff428f09db162272209.zip
Version bump, mostly fixing a few cjk issues in previous version
Package-Manager: portage-2.1.2_pre2-r5
Diffstat (limited to 'x11-libs/pango')
-rw-r--r--x11-libs/pango/ChangeLog8
-rw-r--r--x11-libs/pango/files/digest-pango-1.14.53
-rw-r--r--x11-libs/pango/pango-1.14.5.ebuild75
3 files changed, 85 insertions, 1 deletions
diff --git a/x11-libs/pango/ChangeLog b/x11-libs/pango/ChangeLog
index 060212a7a3c4..4c6b5af3cc11 100644
--- a/x11-libs/pango/ChangeLog
+++ b/x11-libs/pango/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/pango
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.149 2006/09/28 14:59:29 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.150 2006/10/07 06:13:56 leio Exp $
+
+*pango-1.14.5 (07 Oct 2006)
+
+ 07 Oct 2006; Mart Raudsepp <leio@gentoo.org> -pango-1.14.4.ebuild,
+ +pango-1.14.5.ebuild:
+ Version bump, mostly fixing a few cjk issues in previous version
*pango-1.14.4 (28 Sep 2006)
diff --git a/x11-libs/pango/files/digest-pango-1.14.5 b/x11-libs/pango/files/digest-pango-1.14.5
new file mode 100644
index 000000000000..6c3e87b9a559
--- /dev/null
+++ b/x11-libs/pango/files/digest-pango-1.14.5
@@ -0,0 +1,3 @@
+MD5 297959acf7ed048a1f2596574b7671b6 pango-1.14.5.tar.bz2 1288194
+RMD160 5e1f73eb12820f2f9994b56259195283a8a2bc69 pango-1.14.5.tar.bz2 1288194
+SHA256 583060081538248775939c303aed80af1543de4b3472c316a556874437711156 pango-1.14.5.tar.bz2 1288194
diff --git a/x11-libs/pango/pango-1.14.5.ebuild b/x11-libs/pango/pango-1.14.5.ebuild
new file mode 100644
index 000000000000..e59fab303609
--- /dev/null
+++ b/x11-libs/pango/pango-1.14.5.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.14.5.ebuild,v 1.1 2006/10/07 06:13:56 leio Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="Text rendering and layout library"
+HOMEPAGE="http://www.pango.org/"
+
+LICENSE="LGPL-2 FTL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND="|| (
+ (
+ x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXft
+ )
+ virtual/x11
+ )
+ >=dev-libs/glib-2.10.0
+ >=media-libs/fontconfig-1.0.1
+ >=media-libs/freetype-2
+ >=x11-libs/cairo-1.2.2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ || ( x11-proto/xproto virtual/x11 )
+ doc? (
+ >=dev-util/gtk-doc-1
+ ~app-text/docbook-xml-dtd-4.1.2
+ )"
+
+DOCS="AUTHORS ChangeLog* NEWS README TODO*"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Some enhancements from Redhat
+ # These NEED to go upstream.
+ epatch ${FILESDIR}/pango-1.11.3-xfonts.patch
+ epatch ${FILESDIR}/${PN}-1.10.2-slighthint.patch
+
+ # make config file location host specific so that a 32bit and 64bit pango
+ # wont fight with each other on a multilib system
+ use amd64 && epatch ${FILESDIR}/pango-1.2.5-lib64.patch
+
+ # and this line is just here to make building emul-linux-x86-gtklibs a bit
+ # easier, so even this should be amd64 specific.
+ use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && epatch ${FILESDIR}/pango-1.2.5-lib64.patch
+
+ epunt_cxx
+}
+
+src_install() {
+ gnome2_src_install
+
+ rm ${D}/etc/pango/pango.modules
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" == "/" ] ; then
+ einfo "Generating modules listing..."
+
+ use amd64 && PANGO_CONFDIR="/etc/pango/${CHOST}"
+ use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && PANGO_CONFDIR="/etc/pango/${CHOST}"
+
+ PANGO_CONFDIR=${PANGO_CONFDIR:=/etc/pango}
+ mkdir -p ${PANGO_CONFDIR}
+
+ pango-querymodules > ${PANGO_CONFDIR}/pango.modules
+ fi
+}