summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-09-23 21:36:25 +0000
committerAlex Alexander <wired@gentoo.org>2010-09-23 21:36:25 +0000
commitcd65f7d878d9f02332a1ae61947c5b3573ebdafa (patch)
tree701f714cac0b936ccbd51c10f53e84144819a0b7 /x11-libs/qt-assistant
parentadd ~arm, bug #338426 (diff)
downloadhistorical-cd65f7d878d9f02332a1ae61947c5b3573ebdafa.tar.gz
historical-cd65f7d878d9f02332a1ae61947c5b3573ebdafa.tar.bz2
historical-cd65f7d878d9f02332a1ae61947c5b3573ebdafa.zip
EAPI 3, prefix, other improvements
Package-Manager: portage-2.2_rc85/cvs/Linux x86_64
Diffstat (limited to 'x11-libs/qt-assistant')
-rw-r--r--x11-libs/qt-assistant/ChangeLog5
-rw-r--r--x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild48
2 files changed, 29 insertions, 24 deletions
diff --git a/x11-libs/qt-assistant/ChangeLog b/x11-libs/qt-assistant/ChangeLog
index 7da9d43072ca..25f8ac8dd248 100644
--- a/x11-libs/qt-assistant/ChangeLog
+++ b/x11-libs/qt-assistant/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-libs/qt-assistant
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.85 2010/09/21 14:37:38 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.86 2010/09/23 21:36:03 wired Exp $
+
+ 23 Sep 2010; Alex Alexander <wired@gentoo.org> qt-assistant-4.7.0.ebuild:
+ EAPI 3, prefix, other improvements
*qt-assistant-4.7.0 (21 Sep 2010)
diff --git a/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild b/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild
index 38dfd5d8a26f..d7f459dcfd4f 100644
--- a/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild
+++ b/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild,v 1.1 2010/09/21 14:37:38 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild,v 1.2 2010/09/23 21:36:03 wired Exp $
-EAPI="2"
+EAPI="3"
inherit qt4-build
DESCRIPTION="The assistant help module for the Qt toolkit"
@@ -10,27 +10,27 @@ SLOT="4"
KEYWORDS="~amd64 ~x86"
IUSE="doc +glib trace"
-DEPEND="~x11-libs/qt-gui-${PV}[glib=,trace?]
- ~x11-libs/qt-sql-${PV}[sqlite]
- ~x11-libs/qt-webkit-${PV}
+DEPEND="~x11-libs/qt-gui-${PV}[aqua=,glib=,trace?]
+ ~x11-libs/qt-sql-${PV}[aqua=,sqlite]
+ ~x11-libs/qt-webkit-${PV}[aqua=]
~x11-libs/qt-declarative-${PV}"
RDEPEND="${DEPEND}"
-# Pixeltool isn't really assistant related, but it relies on
-# the assistant libraries. doc/qch/
-QT4_TARGET_DIRECTORIES="
- tools/assistant
- tools/pixeltool
- tools/qdoc3"
-QT4_EXTRACT_DIRECTORIES="
- tools/
- demos/
- examples/
- src/
- include/
- doc/"
-
pkg_setup() {
+ # Pixeltool isn't really assistant related, but it relies on
+ # the assistant libraries. doc/qch/
+ QT4_TARGET_DIRECTORIES="
+ tools/assistant
+ tools/pixeltool
+ tools/qdoc3"
+ QT4_EXTRACT_DIRECTORIES="
+ tools/
+ demos/
+ examples/
+ src/
+ include/
+ doc/"
+
use trace && QT4_TARGET_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
tools/qttracereplay"
QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
@@ -77,10 +77,12 @@ src_install() {
fi
dobin "${S}"/bin/qdoc3 || die "Failed to install qdoc3"
# install correct assistant icon, bug 241208
- dodir /usr/share/pixmaps/ || die
+ dodir /usr/share/pixmaps/ || die "dodir failed"
insinto /usr/share/pixmaps/
- doins tools/assistant/tools/assistant/images/assistant.png || die
+ doins tools/assistant/tools/assistant/images/assistant.png ||
+ die "doins failed"
# Note: absolute image path required here!
- make_desktop_entry /usr/bin/assistant Assistant \
- /usr/share/pixmaps/assistant.png 'Qt;Development;GUIDesigner' || die
+ make_desktop_entry "${EPREFIX}"/usr/bin/assistant Assistant \
+ "${EPREFIX}"/usr/share/pixmaps/assistant.png 'Qt;Development;GUIDesigner' ||
+ die "make_desktop_entry failed"
}