summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-08-20 20:24:00 +0000
committerDan Armak <danarmak@gentoo.org>2002-08-20 20:24:00 +0000
commit8eb2b961146965237092e03a9cee2110a9d00abe (patch)
tree9ed9244749b7b3fcf5809bb78e3dbfc0aa9f0c39 /x11-libs/qt-embedded
parentRemoved the comments at the top of the generated files (diff)
downloadhistorical-8eb2b961146965237092e03a9cee2110a9d00abe.tar.gz
historical-8eb2b961146965237092e03a9cee2110a9d00abe.tar.bz2
historical-8eb2b961146965237092e03a9cee2110a9d00abe.zip
qt-embedded, masked for testing.
Diffstat (limited to 'x11-libs/qt-embedded')
-rw-r--r--x11-libs/qt-embedded/files/47qt-embedded34
-rw-r--r--x11-libs/qt-embedded/files/digest-qt-embedded-3.0.51
-rw-r--r--x11-libs/qt-embedded/files/tools-Makefile66
-rw-r--r--x11-libs/qt-embedded/qt-embedded-3.0.5.ebuild176
4 files changed, 247 insertions, 0 deletions
diff --git a/x11-libs/qt-embedded/files/47qt-embedded3 b/x11-libs/qt-embedded/files/47qt-embedded3
new file mode 100644
index 000000000000..9dc57ca40715
--- /dev/null
+++ b/x11-libs/qt-embedded/files/47qt-embedded3
@@ -0,0 +1,4 @@
+PATH=/usr/qt/3-embedded/bin
+ROOTPATH=/usr/qt/3-embedded/bin
+LDPATH=/usr/qt/3-embedded/lib
+QMAKESPEC=linux-g++
diff --git a/x11-libs/qt-embedded/files/digest-qt-embedded-3.0.5 b/x11-libs/qt-embedded/files/digest-qt-embedded-3.0.5
new file mode 100644
index 000000000000..53aa8d6eb06a
--- /dev/null
+++ b/x11-libs/qt-embedded/files/digest-qt-embedded-3.0.5
@@ -0,0 +1 @@
+MD5 0f62114644a598848d59e65b3507a290 qt-embedded-free-3.0.5.tar.bz2 18539706
diff --git a/x11-libs/qt-embedded/files/tools-Makefile b/x11-libs/qt-embedded/files/tools-Makefile
new file mode 100644
index 000000000000..95f8405895bb
--- /dev/null
+++ b/x11-libs/qt-embedded/files/tools-Makefile
@@ -0,0 +1,66 @@
+#############################################################################
+# Makefile for building: tools
+# Generated by qmake (1.03a) on: Tue Aug 20 13:16:21 2002
+# Project: tools.pro
+# Template: subdirs
+# Command: $(QMAKE) tools.pro
+#############################################################################
+
+MAKEFILE = Makefile
+QMAKE = qmake
+SUBDIRS = designer \
+ assistant \
+ linguist \
+ qtconfig
+DEL_FILE = rm -f
+SUBTARGETS = \
+ sub-designer \
+ sub-assistant \
+ sub-linguist \
+ sub-qtconfig
+
+first: all
+
+all: Makefile $(SUBTARGETS)
+
+designer/$(MAKEFILE):
+ cd designer && $(QMAKE) -o $(MAKEFILE)
+sub-designer: designer/$(MAKEFILE) FORCE
+ cd designer && $(MAKE) -f $(MAKEFILE)
+
+assistant/$(MAKEFILE):
+ cd assistant && $(QMAKE) -o $(MAKEFILE)
+sub-assistant: assistant/$(MAKEFILE) FORCE
+ cd assistant && $(MAKE) -f $(MAKEFILE)
+
+linguist/$(MAKEFILE):
+ cd linguist && $(QMAKE) -o $(MAKEFILE)
+sub-linguist: linguist/$(MAKEFILE) FORCE
+ cd linguist && $(MAKE) -f $(MAKEFILE)
+
+qtconfig/$(MAKEFILE):
+ cd qtconfig && $(QMAKE) -o $(MAKEFILE)
+sub-qtconfig: qtconfig/$(MAKEFILE) FORCE
+ cd qtconfig && $(MAKE) -f $(MAKEFILE)
+
+sub-assistant: sub-designer
+sub-linguist: sub-assistant
+sub-qtconfig: sub-linguist
+
+Makefile: tools.pro ../.qmake.cache $(QTDIR)/mkspecs/linux-g++/qmake.conf
+ $(QMAKE) tools.pro
+qmake: qmake_all
+ @$(QMAKE) tools.pro
+
+qmake_all: designer/$(MAKEFILE) assistant/$(MAKEFILE) linguist/$(MAKEFILE) qtconfig/$(MAKEFILE)
+ for i in $(SUBDIRS); do ( if [ -d $$i ]; then cd $$i ; grep "^qmake_all:" $(MAKEFILE) 2>/dev/null >/dev/null && $(MAKE) -f $(MAKEFILE) qmake_all || true; fi; ) ; done
+
+clean: qmake_all FORCE
+ for i in $(SUBDIRS); do ( if [ -d $$i ]; then cd $$i ; $(MAKE) -f $(MAKEFILE) clean; fi; ) ; done
+uninstall install uiclean mocclean: qmake_all FORCE
+ for i in $(SUBDIRS); do ( if [ -d $$i ]; then cd $$i ; $(MAKE) -f $(MAKEFILE) $@; fi; ) ; done
+distclean: qmake_all FORCE
+ for i in $(SUBDIRS); do ( if [ -d $$i ]; then cd $$i ; $(MAKE) -f $(MAKEFILE) $@ ; $(DEL_FILE) $(MAKEFILE) ; fi; ) ; done
+
+FORCE:
+
diff --git a/x11-libs/qt-embedded/qt-embedded-3.0.5.ebuild b/x11-libs/qt-embedded/qt-embedded-3.0.5.ebuild
new file mode 100644
index 000000000000..0bf67e4579f5
--- /dev/null
+++ b/x11-libs/qt-embedded/qt-embedded-3.0.5.ebuild
@@ -0,0 +1,176 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-embedded/qt-embedded-3.0.5.ebuild,v 1.1 2002/08/20 20:24:00 danarmak Exp $
+
+S=${WORKDIR}/qt-embedded-free-${PV}
+
+DESCRIPTION="QT version ${PV}"
+SLOT="3"
+LICENSE="QPL-1.0 | GPL-2"
+KEYWORDS="x86"
+
+SRC_URI="ftp://ftp.trolltech.com/qt/source/qt-embedded-free-${PV}.tar.bz2"
+
+HOMEPAGE="http://www.trolltech.com/"
+
+if [ -z "`use build`" ]; then
+ DEPEND="media-libs/libpng
+ media-libs/lcms
+ media-libs/jpeg
+ >=media-libs/libmng-1.0.0
+ >=media-libs/freetype-2
+ odbc? ( >=dev-db/unixODBC-2.0 )
+ mysql? ( >=dev-db/mysql-3.2.10 )
+ opengl? ( virtual/opengl virtual/glu )
+ postgres? ( >=dev-db/postgresql-7.2 )"
+else
+ DEPEND="media-libs/lcms
+ >=media-libs/freetype-2"
+fi
+
+
+QTBASE=/usr/qt/3-embedded
+export QTDIR=${S}
+
+src_unpack() {
+
+ [ -z "`use build`" ] && einfo "
+Note: this will build a rather bloated qt/e, with all features enabled.
+It may be suitable for testing, but definitely not for real embedded systems
+where memory is precious. I advise you select your own featureset (e.g. by
+editing this ebuild) if building for such a system.
+"
+
+ export QTDIR=${S}
+
+ unpack $A
+
+ cd ${S}
+ cp configure configure.orig
+ sed -e 's:read acceptance:acceptance=yes:' configure.orig > configure
+
+ # avoid wasting time building things we won't install
+ rm -rf tutorial examples
+
+}
+
+src_compile() {
+
+ export QTDIR=${S}
+ export YACC='byacc -d'
+ export LDFLAGS="-ldl"
+ export QTDIR=${S}
+
+ if [ -z "`use build`" ]; then
+ # ordinary setup, rather bloated
+ use gif && myconf="${myconf} -qt-gif"
+ use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/lib/mysql"
+ use postgres && myconf="${myconf} -plugin-sql-psql -I/usr/include/postgresql/server"
+ use odbc && myconf="${myconf} -plugin-sql-odbc"
+ [ -n "$DEBUG" ] && myconf="${myconf} -debug" || myconf="${myconf} -release -no-g++-exceptions"
+
+ if [ "`use x86`" ]; then
+ myconf="$myconf -embedded x86" # -xplatform linux-g++ -platform linux-g++"
+ else
+ # and i've no idea if it'll work
+ myconf="$myconf -xplatform generic -embedded generic"
+ fi
+
+ # -accel-{voodoo3,mach64,matrox} -vnc -depths v,4,8,16,24,32 # this stuff miscompiles :-(
+
+ ./configure $myconf -depths 8,16 -system-zlib -thread -stl -freetype -qvfb \
+ -plugin-imgfmt-{jpeg,mng,png} -system-lib{png,jpeg,mng} || die
+
+
+ else
+ # use build == we're building for the gentoo isntaller project
+ # and know exactly which features we'll need
+
+ # not all of these features are as yet reflected in the configure call below
+
+ #png only, builtin. also zlib, system.
+ #no sql or other fancy stuff.
+ #no debug
+ #thread support
+ #freetype2 support
+ #vnc
+ #all styles as plugins
+ ./configure -depths 8,16 -no-gif -no-lib{jpeg,mng} -qt-libpng -system-zlib -release \
+ -no-g++-exceptions -no-qvfb -thread -freetype -vnc || die
+ fi
+
+ cp $FILESDIR/tools-Makefile $S/tools/Makefile
+
+ cd $S/tools/designer/designer
+ mv Makefile Makefile.orig
+ sed -e 's:lqt-mt:lqte-mt:g' Makefile.orig > Makefile
+ rm Makefile.orig
+
+ cd $S
+ emake src-qmake src-moc sub-src sub-tools || die
+
+}
+
+src_install() {
+
+
+ export QTDIR=${S}
+
+ cd ${S}
+
+ # binaries
+ into $QTBASE
+ dobin bin/*
+
+ # libraries
+ dolib lib/libqte-mt.so.${PV} lib/libqui.so.1.0.0 lib/libeditor.so.1.0.0
+ cd ${D}$QTBASE/lib
+ for x in libqui.so libeditor.so
+ do
+ ln -s $x.1.0.0 $x.1.0
+ ln -s $x.1.0 $x.1
+ ln -s $x.1 $x
+ done
+
+ # version symlinks - 3.0.3->3.0->3->.so
+ ln -s libqte-mt.so.${PV} libqte-mt.so.3.0
+ ln -s libqte-mt.so.3.0 libqte-mt.so.3
+ ln -s libqte-mt.so.3 libqte-mt.so
+
+ # libqt -> libqt-mt symlinks
+ ln -s libqte-mt.so.${PV} libqte.so.${PV}
+ ln -s libqte-mt.so.3.0 libqte.so.3.0
+ ln -s libqte-mt.so.3 libqte.so.3
+ ln -s libqte-mt.so libqte.so
+
+ # includes
+ cd ${S}
+ dodir ${QTBASE}/include/private
+ cp include/* ${D}/${QTBASE}/include/
+ cp include/private/* ${D}/${QTBASE}/include/private/
+
+ # misc
+ insinto /etc/env.d
+ doins ${FILESDIR}/47qt-embedded3
+
+ # misc build reqs
+ dodir ${QTBASE}/mkspecs
+ cp -R ${S}/mkspecs/linux-g++ ${D}/${QTBASE}/mkspecs/
+
+ sed -e "s:${D}::g" \
+ -e "s:qt-x11-free-3.0.1::g" \
+ -e "s:${WORKDIR}:${QTBASE}:" \
+ -e "s:/usr/local/qt:${QTBASE}:" \
+ ${S}/.qmake.cache > ${D}${QTBASE}/.qmake.cache
+
+ # plugins
+ cd ${S}
+ plugins=`find plugins -name "lib*.so" -print`
+ for x in $plugins; do
+ insinto ${QTBASE}/`dirname $x`
+ doins $x
+ done
+
+}
+
+