summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-04-26 11:32:56 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-04-26 11:32:56 +0000
commitb7e1a799acb81d2d275cdde68fc47842786020a0 (patch)
tree7ecbaa25cdc48d109e1f05699b9bc73c2ff650b9 /x11-libs/xvba-video/xvba-video-0.7.8.ebuild
parentStable on amd64 wrt bug #364417 (diff)
downloadhistorical-b7e1a799acb81d2d275cdde68fc47842786020a0.tar.gz
historical-b7e1a799acb81d2d275cdde68fc47842786020a0.tar.bz2
historical-b7e1a799acb81d2d275cdde68fc47842786020a0.zip
Initial commit for xvba-video fglrx driver for libva. Per bug #325033.
Package-Manager: portage-2.2.0_alpha30/cvs/Linux x86_64
Diffstat (limited to 'x11-libs/xvba-video/xvba-video-0.7.8.ebuild')
-rw-r--r--x11-libs/xvba-video/xvba-video-0.7.8.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-libs/xvba-video/xvba-video-0.7.8.ebuild b/x11-libs/xvba-video/xvba-video-0.7.8.ebuild
new file mode 100644
index 000000000000..c6791deee9e2
--- /dev/null
+++ b/x11-libs/xvba-video/xvba-video-0.7.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xvba-video/xvba-video-0.7.8.ebuild,v 1.1 2011/04/26 11:32:56 scarabeus Exp $
+
+EAPI=4
+
+inherit multilib
+
+x86name="${P}.i686"
+amd64name="${P}.x86_64"
+
+DESCRIPTION="VDPAU Backend for Video Acceleration (VA) API"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/vaapi"
+SRC_URI="
+ amd64? ( http://www.splitted-desktop.com/~gbeauchesne/${PN}/${amd64name}.tar.gz )
+ x86? ( http://www.splitted-desktop.com/~gbeauchesne/${PN}/${x86name}.tar.gz )
+"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libva[opengl]
+ x11-drivers/ati-drivers"
+DEPEND=""
+
+S=${WORKDIR}
+
+# TODO: ignore QA warning about ldflags since this is binary
+QA_PRESTRIPPED="
+ usr/lib\(32\|64\)\?/va/drivers/xvba_drv_video.so
+ usr/lib\(32\|64\)\?/va/drivers/fglrx_drv_video.so
+"
+
+src_install() {
+ use x86 && cd "${x86name}"
+ use amd64 && cd "${amd64name}"
+
+ dodoc AUTHORS NEWS README
+ exeinto /usr/$(get_libdir)/va/drivers/
+ doexe usr/lib/va/drivers/*
+}