summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-05-29 20:03:53 +0000
committerTravis Tilley <lv@gentoo.org>2004-05-29 20:03:53 +0000
commit1542ebcc2be5d26c23f3d1696ed1d98f8bb33b4d (patch)
tree83f008a7b47443bc4e5cdcde58767fa75dc353e8 /x11-libs
parentmarking -r3 stable, adding -r4 with a couple of patches from cvs. (diff)
downloadhistorical-1542ebcc2be5d26c23f3d1696ed1d98f8bb33b4d.tar.gz
historical-1542ebcc2be5d26c23f3d1696ed1d98f8bb33b4d.tar.bz2
historical-1542ebcc2be5d26c23f3d1696ed1d98f8bb33b4d.zip
added an #undef X_LOCALE before including XLocale.h, otherwise locale.h isnt included and compilation fails with gcc 3.4
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/openmotif/ChangeLog7
-rw-r--r--x11-libs/openmotif/Manifest13
-rw-r--r--x11-libs/openmotif/files/openmotif-2.1.30-gcc34.patch12
-rw-r--r--x11-libs/openmotif/openmotif-2.1.30-r5.ebuild3
4 files changed, 27 insertions, 8 deletions
diff --git a/x11-libs/openmotif/ChangeLog b/x11-libs/openmotif/ChangeLog
index 981d7f71a9ae..a9b1bfb7a8f7 100644
--- a/x11-libs/openmotif/ChangeLog
+++ b/x11-libs/openmotif/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/openmotif
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/ChangeLog,v 1.43 2004/05/12 15:42:57 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/ChangeLog,v 1.44 2004/05/29 20:03:53 lv Exp $
+
+ 29 May 2004; Travis Tilley <lv@gentoo.org>
+ +files/openmotif-2.1.30-gcc34.patch, openmotif-2.1.30-r5.ebuild:
+ added an #undef X_LOCALE before including XLocale.h, otherwise locale.h isnt
+ included and compilation fails with gcc 3.4
12 May 2004; Ciaran McCreesh <ciaranm@gentoo.org>
openmotif-2.1.30-r4.ebuild:
diff --git a/x11-libs/openmotif/Manifest b/x11-libs/openmotif/Manifest
index dc7cc0ac1b5a..5da9a3132d3f 100644
--- a/x11-libs/openmotif/Manifest
+++ b/x11-libs/openmotif/Manifest
@@ -1,11 +1,12 @@
-MD5 45e43e35c28fbbd2680648402de3b0f1 ChangeLog 6258
-MD5 c6201f18209870d9d93dfffdf49c5251 openmotif-2.1.30-r5.ebuild 3176
+MD5 04b14d660cb7bb3e40126b62be1aab75 openmotif-2.1.30-r5.ebuild 3211
+MD5 fe8639062cd06ad1ca961ce6d15c69aa ChangeLog 6491
MD5 dffd46174e78b327c834fc3e4b1cf848 metadata.xml 160
MD5 9776841276c4785935229a8e35bc0d8a openmotif-2.1.30-r4.ebuild 3118
-MD5 28350d5dab901ef8cd0dc92e578e3f45 files/openmotif-2.1.30-imake-tmpdir.patch 1083
-MD5 ed2738dd3cbdc87b0800fe9710092d18 files/openmotif-2.1.30-imake-ansi.patch 6554
MD5 818d2d673fe5ee323f93b5a66fb1baca files/digest-openmotif-2.1.30-r4 79
-MD5 f586e24ce0a2b3eeea25a82c8ec1d3c4 files/openmotif-2.1.30-uil-bad_grammar_fix.diff 832
-MD5 7284e10e14cac30429821b824dd2f722 files/site.def 2062
MD5 818d2d673fe5ee323f93b5a66fb1baca files/digest-openmotif-2.1.30-r5 79
+MD5 c63bde26627325aeb48d09772875670b files/openmotif-2.1.30-gcc34.patch 374
+MD5 7284e10e14cac30429821b824dd2f722 files/site.def 2062
+MD5 ed2738dd3cbdc87b0800fe9710092d18 files/openmotif-2.1.30-imake-ansi.patch 6554
+MD5 f586e24ce0a2b3eeea25a82c8ec1d3c4 files/openmotif-2.1.30-uil-bad_grammar_fix.diff 832
+MD5 28350d5dab901ef8cd0dc92e578e3f45 files/openmotif-2.1.30-imake-tmpdir.patch 1083
MD5 7284e10e14cac30429821b824dd2f722 files/site.def.1 2062
diff --git a/x11-libs/openmotif/files/openmotif-2.1.30-gcc34.patch b/x11-libs/openmotif/files/openmotif-2.1.30-gcc34.patch
new file mode 100644
index 000000000000..d7d56295e103
--- /dev/null
+++ b/x11-libs/openmotif/files/openmotif-2.1.30-gcc34.patch
@@ -0,0 +1,12 @@
+--- motif.old/lib/Xm/Scale.c 2004-05-29 15:39:27.089621032 +0000
++++ motif/lib/Xm/Scale.c 2004-05-29 15:44:09.597673280 +0000
+@@ -81,6 +81,9 @@
+ #ifdef __cplusplus
+ extern "C" { /* some 'locale.h' do not have prototypes (sun) */
+ #endif
++#ifdef X_LOCALE
++#undef X_LOCALE
++#endif
+ #include <X11/Xlocale.h>
+ #ifdef __cplusplus
+ } /* Close scope of 'extern "C"' declaration */
diff --git a/x11-libs/openmotif/openmotif-2.1.30-r5.ebuild b/x11-libs/openmotif/openmotif-2.1.30-r5.ebuild
index e69c83146451..2930b2692a1a 100644
--- a/x11-libs/openmotif/openmotif-2.1.30-r5.ebuild
+++ b/x11-libs/openmotif/openmotif-2.1.30-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.1.30-r5.ebuild,v 1.3 2004/04/17 23:02:17 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.1.30-r5.ebuild,v 1.4 2004/05/29 20:03:53 lv Exp $
inherit eutils
@@ -59,6 +59,7 @@ src_unpack() {
# compile on gcc 2.9x
epatch ${FILESDIR}/${P}-imake-ansi.patch
epatch ${FILESDIR}/${P}-uil-bad_grammar_fix.diff
+ epatch ${FILESDIR}/${P}-gcc34.patch
}
src_compile() {