summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-06-11 22:58:13 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-06-11 22:58:13 +0000
commitdbc40c050a1e480b797128cb7fb1d08364449654 (patch)
tree81b816c1a029f7b7467c2deafea78d25fbb20b36 /x11-misc/hotkeys
parentAdded xchat-1.9.1 to the mask lists. (diff)
downloadhistorical-dbc40c050a1e480b797128cb7fb1d08364449654.tar.gz
historical-dbc40c050a1e480b797128cb7fb1d08364449654.tar.bz2
historical-dbc40c050a1e480b797128cb7fb1d08364449654.zip
added an ebuild for hotkeys - handles extra buttons on newer keyboards.
Diffstat (limited to 'x11-misc/hotkeys')
-rw-r--r--x11-misc/hotkeys/files/digest-hotkeys-0.5.41
-rw-r--r--x11-misc/hotkeys/files/hotkeys-0.5.4-gentoo.diff.gzbin0 -> 20810 bytes
-rw-r--r--x11-misc/hotkeys/hotkeys-0.5.4.ebuild41
3 files changed, 42 insertions, 0 deletions
diff --git a/x11-misc/hotkeys/files/digest-hotkeys-0.5.4 b/x11-misc/hotkeys/files/digest-hotkeys-0.5.4
new file mode 100644
index 000000000000..f63a40da8fca
--- /dev/null
+++ b/x11-misc/hotkeys/files/digest-hotkeys-0.5.4
@@ -0,0 +1 @@
+MD5 50810778bf50c769a39cd44ba59fd14a hotkeys_0.5.4.tar.gz 378334
diff --git a/x11-misc/hotkeys/files/hotkeys-0.5.4-gentoo.diff.gz b/x11-misc/hotkeys/files/hotkeys-0.5.4-gentoo.diff.gz
new file mode 100644
index 000000000000..d03c41c9add8
--- /dev/null
+++ b/x11-misc/hotkeys/files/hotkeys-0.5.4-gentoo.diff.gz
Binary files differ
diff --git a/x11-misc/hotkeys/hotkeys-0.5.4.ebuild b/x11-misc/hotkeys/hotkeys-0.5.4.ebuild
new file mode 100644
index 000000000000..20a4f5cd8ce8
--- /dev/null
+++ b/x11-misc/hotkeys/hotkeys-0.5.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Stacey Keast <slik@telusplanet.net>
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/hotkeys/hotkeys-0.5.4.ebuild,v 1.1 2002/06/11 22:58:13 george Exp $
+
+NAME="hotkeys"
+S=${WORKDIR}/${P}
+DESCRIPTION="Make use of extra buttons on newer keyboards."
+SRC_URI="http://ypwong.org/hotkeys/hotkeys_0.5.4.tar.gz"
+HOMEPAGE="http://ypwong.org/hotkeys/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="virtual/x11
+ virtual/glibc
+ dev-libs/libxml2
+ >=sys-libs/db-3.2.3
+ x11-libs/xosd"
+
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ zcat ${FILESDIR}/${P}-gentoo.diff.gz | patch -p0
+}
+
+src_compile() {
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS ChangeLog COPYING README TODO
+}
+