summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Stine <battousai@gentoo.org>2005-07-25 18:09:09 +0000
committerBryan Stine <battousai@gentoo.org>2005-07-25 18:09:09 +0000
commit1b0d350795906e79fdbe10066c02f6ef23f46ca1 (patch)
treef340c94e519f6753e1f0bc30cb2fc5f6c7a36822 /x11-misc/synaptics
parentChange qt dep per bug #100235 (diff)
downloadhistorical-1b0d350795906e79fdbe10066c02f6ef23f46ca1.tar.gz
historical-1b0d350795906e79fdbe10066c02f6ef23f46ca1.tar.bz2
historical-1b0d350795906e79fdbe10066c02f6ef23f46ca1.zip
Add patch to backport sentinel code to included headers. Closes bug #100134.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'x11-misc/synaptics')
-rw-r--r--x11-misc/synaptics/ChangeLog8
-rw-r--r--x11-misc/synaptics/Manifest9
-rw-r--r--x11-misc/synaptics/files/synaptics-0.14.x-gcc4-the-sentinels-have-attacked.patch16
-rw-r--r--x11-misc/synaptics/synaptics-0.14.1.ebuild4
-rw-r--r--x11-misc/synaptics/synaptics-0.14.2.ebuild4
-rw-r--r--x11-misc/synaptics/synaptics-0.14.3.ebuild4
6 files changed, 37 insertions, 8 deletions
diff --git a/x11-misc/synaptics/ChangeLog b/x11-misc/synaptics/ChangeLog
index 0134b88b756e..cfc639330d7d 100644
--- a/x11-misc/synaptics/ChangeLog
+++ b/x11-misc/synaptics/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/synaptics
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/synaptics/ChangeLog,v 1.42 2005/07/22 23:23:12 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/synaptics/ChangeLog,v 1.43 2005/07/25 18:09:09 battousai Exp $
+
+ 25 Jul 2005; Bryan Stine <battousai@gentoo.org>
+ +files/synaptics-0.14.x-gcc4-the-sentinels-have-attacked.patch,
+ synaptics-0.14.1.ebuild, synaptics-0.14.2.ebuild, synaptics-0.14.3.ebuild:
+ Add patch to backport X sentinel code into included headers. Thanks to
+ Christoph Brill for posting the patch. Closes bug #100134.
22 Jul 2005; Bryan Stine <battousai@gentoo.org> synaptics-0.14.1.ebuild,
synaptics-0.14.2.ebuild, synaptics-0.14.3.ebuild:
diff --git a/x11-misc/synaptics/Manifest b/x11-misc/synaptics/Manifest
index d662e3293f08..090e5cd7891e 100644
--- a/x11-misc/synaptics/Manifest
+++ b/x11-misc/synaptics/Manifest
@@ -1,10 +1,11 @@
-MD5 37c1f9e15607ec3a521205ce5fd859de ChangeLog 7664
+MD5 a206dc73dc4969c0d12527188a8419cc ChangeLog 7992
MD5 1cb923bfa5e7e99ae6804f147a1c730c metadata.xml 164
-MD5 be8f88fd556395e169214e4dffb60782 synaptics-0.14.2.ebuild 1872
-MD5 aabad7e693de1cbbe3605ce8822c1fef synaptics-0.14.1.ebuild 1872
-MD5 50f4c24a798e9cb5d9638454f21e73bf synaptics-0.14.3.ebuild 1873
+MD5 d2d6066cd7caf3ca537ccad3dc9647c1 synaptics-0.14.2.ebuild 1945
+MD5 f7a1a2b855a0d4c76970cb7ac4a2ecd0 synaptics-0.14.1.ebuild 1945
+MD5 f978563501bf1b595e2fa15e7301d83f synaptics-0.14.3.ebuild 1946
MD5 f2c16c935f2447340a41eb72bb137f57 files/digest-synaptics-0.14.3 69
MD5 595f2c641792adda7a9f78f547a3f98b files/digest-synaptics-0.14.1 69
MD5 e46163bec0b3237d0d7e371b767cd077 files/rc.conf 329
MD5 6fd019ebb1dd7433d16845d73595f81b files/rc.init 440
MD5 b18951d106b4ce580ac6177b199cf712 files/digest-synaptics-0.14.2 69
+MD5 f2c484f02a746852ee1295ca1f092e8d files/synaptics-0.14.x-gcc4-the-sentinels-have-attacked.patch 538
diff --git a/x11-misc/synaptics/files/synaptics-0.14.x-gcc4-the-sentinels-have-attacked.patch b/x11-misc/synaptics/files/synaptics-0.14.x-gcc4-the-sentinels-have-attacked.patch
new file mode 100644
index 000000000000..c8d34ef6ebfb
--- /dev/null
+++ b/x11-misc/synaptics/files/synaptics-0.14.x-gcc4-the-sentinels-have-attacked.patch
@@ -0,0 +1,16 @@
+--- Xincludes/usr/X11R6/include/X11/Xfuncproto.h.orig 2005-07-02 12:50:40.000000000 +0200
++++ Xincludes/usr/X11R6/include/X11/Xfuncproto.h 2005-07-25 08:13:46.000000000 +0200
+@@ -69,4 +69,12 @@
+ #endif
+ #endif /* _XFUNCPROTOBEGIN */
+
++#if defined(__GNUC__) && (__GNUC__ >= 4)
++# define _X_SENTINEL(x) __attribute__ ((__sentinel__(x)))
++# define _X_ATTRIBUTE_PRINTF(x,y) __attribute__((__format__(__printf__,x,y)))
++#else
++# define _X_SENTINEL(x)
++# define _X_ATTRIBUTE_PRINTF(x,y)
++#endif /* GNUC >= 4 */
++
+ #endif /* _XFUNCPROTO_H_ */
+
diff --git a/x11-misc/synaptics/synaptics-0.14.1.ebuild b/x11-misc/synaptics/synaptics-0.14.1.ebuild
index 8cf2ae8e5b1b..a19f9413fecd 100644
--- a/x11-misc/synaptics/synaptics-0.14.1.ebuild
+++ b/x11-misc/synaptics/synaptics-0.14.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/synaptics/synaptics-0.14.1.ebuild,v 1.5 2005/07/22 23:23:12 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/synaptics/synaptics-0.14.1.ebuild,v 1.6 2005/07/25 18:09:09 battousai Exp $
inherit toolchain-funcs eutils
@@ -19,6 +19,8 @@ src_unpack() {
cd ${S}
+ epatch ${FILESDIR}/${PN}-0.14.x-gcc4-the-sentinels-have-attacked.patch
+
# Put stuff into /usr, also switch up the CC and CFLAGS stuff.
sed -i -e "s:BINDIR = \\\$(DESTDIR)/usr/local/bin:BINDIR = ${D}/usr/bin:g" ${S}/Makefile
sed -i -e "s:CC = gcc:CC = $(tc-getCC):g" ${S}/Makefile
diff --git a/x11-misc/synaptics/synaptics-0.14.2.ebuild b/x11-misc/synaptics/synaptics-0.14.2.ebuild
index 8f17650c0029..aac0fa9d185a 100644
--- a/x11-misc/synaptics/synaptics-0.14.2.ebuild
+++ b/x11-misc/synaptics/synaptics-0.14.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/synaptics/synaptics-0.14.2.ebuild,v 1.4 2005/07/22 23:23:12 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/synaptics/synaptics-0.14.2.ebuild,v 1.5 2005/07/25 18:09:09 battousai Exp $
inherit toolchain-funcs eutils
@@ -19,6 +19,8 @@ src_unpack() {
cd ${S}
+ epatch ${FILESDIR}/${PN}-0.14.x-gcc4-the-sentinels-have-attacked.patch
+
# Put stuff into /usr, also switch up the CC and CFLAGS stuff.
sed -i -e "s:BINDIR = \\\$(DESTDIR)/usr/local/bin:BINDIR = ${D}/usr/bin:g" ${S}/Makefile
sed -i -e "s:CC = gcc:CC = $(tc-getCC):g" ${S}/Makefile
diff --git a/x11-misc/synaptics/synaptics-0.14.3.ebuild b/x11-misc/synaptics/synaptics-0.14.3.ebuild
index 0ec5f32ab60d..407c5fced1f9 100644
--- a/x11-misc/synaptics/synaptics-0.14.3.ebuild
+++ b/x11-misc/synaptics/synaptics-0.14.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/synaptics/synaptics-0.14.3.ebuild,v 1.3 2005/07/22 23:23:12 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/synaptics/synaptics-0.14.3.ebuild,v 1.4 2005/07/25 18:09:09 battousai Exp $
inherit toolchain-funcs eutils
@@ -19,6 +19,8 @@ src_unpack() {
cd ${S}
+ epatch ${FILESDIR}/${PN}-0.14.x-gcc4-the-sentinels-have-attacked.patch
+
# Put stuff into /usr, also switch up the CC and CFLAGS stuff.
sed -i -e "s:BINDIR = \\\$(DESTDIR)/usr/local/bin:BINDIR = ${D}/usr/bin:g" ${S}/Makefile
sed -i -e "s:CC = gcc:CC = $(tc-getCC):g" ${S}/Makefile