summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-12-23 01:25:26 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-12-23 01:25:26 +0000
commit7d3f4a269d76007895f70072e79cf9f436a2e7ca (patch)
treec89401b339762e9e7f0767d356a95b29dcf80b78 /x11-misc/ttmkfdir
parentChanged SRC_URI and added new version (diff)
downloadhistorical-7d3f4a269d76007895f70072e79cf9f436a2e7ca.tar.gz
historical-7d3f4a269d76007895f70072e79cf9f436a2e7ca.tar.bz2
historical-7d3f4a269d76007895f70072e79cf9f436a2e7ca.zip
fix bork on FIRSTINDEX
Diffstat (limited to 'x11-misc/ttmkfdir')
-rw-r--r--x11-misc/ttmkfdir/ChangeLog8
-rw-r--r--x11-misc/ttmkfdir/files/digest-ttmkfdir-2.0-r11
-rw-r--r--x11-misc/ttmkfdir/files/ttmkfdir2-ignore-FIRSTINDEX.patch11
-rw-r--r--x11-misc/ttmkfdir/ttmkfdir-2.0-r1.ebuild45
4 files changed, 64 insertions, 1 deletions
diff --git a/x11-misc/ttmkfdir/ChangeLog b/x11-misc/ttmkfdir/ChangeLog
index b7f6a207c584..b178d66e4a3b 100644
--- a/x11-misc/ttmkfdir/ChangeLog
+++ b/x11-misc/ttmkfdir/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/ttmkfdir
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/ttmkfdir/ChangeLog,v 1.7 2002/12/13 11:00:54 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/ttmkfdir/ChangeLog,v 1.8 2002/12/23 01:25:26 azarah Exp $
+
+*ttmkfdir-2.0-r1 (23 Dec 2002)
+
+ 23 Dec 2002; Martin Schlemmer <azarah@gentoo.org> ttmkfdir-2.0-r1.ebuild :
+
+ Fix ttmkfdir to ignore FIRSTINDEX it usually borks on.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/x11-misc/ttmkfdir/files/digest-ttmkfdir-2.0-r1 b/x11-misc/ttmkfdir/files/digest-ttmkfdir-2.0-r1
new file mode 100644
index 000000000000..0ba4ef3c4b91
--- /dev/null
+++ b/x11-misc/ttmkfdir/files/digest-ttmkfdir-2.0-r1
@@ -0,0 +1 @@
+MD5 61efb004b19befdb5335ef058323002c ttmkfdir2-1.0.tar.bz2 16650
diff --git a/x11-misc/ttmkfdir/files/ttmkfdir2-ignore-FIRSTINDEX.patch b/x11-misc/ttmkfdir/files/ttmkfdir2-ignore-FIRSTINDEX.patch
new file mode 100644
index 000000000000..c2652966e6a1
--- /dev/null
+++ b/x11-misc/ttmkfdir/files/ttmkfdir2-ignore-FIRSTINDEX.patch
@@ -0,0 +1,11 @@
+--- ttmkfdir2/encoding.l.orig 2002-12-23 03:22:27.000000000 +0200
++++ ttmkfdir2/encoding.l 2002-12-23 03:28:39.000000000 +0200
+@@ -167,7 +167,7 @@
+ }
+
+ [[:alnum:]]+ {
+- if (YY_START != INSIDE_UNKNOWN_MAP) {
++ if ((YY_START != INSIDE_UNKNOWN_MAP) && (0 != strcmp(yytext,"FIRSTINDEX"))) {
+ std::cerr << "unexpected token " << yytext << " in file " <<
+ current_file << ", line " << line_number << std::endl;
+ switch (YY_START) {
diff --git a/x11-misc/ttmkfdir/ttmkfdir-2.0-r1.ebuild b/x11-misc/ttmkfdir/ttmkfdir-2.0-r1.ebuild
new file mode 100644
index 000000000000..5aeb04873587
--- /dev/null
+++ b/x11-misc/ttmkfdir/ttmkfdir-2.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/ttmkfdir/ttmkfdir-2.0-r1.ebuild,v 1.1 2002/12/23 01:25:26 azarah Exp $
+
+IUSE=""
+
+inherit eutils
+
+S="${WORKDIR}/${PN}2"
+DESCRIPTION="A utility to create a fonts.scale file from a set of TrueType fonts"
+SRC_URI="mirror://gentoo/ttmkfdir2-1.0.tar.bz2"
+HOMEPAGE="http://www.joerg-pommnitz.de/TrueType/xfsft.html"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86 sparc ppc alpha"
+
+DEPEND=">=media-libs/freetype-2.0.8
+ >=sys-devel/flex-2.5.4a-r5
+ sys-devel/libtool"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.patch
+
+ # Fix ttmkfdir to ignore FIRSTINDEX it usually borks on.
+ # <azarah@gentoo.org> (23 Dec 2002)
+ epatch ${FILESDIR}/${PN}2-ignore-FIRSTINDEX.patch
+
+ cp ${S}/Makefile ${S}/Makefile.orig
+ sed -e "s:CXXFLAGS=-Wall:CXXFLAGS=${CFLAGS} -Wall:" \
+ ${S}/Makefile.orig > ${S}/Makefile
+}
+
+src_compile() {
+ make OPT="${CFLAGS}" || die
+}
+
+src_install() {
+ exeinto /usr/X11R6/bin
+ doexe ${S}/ttmkfdir
+}
+