summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-12-15 22:23:33 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-12-15 22:23:33 +0000
commit45dbdd491b452bdcb0b7a1c8962310768ad8e259 (patch)
treecf2915b4c57b60761f0a323bf79bd05a3d59c3c4 /x11-misc/xcalendar
parentChanged the pcmcia init script name, which required a minor edit to all pcmci... (diff)
downloadhistorical-45dbdd491b452bdcb0b7a1c8962310768ad8e259.tar.gz
historical-45dbdd491b452bdcb0b7a1c8962310768ad8e259.tar.bz2
historical-45dbdd491b452bdcb0b7a1c8962310768ad8e259.zip
new package
Diffstat (limited to 'x11-misc/xcalendar')
-rw-r--r--x11-misc/xcalendar/ChangeLog11
-rw-r--r--x11-misc/xcalendar/files/digest-xcalendar-4.01
-rw-r--r--x11-misc/xcalendar/files/xcalendar-4.0-motif-gentoo.diff26
-rw-r--r--x11-misc/xcalendar/xcalendar-4.0.ebuild42
4 files changed, 80 insertions, 0 deletions
diff --git a/x11-misc/xcalendar/ChangeLog b/x11-misc/xcalendar/ChangeLog
new file mode 100644
index 000000000000..4da3df1be069
--- /dev/null
+++ b/x11-misc/xcalendar/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-misc/xcalendar
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xcalendar/ChangeLog,v 1.1 2002/12/15 22:23:33 seemant Exp $
+
+*xcalendar-4.0 (15 Dec 2002)
+
+ 15 Dec 2002; Seemant Kulleen <seemant@gentoo.org> xcalendar-4.0.ebuild
+ files/xcalendar-4.0-motif-gentoo.diff files/digest-xcalendar-4.0 ChangeLog :
+
+ New package which is an interactive calendar/notepad. Submitted by:
+ scott@lampert.org (Scott Lampert) in bug #11255.
diff --git a/x11-misc/xcalendar/files/digest-xcalendar-4.0 b/x11-misc/xcalendar/files/digest-xcalendar-4.0
new file mode 100644
index 000000000000..10cdcad3783b
--- /dev/null
+++ b/x11-misc/xcalendar/files/digest-xcalendar-4.0
@@ -0,0 +1 @@
+MD5 88a642ccb00d419068b43c1f6f1949c8 xcalendar-4.0+i18n.tar.gz 48635
diff --git a/x11-misc/xcalendar/files/xcalendar-4.0-motif-gentoo.diff b/x11-misc/xcalendar/files/xcalendar-4.0-motif-gentoo.diff
new file mode 100644
index 000000000000..a35d98bcb814
--- /dev/null
+++ b/x11-misc/xcalendar/files/xcalendar-4.0-motif-gentoo.diff
@@ -0,0 +1,26 @@
+--- xcalendar.orig/Imakefile Sat Sep 30 20:19:17 1995
++++ xcalendar/Imakefile Tue Aug 20 08:37:48 2002
+@@ -1,18 +1,18 @@
+ XCALENDAR_LIBDIR = $(LIBDIR)/xcalendar
+ LIBFILES = larrow.xbm qmark.xbm quit.xbm rarrow.xbm xcalendar.hlp
+ # Comment out the following two lines for the Motif version
+-LOCAL_LIBRARIES = $(XAWLIB) $(XMULIB) $(XTOOLLIB) $(XLIB)
+- EXTRA_DEFINES = -DATHENA
++#LOCAL_LIBRARIES = $(XAWLIB) $(XMULIB) $(XTOOLLIB) $(XLIB)
++# EXTRA_DEFINES = -DATHENA
+ # Uncomment the following two lines for the Motif version
+-# LOCAL_LIBRARIES = -L/usr/local/Motif/lib -lXm $(XMULIB) $(XTOOLLIB) $(XLIB)
+-# EXTRA_DEFINES = -I/usr/local/Motif/include
++ LOCAL_LIBRARIES = -lXm $(XMULIB) $(XTOOLLIB) $(XLIB)
++ EXTRA_DEFINES =
+ SRCS = xcalendar.c dayeditor.c lists.c
+ OBJS = xcalendar.o dayeditor.o lists.o
+
+ #
+ # for Internationalization
+ #
+-EXTRA_DEFINES = -DXI18N -DATHENA
++#EXTRA_DEFINES = -DXI18N -DATHENA
+ ##if !SharedLibXwchar
+ # _UseCat($(USRLIBDIR),$(CONTRIBSRC)/lib/Xwchar,/libXwchar.a)
+ # XWCHARLIB = LoaderLibPrefix _Use(-lXwchar,$(DEPXWCHARLIB))
diff --git a/x11-misc/xcalendar/xcalendar-4.0.ebuild b/x11-misc/xcalendar/xcalendar-4.0.ebuild
new file mode 100644
index 000000000000..2c4368dfdd26
--- /dev/null
+++ b/x11-misc/xcalendar/xcalendar-4.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xcalendar/xcalendar-4.0.ebuild,v 1.1 2002/12/15 22:23:33 seemant Exp $
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="A simple interactive calendar program with a notebook capability"
+HOMEPAGE="http://www.freebsd.org/"
+SRC_URI="ftp://daemon.jp.FreeBSD.org/pub/FreeBSD-jp/ports-jp/LOCAL_PORTS/${P}+i18n.tar.gz"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86"
+
+DEPEND="virtual/x11
+ x11-libs/xaw
+ motif? ( >=x11-libs/openmotif-2.2.1 )"
+
+src_compile() {
+
+ if use motif
+ then
+ patch -p1 < ${FILESDIR}/${P}-motif-gentoo.diff || die
+ fi
+ xmkmf -a
+ emake || die
+}
+
+src_install () {
+
+ dobin xcalendar
+ newman xcalendar.man xcalendar.1
+
+ dodir /etc/X11/app-defaults
+ sed 's;%%XCALENDAR_LIBDIR%%;/usr/lib/xcalendar;
+ s;/usr/local/X11R5/lib/X11/;/usr/lib/;' \
+ < XCalendar.sed > ${D}/etc/X11/app-defaults/XCalendar || die
+
+ insinto /usr/lib/xcalendar
+ doins *.xbm *.hlp
+
+ dodoc README
+}