summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-02-17 00:32:42 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-02-17 00:32:42 +0000
commiteddcff43780778231b4611e38a39671af90b1312 (patch)
treec44d205d6d7f300a90f1ec784e4999627a72f200 /x11-misc/xstroke
parentnew ebuild (diff)
downloadhistorical-eddcff43780778231b4611e38a39671af90b1312.tar.gz
historical-eddcff43780778231b4611e38a39671af90b1312.tar.bz2
historical-eddcff43780778231b4611e38a39671af90b1312.zip
Fixed freetype compile errors. Fixes #15494.
Diffstat (limited to 'x11-misc/xstroke')
-rw-r--r--x11-misc/xstroke/ChangeLog8
-rw-r--r--x11-misc/xstroke/xstroke-0.5.12.ebuild14
2 files changed, 12 insertions, 10 deletions
diff --git a/x11-misc/xstroke/ChangeLog b/x11-misc/xstroke/ChangeLog
index 077f63a73566..7b7a581ce7a5 100644
--- a/x11-misc/xstroke/ChangeLog
+++ b/x11-misc/xstroke/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for x11-misc/xstroke
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xstroke/ChangeLog,v 1.5 2003/02/12 09:34:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xstroke/ChangeLog,v 1.6 2003/02/17 00:32:42 liquidx Exp $
*xstroke-0.5.12 (31 May 2002)
-
+
+ 17 Feb 2003; Alastair Tse <liquidx@gentoo.org> :
+
+ Eliminated the need for patch and fixed freetype header problems (#15494).
+
11 Feb 2003; Seemant Kulleen <seemant@gentoo.org> :
Moved the patch to a patchball on the mirrors and out of files/
diff --git a/x11-misc/xstroke/xstroke-0.5.12.ebuild b/x11-misc/xstroke/xstroke-0.5.12.ebuild
index 4341afff9388..1e11335eac43 100644
--- a/x11-misc/xstroke/xstroke-0.5.12.ebuild
+++ b/x11-misc/xstroke/xstroke-0.5.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xstroke/xstroke-0.5.12.ebuild,v 1.7 2003/02/11 13:00:40 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xstroke/xstroke-0.5.12.ebuild,v 1.8 2003/02/17 00:32:42 liquidx Exp $
inherit eutils
@@ -9,10 +9,7 @@ IUSE=""
S=${WORKDIR}/${P}
DESCRIPTION="Gesture/Handwriting recognition engine for X"
HOMEPAGE="http://www.east.isi.edu/projects/DSN/xstroke/"
-SRC_URI="ftp://ftp.handhelds.org/pub/projects/${PN}/release-0.5/${P}.tar.gz
- mirror://gentoo/${P}-gentoo.diff.bz2
- http://cvs.gentoo.org/~seemant/${P}-gentoo.diff.bz2"
-
+SRC_URI="ftp://ftp.handhelds.org/pub/projects/${PN}/release-0.5/${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 sparc"
@@ -20,13 +17,14 @@ KEYWORDS="x86 sparc"
DEPEND=">=x11-base/xfree-4.1.0"
src_unpack() {
- cd ${WORKDIR}
unpack ${A}
- epatch ${WORKDIR}/${P}-gentoo.diff
+ # generate Makefile from Imakefile
+ cd ${S}; xmkmf -a
}
src_compile() {
- make DESTDIR=${D} || die
+ # otherwise it'll include the wrong freetype headers.
+ make INCLUDES="-I/usr/include/freetype2" || die
}
src_install() {