summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gardiner <obz@gentoo.org>2003-09-28 05:25:02 +0000
committerMike Gardiner <obz@gentoo.org>2003-09-28 05:25:02 +0000
commitfeb2cfec2f520d56eb44e050885f49e1afa5c67e (patch)
treef51ef5102d8a9d73d9fc14e712596baa697ffcf5 /x11-plugins/desklet-cpuinfo/desklet-cpuinfo-0.1.4-r1.ebuild
parentUpdated dependencies to -core-0.22 (diff)
downloadhistorical-feb2cfec2f520d56eb44e050885f49e1afa5c67e.tar.gz
historical-feb2cfec2f520d56eb44e050885f49e1afa5c67e.tar.bz2
historical-feb2cfec2f520d56eb44e050885f49e1afa5c67e.zip
Updated dependencies to -core-0.22
Diffstat (limited to 'x11-plugins/desklet-cpuinfo/desklet-cpuinfo-0.1.4-r1.ebuild')
-rw-r--r--x11-plugins/desklet-cpuinfo/desklet-cpuinfo-0.1.4-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/x11-plugins/desklet-cpuinfo/desklet-cpuinfo-0.1.4-r1.ebuild b/x11-plugins/desklet-cpuinfo/desklet-cpuinfo-0.1.4-r1.ebuild
new file mode 100644
index 000000000000..9a7df63b95b8
--- /dev/null
+++ b/x11-plugins/desklet-cpuinfo/desklet-cpuinfo-0.1.4-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/desklet-cpuinfo/desklet-cpuinfo-0.1.4-r1.ebuild,v 1.1 2003/09/28 05:24:49 obz Exp $
+
+SENS_NAME="CPU"
+DISP_NAME="info"
+
+SENS_P=${SENS_NAME}-${PV}
+DISP_P=${DISP_NAME}-${PV}
+
+DESCRIPTION="A CPU Monitor Sensor and Display for gDesklets"
+SRC_URI="http://gdesklets.gnomedesktop.org/files/${SENS_P}.tar.bz2 \
+ http://gdesklets.gnomedesktop.org/files/${DISP_P}.tar.bz2"
+HOMEPAGE="http://www.pycage.de/"
+LICENSE="as-is"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86"
+
+DEPEND=">=gnome-extra/gdesklets-core-0.22"
+
+# unfortunately, these are usually dependent on the particular
+# desklet and it's packager
+DOCS="README ChangeLog"
+
+SENS_S=${WORKDIR}/${SENS_P}
+DISP_S=${WORKDIR}
+
+src_install( ) {
+
+ # set up our paths
+ SYS_PATH="/usr/share/gdesklets"
+ INSTALL_BIN="Install_${SENS_NAME}_Sensor.bin"
+ dodir ${SYS_PATH}/{Sensors,Displays}
+
+ # first we install the Sensor
+ cd ${SENS_S}
+ python ${INSTALL_BIN} --nomsg ${D}${SYS_PATH}/Sensors
+ # and the docs
+ dodoc ${DOCS}
+
+ # and now the display
+ cd ${DISP_S}
+ dodir ${SYS_PATH}/Displays/${DISP_NAME}/{dark,light}-theme
+ # this one include both 'light' and 'dark' themed displays
+ cp -R dark-theme/{${DISP_NAME}.display,gfx/} \
+ ${D}${SYS_PATH}/Displays/${DISP_NAME}/dark-theme
+ cp -R light-theme/{${DISP_NAME}.display,gfx/} \
+ ${D}${SYS_PATH}/Displays/${DISP_NAME}/light-theme
+
+}
+