summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-10-30 23:42:55 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-10-30 23:42:55 +0000
commit8b75b873528331d2afd08d5f062dbf5c8449e053 (patch)
tree49af81f5aa7fb289bd8d302b823782a7cb15a282 /x11-plugins/gkrellstock
parentRemoved lintool. It is superceded by dev-util/lintool (diff)
downloadhistorical-8b75b873528331d2afd08d5f062dbf5c8449e053.tar.gz
historical-8b75b873528331d2afd08d5f062dbf5c8449e053.tar.bz2
historical-8b75b873528331d2afd08d5f062dbf5c8449e053.zip
gkrellm stock ticker plugin
Diffstat (limited to 'x11-plugins/gkrellstock')
-rw-r--r--x11-plugins/gkrellstock/ChangeLog18
-rw-r--r--x11-plugins/gkrellstock/files/digest-gkrellstock-0.41
-rw-r--r--x11-plugins/gkrellstock/files/digest-gkrellstock-0.51
-rw-r--r--x11-plugins/gkrellstock/gkrellstock-0.4.ebuild28
-rw-r--r--x11-plugins/gkrellstock/gkrellstock-0.5.ebuild28
5 files changed, 76 insertions, 0 deletions
diff --git a/x11-plugins/gkrellstock/ChangeLog b/x11-plugins/gkrellstock/ChangeLog
new file mode 100644
index 000000000000..9398cbbe912f
--- /dev/null
+++ b/x11-plugins/gkrellstock/ChangeLog
@@ -0,0 +1,18 @@
+# ChangeLog for x11-plugins/gkrellstock
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellstock/ChangeLog,v 1.1 2002/10/30 23:42:55 seemant Exp $
+
+*gkrellstock-0.5 (30 Oct 2002)
+
+ 30 Oct 2002; Seemant Kulleen <seemant@gentoo.org> gkrellstock-0.5.ebuild
+ ChangeLog files/digest-gkrellstock-0.5 :
+
+ GKrellM2 plugin to retrieve stock quotes from Yahoo! Finance website.
+ Thanks to: Gustavo Felisberto <gustavo@felisberto.net> in bug #8926.
+
+*gkrellstock-0.4 (30 Oct 2002)
+
+ 30 Oct 2002; Seemant Kulleen <seemant@gentoo.org> gkrellstock-0.4.ebuild
+ files/digest-gkrellstock-0.4 :
+
+ Version for gkrellm-1.2 added by me :)
diff --git a/x11-plugins/gkrellstock/files/digest-gkrellstock-0.4 b/x11-plugins/gkrellstock/files/digest-gkrellstock-0.4
new file mode 100644
index 000000000000..19e472cff546
--- /dev/null
+++ b/x11-plugins/gkrellstock/files/digest-gkrellstock-0.4
@@ -0,0 +1 @@
+MD5 ab13ade7287756cdfcfda0e2eea0c512 gkrellstock-0.4.tar.gz 22188
diff --git a/x11-plugins/gkrellstock/files/digest-gkrellstock-0.5 b/x11-plugins/gkrellstock/files/digest-gkrellstock-0.5
new file mode 100644
index 000000000000..3055cb2dfa31
--- /dev/null
+++ b/x11-plugins/gkrellstock/files/digest-gkrellstock-0.5
@@ -0,0 +1 @@
+MD5 e3056d555fd434bd5038434a5b344c80 gkrellstock-0.5.tar.gz 22332
diff --git a/x11-plugins/gkrellstock/gkrellstock-0.4.ebuild b/x11-plugins/gkrellstock/gkrellstock-0.4.ebuild
new file mode 100644
index 000000000000..1b01baeafc18
--- /dev/null
+++ b/x11-plugins/gkrellstock/gkrellstock-0.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellstock/gkrellstock-0.4.ebuild,v 1.1 2002/10/30 23:42:55 seemant Exp $
+
+S=${WORKDIR}/${P/s/S}
+DESCRIPTION="Get Stock quotes plugin for GKrellM"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://gkrellstock.sourceforge.net/"
+
+DEPEND="=app-admin/gkrellm-1*
+ dev-perl/libwww-perl
+ dev-perl/Finance-Quote"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 sparc sparc64"
+
+src_compile() {
+ emake || die
+}
+
+src_install () {
+ insinto /usr/lib/gkrellm/plugins
+ doins gkrellstock.so
+ exeinto /usr/X11R6/bin
+ doexe GetQuote
+ dodoc README ChangeLog COPYING
+}
diff --git a/x11-plugins/gkrellstock/gkrellstock-0.5.ebuild b/x11-plugins/gkrellstock/gkrellstock-0.5.ebuild
new file mode 100644
index 000000000000..fa55c4f2f1c4
--- /dev/null
+++ b/x11-plugins/gkrellstock/gkrellstock-0.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellstock/gkrellstock-0.5.ebuild,v 1.1 2002/10/30 23:42:55 seemant Exp $
+
+S=${WORKDIR}/${P/s/S}
+DESCRIPTION="Get Stock quotes plugin for Gkrellm2"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://gkrellstock.sourceforge.net/"
+
+DEPEND=">=app-admin/gkrellm-2*
+ dev-perl/libwww-perl
+ dev-perl/Finance-Quote"
+
+SLOT="2"
+LICENSE="GPL-2"
+KEYWORDS="x86 sparc sparc64"
+
+src_compile() {
+ emake || die
+}
+
+src_install () {
+ insinto /usr/lib/gkrellm2/plugins
+ doins gkrellstock.so
+ exeinto /usr/X11R6/bin
+ doexe GetQuote2
+ dodoc README ChangeLog COPYING
+}