summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-02-12 10:56:18 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-02-12 10:56:18 +0000
commit9925455a0b18a5be4ac14100d44d6626abe64d91 (patch)
tree2fd1fdd6098ce56518120afe5b974f26be647190 /x11-plugins/i8krellm
parentinitial import (diff)
downloadhistorical-9925455a0b18a5be4ac14100d44d6626abe64d91.tar.gz
historical-9925455a0b18a5be4ac14100d44d6626abe64d91.tar.bz2
historical-9925455a0b18a5be4ac14100d44d6626abe64d91.zip
gkrellm/gkrellm2 plugin for dell lappies
Diffstat (limited to 'x11-plugins/i8krellm')
-rw-r--r--x11-plugins/i8krellm/ChangeLog12
-rw-r--r--x11-plugins/i8krellm/files/digest-i8krellm-2.21
-rw-r--r--x11-plugins/i8krellm/i8krellm-2.2.ebuild49
3 files changed, 62 insertions, 0 deletions
diff --git a/x11-plugins/i8krellm/ChangeLog b/x11-plugins/i8krellm/ChangeLog
new file mode 100644
index 000000000000..b84b8ca6bf4a
--- /dev/null
+++ b/x11-plugins/i8krellm/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for x11-plugins/i8krellm
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/i8krellm/ChangeLog,v 1.1 2003/02/12 10:56:18 seemant Exp $
+
+*i8krellm-2.2 (12 Feb 2003)
+
+ 12 Feb 2003; Seemant Kulleen <seemant@gentoo.org> i8krellm-2.2.ebuild
+ ChangeLog files/digest-i8krellm-2.2 :
+
+ New GKrellM/GKrellM2 plugin for Dell Inspiron and Dell Latitude laptops
+ to control fans and monitor temperatures. Ebuild by: Christoph Hornung
+ <hornung@cs.tu-berlin.de> in bug #13715.
diff --git a/x11-plugins/i8krellm/files/digest-i8krellm-2.2 b/x11-plugins/i8krellm/files/digest-i8krellm-2.2
new file mode 100644
index 000000000000..df8a167425c3
--- /dev/null
+++ b/x11-plugins/i8krellm/files/digest-i8krellm-2.2
@@ -0,0 +1 @@
+MD5 52a2ad0f8418fc2e17f439a136be90e6 i8krellm-2.2.tar.gz 14596
diff --git a/x11-plugins/i8krellm/i8krellm-2.2.ebuild b/x11-plugins/i8krellm/i8krellm-2.2.ebuild
new file mode 100644
index 000000000000..42dfe747ad38
--- /dev/null
+++ b/x11-plugins/i8krellm/i8krellm-2.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/i8krellm/i8krellm-2.2.ebuild,v 1.1 2003/02/12 10:56:18 seemant Exp $
+
+IUSE="gtk2"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GKrellM2 Plugin for the Dell Inspiron and Latitude notebooks"
+SRC_URI="http://www.coding-zone.com/${P}.tar.gz"
+HOMEPAGE="http://www.coding-zone.com/i8krellm.phtml"
+
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="~x86 -ppc -sparc -alpha -mips -hppa"
+
+DEPEND="app-admin/gkrellm
+ x11-libs/gtk+
+ gtk2? ( =x11-libs/gtk+-2*
+ =app-admin/gkrellm-2* )
+ >=sys-apps/i8kutils-1.5"
+
+src_compile() {
+
+ if [ -f /usr/bin/gkrellm ]
+ then
+ emake || die
+ fi
+
+ if [ -f /usr/bin/gkrellm2 ]
+ then
+ emake i8krellm2 || die
+ fi
+}
+
+src_install () {
+
+ if [ -f /usr/bin/gkrellm ]
+ then
+ insinto /usr/lib/gkrellm/plugins
+ doins i8krellm.so
+ fi
+
+ if [ -f /usr/bin/gkrellm2 ]
+ then
+ insinto /usr/lib/gkrellm2/plugins
+ doins i8krellm2.so
+ fi
+ dodoc README Changelog AUTHORS
+}