summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-12-05 11:14:49 +0000
committerPeter Volkov <pva@gentoo.org>2010-12-05 11:14:49 +0000
commit44e5363157596824fb26dd58ccba577bb2381191 (patch)
treedb929d3225ba1643dfdb0bda6cb75a5b9a02ec32 /x11-plugins/pidgin-latex/pidgin-latex-1.4.3.ebuild
parentadd removed upstream bug url (diff)
downloadhistorical-44e5363157596824fb26dd58ccba577bb2381191.tar.gz
historical-44e5363157596824fb26dd58ccba577bb2381191.tar.bz2
historical-44e5363157596824fb26dd58ccba577bb2381191.zip
Version bump, bug #347689 thank keenblade for report.
Package-Manager: portage-2.1.9.25/cvs/Linux x86_64
Diffstat (limited to 'x11-plugins/pidgin-latex/pidgin-latex-1.4.3.ebuild')
-rw-r--r--x11-plugins/pidgin-latex/pidgin-latex-1.4.3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-latex/pidgin-latex-1.4.3.ebuild b/x11-plugins/pidgin-latex/pidgin-latex-1.4.3.ebuild
new file mode 100644
index 000000000000..a0f85b3f47a6
--- /dev/null
+++ b/x11-plugins/pidgin-latex/pidgin-latex-1.4.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-latex/pidgin-latex-1.4.3.ebuild,v 1.1 2010/12/05 11:14:49 pva Exp $
+
+EAPI="2"
+inherit multilib toolchain-funcs
+
+MY_P=${PN}_${PV}
+
+DESCRIPTION="Pidgin plugin that renders latex formulae"
+HOMEPAGE="http://sourceforge.net/projects/pidgin-latex"
+SRC_URI="mirror://sourceforge/pidgin-latex/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+COMMON_DEPEND="net-im/pidgin[gtk]
+ x11-libs/gtk+:2"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/libtool
+ dev-util/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ app-text/dvipng"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -e "s:\(CC.*=\).*:\1 $(tc-getCC):" \
+ -e "/LIB_INSTALL_DIR/{s:/lib/pidgin:/$(get_libdir)/pidgin:;}" \
+ -i Makefile || die
+}
+
+src_install() {
+ make PREFIX="${D}/usr" install || die "make install failed"
+ dodoc README CHANGELOG TODO || die
+}
+
+pkg_postinst() {
+ elog 'Note, to see formulas either disable "Conversation Colors" plugin or'
+ elog 'switch off "ignore incoming format" option in plugin configuration.'
+ elog 'For details, take a look (and vote) at http://developer.pidgin.im/ticket/2772'
+}