summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-10-04 18:42:58 +0000
committerNick Hadaway <raker@gentoo.org>2002-10-04 18:42:58 +0000
commitf01dbdfbbc64f76fbf00fdc9e75fe6881f026f7a (patch)
tree0715c8a54b9267082229d7abc693f1d61355791e /x11-plugins/wmtop/wmtop-0.84.ebuild
parentInitial add of ebuild to portage. (diff)
downloadhistorical-f01dbdfbbc64f76fbf00fdc9e75fe6881f026f7a.tar.gz
historical-f01dbdfbbc64f76fbf00fdc9e75fe6881f026f7a.tar.bz2
historical-f01dbdfbbc64f76fbf00fdc9e75fe6881f026f7a.zip
Initial add of ebuild to portage
Diffstat (limited to 'x11-plugins/wmtop/wmtop-0.84.ebuild')
-rw-r--r--x11-plugins/wmtop/wmtop-0.84.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-plugins/wmtop/wmtop-0.84.ebuild b/x11-plugins/wmtop/wmtop-0.84.ebuild
new file mode 100644
index 000000000000..20d5de7f7aaf
--- /dev/null
+++ b/x11-plugins/wmtop/wmtop-0.84.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtop/wmtop-0.84.ebuild,v 1.1 2002/10/04 18:42:58 raker Exp $
+
+S="${WORKDIR}/${P}"
+
+DESCRIPTION="top in a dockapp"
+HOMEPAGE="http://wmtop.sourceforge.net"
+SRC_URI="mirror://sourceforge/wmtop/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/glibc
+ virtual/x11"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+
+ cd ${S}
+ cp Makefile Makefile.orig
+ sed -e "s:-O3 -g -Wall:${CFLAGS}:" \
+ -e "s:/local::" Makefile.orig > Makefile
+
+ make linux
+
+}
+
+src_install() {
+
+ dodir /usr/bin /usr/man/man1
+ make PREFIX=${D}/usr install || die "make install failed"
+
+}