summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2007-01-22 11:15:43 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2007-01-22 11:15:43 +0000
commit584b824f9fa53cd3c9250449589ef1ca67a0291f (patch)
treeecd1528d862266ecf4ae6b472be08df87d1b9887 /x11-plugins/wmweather+/wmweather+-2.9.ebuild
parentAdd a patch for hppa and fix URL (diff)
downloadhistorical-584b824f9fa53cd3c9250449589ef1ca67a0291f.tar.gz
historical-584b824f9fa53cd3c9250449589ef1ca67a0291f.tar.bz2
historical-584b824f9fa53cd3c9250449589ef1ca67a0291f.zip
Filtered -optimize-sibling-calls out of CFLAGS, closing bug #159280.
Package-Manager: portage-2.1.1-r2
Diffstat (limited to 'x11-plugins/wmweather+/wmweather+-2.9.ebuild')
-rw-r--r--x11-plugins/wmweather+/wmweather+-2.9.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/x11-plugins/wmweather+/wmweather+-2.9.ebuild b/x11-plugins/wmweather+/wmweather+-2.9.ebuild
index f48efbd43285..5b36d9141b0a 100644
--- a/x11-plugins/wmweather+/wmweather+-2.9.ebuild
+++ b/x11-plugins/wmweather+/wmweather+-2.9.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmweather+/wmweather+-2.9.ebuild,v 1.9 2006/10/25 10:37:22 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmweather+/wmweather+-2.9.ebuild,v 1.10 2007/01/22 11:15:43 s4t4n Exp $
+
+inherit flag-o-matic
IUSE=""
DESCRIPTION="A dockapp for displaying data collected from METAR, AVN, ETA, and MRF forecasts"
@@ -16,6 +18,13 @@ DEPEND="x11-wm/windowmaker
net-libs/libwww
x11-libs/libXpm"
+src_compile() {
+ append-flags "-fno-optimize-sibling-calls"
+
+ econf || die
+ emake || die
+}
+
src_install() {
dobin wmweather+
dodoc ChangeLog HINTS README example.conf