summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-08-05 13:51:40 +0000
committerBen de Groot <yngwin@gentoo.org>2009-08-05 13:51:40 +0000
commita5398e8024c6a67c333b40da5b5f9b2ceed53869 (patch)
tree1e89078bba51ea958c68b719a8f85d96fc1baf34 /x11-themes/qtcurve-qt4
parentremoved old and broken versions of synce (diff)
downloadhistorical-a5398e8024c6a67c333b40da5b5f9b2ceed53869.tar.gz
historical-a5398e8024c6a67c333b40da5b5f9b2ceed53869.tar.bz2
historical-a5398e8024c6a67c333b40da5b5f9b2ceed53869.zip
Version bump
Package-Manager: portage-2.2_rc35/cvs/Linux x86_64
Diffstat (limited to 'x11-themes/qtcurve-qt4')
-rw-r--r--x11-themes/qtcurve-qt4/ChangeLog7
-rw-r--r--x11-themes/qtcurve-qt4/qtcurve-qt4-0.67.2.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/x11-themes/qtcurve-qt4/ChangeLog b/x11-themes/qtcurve-qt4/ChangeLog
index 6f596f3a94af..76a217c53792 100644
--- a/x11-themes/qtcurve-qt4/ChangeLog
+++ b/x11-themes/qtcurve-qt4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-themes/qtcurve-qt4
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/ChangeLog,v 1.71 2009/08/03 20:19:47 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/ChangeLog,v 1.72 2009/08/05 13:51:40 yngwin Exp $
+
+*qtcurve-qt4-0.67.2 (05 Aug 2009)
+
+ 05 Aug 2009; Ben de Groot <yngwin@gentoo.org> +qtcurve-qt4-0.67.2.ebuild:
+ Version bump
03 Aug 2009; Markus Meier <maekke@gentoo.org> qtcurve-qt4-0.65.2.ebuild:
amd64/x86 stable, bug #279585
diff --git a/x11-themes/qtcurve-qt4/qtcurve-qt4-0.67.2.ebuild b/x11-themes/qtcurve-qt4/qtcurve-qt4-0.67.2.ebuild
new file mode 100644
index 000000000000..77f17c2ae4f4
--- /dev/null
+++ b/x11-themes/qtcurve-qt4/qtcurve-qt4-0.67.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/qtcurve-qt4-0.67.2.ebuild,v 1.1 2009/08/05 13:51:40 yngwin Exp $
+
+EAPI="2"
+KDE_REQUIRED="optional"
+inherit flag-o-matic cmake-utils kde4-base
+
+MY_P="${P/qtcurve-qt4/QtCurve-KDE4}"
+DESCRIPTION="A set of widget styles for Qt4 based apps, also available for KDE3 and GTK2"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=40492"
+SRC_URI="http://home.freeuk.com/cpdrummond/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="kde"
+
+DEPEND="x11-libs/qt-gui:4[dbus]
+ kde? ( >=kde-base/kwin-4.1.0 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+DOCS="ChangeLog README TODO"
+
+src_configure() {
+ if use kde ; then
+ kde4-base_src_configure
+ else
+ mycmakeargs="-DQTC_QT_ONLY=true"
+ cmake-utils_src_configure
+ fi
+}