summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-12 14:33:30 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-12 14:33:30 +0000
commit0e7542c0d901de08076ef3c10477b2185726ee32 (patch)
treeb10bca80abbf940b5a35fdb597423046e17ac192 /x11-wm/flwm
parentSLOTified and other changes (diff)
downloadhistorical-0e7542c0d901de08076ef3c10477b2185726ee32.tar.gz
historical-0e7542c0d901de08076ef3c10477b2185726ee32.tar.bz2
historical-0e7542c0d901de08076ef3c10477b2185726ee32.zip
depends on fltk-1.0
Diffstat (limited to 'x11-wm/flwm')
-rw-r--r--x11-wm/flwm/ChangeLog8
-rw-r--r--x11-wm/flwm/files/digest-flwm-1.00-r31
-rw-r--r--x11-wm/flwm/flwm-1.00-r3.ebuild63
3 files changed, 71 insertions, 1 deletions
diff --git a/x11-wm/flwm/ChangeLog b/x11-wm/flwm/ChangeLog
index 8374bbf38715..37fcf5eca4e9 100644
--- a/x11-wm/flwm/ChangeLog
+++ b/x11-wm/flwm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/flwm
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/flwm/ChangeLog,v 1.1 2002/02/01 21:53:39 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/flwm/ChangeLog,v 1.2 2002/08/12 14:33:30 seemant Exp $
+
+*flwm-1.00-r3 (12 Aug 2002)
+
+ 12 Aug 2002; Seemant Kulleen <seemant@gentoo.org> flwm-1.00-r3.ebuild :
+
+ Made it depend explicitly on fltk-1.0
*flwm-1.00-r2 (1 Feb 2002)
diff --git a/x11-wm/flwm/files/digest-flwm-1.00-r3 b/x11-wm/flwm/files/digest-flwm-1.00-r3
new file mode 100644
index 000000000000..448d78ce713b
--- /dev/null
+++ b/x11-wm/flwm/files/digest-flwm-1.00-r3
@@ -0,0 +1 @@
+MD5 75047b2ddcac30eecfb380773177d54d flwm-1.00.tgz 61747
diff --git a/x11-wm/flwm/flwm-1.00-r3.ebuild b/x11-wm/flwm/flwm-1.00-r3.ebuild
new file mode 100644
index 000000000000..a3682c6d6356
--- /dev/null
+++ b/x11-wm/flwm/flwm-1.00-r3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/flwm/flwm-1.00-r3.ebuild,v 1.1 2002/08/12 14:33:30 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A lightweight window manager based on fltk"
+SRC_URI="http://flwm.sourceforge.net/${P}.tgz"
+HOMEPAGE="http://flwm.sourceforge.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 -ppc"
+
+
+DEPEND=">=x11-base/xfree-4.0.1
+ =x11-libs/fltk-1.0*
+ opengl? ( virtual/opengl )"
+
+ #Configuration of the appearance and behavior of flwm
+ #must be done at compile time, i.e. there is
+ #no .flwmrc file or interactive configuring while
+ #running. To quote the man page, "gcc is your friend,"
+ #so this type of configuration must be done at compile
+ #time by editing the config.h file. I can't see any
+ #way to do this automagically so we'll echo a message
+ #in pkg_postinst to tell the user to 'ebuild unpack'
+ #and edit the config.h to their liking.
+
+src_compile() {
+
+ use opengl && export X_EXTRA_LIBS=-lGL
+
+ export CXXFLAGS="${CXXFLAGS} -I/usr/include/fltk-1.0"
+ export LIBS="-L/usr/lib/fltk-1.0"
+
+ econf || die
+ make || die
+}
+
+src_install() {
+
+ doman flwm.1
+ dodoc README flwm_wmconfig
+
+ into /usr
+ dobin flwm
+}
+
+pkg_postinst() {
+
+ echo "**********************************************"
+ echo "Customization of behaviour and appearance of"
+ echo "flwm requires manually editing the config.h"
+ echo "source file. If you want to change the defaults,"
+ echo "Do the following:"
+ echo ""
+ echo "ebuild ${P}.ebuild unpack"
+ echo "${EDITOR} ${S}/config.h "
+ echo "ebuild ${P} compile install qmerge"
+ echo ""
+ echo "**********************************************"
+
+}