summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2003-07-15 14:50:53 +0000
committerHeinrich Wendel <lanius@gentoo.org>2003-07-15 14:50:53 +0000
commite1053cea07218a5f7ae27262e2d5dbbd03883bba (patch)
tree514b8c76dd85f0a301b6eaa4fc612ec7127b4c4c /x11-wm/flwm
parentfltk 1.1 patch (diff)
downloadhistorical-e1053cea07218a5f7ae27262e2d5dbbd03883bba.tar.gz
historical-e1053cea07218a5f7ae27262e2d5dbbd03883bba.tar.bz2
historical-e1053cea07218a5f7ae27262e2d5dbbd03883bba.zip
fltk 1.1 patch
Diffstat (limited to 'x11-wm/flwm')
-rw-r--r--x11-wm/flwm/Manifest4
-rw-r--r--x11-wm/flwm/files/digest-flwm-1.00-r41
-rw-r--r--x11-wm/flwm/files/fltk1.1.patch11
-rw-r--r--x11-wm/flwm/flwm-1.00-r4.ebuild62
4 files changed, 76 insertions, 2 deletions
diff --git a/x11-wm/flwm/Manifest b/x11-wm/flwm/Manifest
index 084c1a4f6666..18af9bacc2e6 100644
--- a/x11-wm/flwm/Manifest
+++ b/x11-wm/flwm/Manifest
@@ -1,7 +1,7 @@
-MD5 f2f8cd5d752fd33cc188c080b897e4cb ChangeLog 955
+MD5 ed4bb58e8fca21355f0658b08f918062 ChangeLog 955
MD5 c47c316051906a2a26918de2fbaaea14 flwm-1.00-r2.ebuild 1721
MD5 26b6d6d54fed593bd04b8a7f814e9c8a flwm-1.00-r3.ebuild 1620
-MD5 41ff3dfbd2be6e90f7294421d6046c48 flwm-1.00-r4.ebuild 1563
+MD5 e3e1ac51ea3d4d11067e610019c8e773 flwm-1.00-r4.ebuild 1657
MD5 153d0f044aec18fbaa1ea5a6ca417551 files/fltk1.1.patch 376
MD5 bcffe93a535c096964afbd7e789560d5 files/digest-flwm-1.00-r2 57
MD5 bcffe93a535c096964afbd7e789560d5 files/digest-flwm-1.00-r3 57
diff --git a/x11-wm/flwm/files/digest-flwm-1.00-r4 b/x11-wm/flwm/files/digest-flwm-1.00-r4
new file mode 100644
index 000000000000..448d78ce713b
--- /dev/null
+++ b/x11-wm/flwm/files/digest-flwm-1.00-r4
@@ -0,0 +1 @@
+MD5 75047b2ddcac30eecfb380773177d54d flwm-1.00.tgz 61747
diff --git a/x11-wm/flwm/files/fltk1.1.patch b/x11-wm/flwm/files/fltk1.1.patch
new file mode 100644
index 000000000000..12483682af7e
--- /dev/null
+++ b/x11-wm/flwm/files/fltk1.1.patch
@@ -0,0 +1,11 @@
+--- main.C 2000-09-19 10:02:51.000000000 +0200
++++ main.C.1 2003-06-30 21:27:10.000000000 +0200
+@@ -351,7 +351,7 @@
+ }
+
+ int main(int argc, char** argv) {
+- program_name = filename_name(argv[0]);
++ program_name = fl_filename_name(argv[0]);
+ int i; if (Fl::args(argc, argv, i, arg) < argc) Fl::error(
+ "options are:\n"
+ " -d[isplay] host:#.#\tX display & screen to use\n"
diff --git a/x11-wm/flwm/flwm-1.00-r4.ebuild b/x11-wm/flwm/flwm-1.00-r4.ebuild
new file mode 100644
index 000000000000..fff9da605609
--- /dev/null
+++ b/x11-wm/flwm/flwm-1.00-r4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/flwm/flwm-1.00-r4.ebuild,v 1.1 2003/07/15 14:50:40 lanius Exp $
+
+IUSE="opengl"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A lightweight window manager based on fltk"
+SRC_URI="http://flwm.sourceforge.net/${P}.tgz"
+HOMEPAGE="http://flwm.sourceforge.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 -ppc"
+
+
+DEPEND=">=x11-base/xfree-4.0.1
+ >=x11-libs/fltk-1.1*
+ opengl? ( virtual/opengl )"
+
+ #Configuration of the appearance and behavior of flwm
+ #must be done at compile time, i.e. there is
+ #no .flwmrc file or interactive configuring while
+ #running. To quote the man page, "gcc is your friend,"
+ #so this type of configuration must be done at compile
+ #time by editing the config.h file. I can't see any
+ #way to do this automagically so we'll echo a message
+ #in pkg_postinst to tell the user to 'ebuild unpack'
+ #and edit the config.h to their liking.
+
+src_compile() {
+
+ use opengl && export X_EXTRA_LIBS=-lGL
+
+ export CXXFLAGS="${CXXFLAGS} -I/usr/include/fltk-1.1"
+ export LIBS="-L/usr/lib/fltk-1.1"
+
+ epatch ${FILESDIR}/fltk1.1.patch
+
+ econf || die
+ make || die
+}
+
+src_install() {
+
+ doman flwm.1
+ dodoc README flwm_wmconfig
+
+ into /usr
+ dobin flwm
+}
+
+pkg_postinst() {
+ einfo "Customization of behaviour and appearance of"
+ einfo "flwm requires manually editing the config.h"
+ einfo "source file. If you want to change the defaults,"
+ einfo "do the following:"
+ einfo ""
+ einfo "\tebuild ${P}.ebuild unpack"
+ einfo "\t${EDITOR} ${S}/config.h "
+ einfo "\tebuild ${P} compile install qmerge"
+}