summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-07-29 01:15:09 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-07-29 01:15:09 +0000
commit40f565e117b9f321a9cd03aba7a48e399e1cdf7e (patch)
treed417c8339e6eb1e8f0133cd950ec7791741f28c1 /x11-wm/sawfish
parentupdated to 0.14, needed by sawfish 1.0 (diff)
downloadhistorical-40f565e117b9f321a9cd03aba7a48e399e1cdf7e.tar.gz
historical-40f565e117b9f321a9cd03aba7a48e399e1cdf7e.tar.bz2
historical-40f565e117b9f321a9cd03aba7a48e399e1cdf7e.zip
updated to 1.0
Diffstat (limited to 'x11-wm/sawfish')
-rw-r--r--x11-wm/sawfish/files/digest-sawfish-1.01
-rw-r--r--x11-wm/sawfish/sawfish-1.0.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/x11-wm/sawfish/files/digest-sawfish-1.0 b/x11-wm/sawfish/files/digest-sawfish-1.0
new file mode 100644
index 000000000000..6eaf123c18d7
--- /dev/null
+++ b/x11-wm/sawfish/files/digest-sawfish-1.0
@@ -0,0 +1 @@
+MD5 ad0b179620ef9d8aeea692b56ab6a302 sawfish-1.0.tar.gz
diff --git a/x11-wm/sawfish/sawfish-1.0.ebuild b/x11-wm/sawfish/sawfish-1.0.ebuild
new file mode 100644
index 000000000000..b999a4c6a40f
--- /dev/null
+++ b/x11-wm/sawfish/sawfish-1.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-1.0.ebuild,v 1.1 2001/07/29 01:15:09 hallski Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Extensible window manager using a Lisp-based scripting language"
+SRC_URI="ftp://sawmill.sourceforge.net/pub/sawmill/"${A}
+HOMEPAGE="http://sawmill.sourceforge.net/"
+DEPEND=">=dev-libs/rep-gtk-0.15-r1
+ >=dev-libs/librep-0.14
+ >=media-libs/imlib-1.9.10
+ esd? ( >=media-sound/esound-0.2.22 )
+ readline? ( >=sys-libs/readline-4.1 )
+ nls? ( sys-devel/gettext )
+ gnome? ( >=gnome-base/gnome-core-1.4.0 )"
+RDEPEND=">=dev-libs/rep-gtk-0.15-r1
+ >=dev-libs/librep-0.14
+ >=x11-libs/gtk+-1.2.10
+ >=media-libs/imlib-1.9.10
+ esd? ( >=media-sound/esound-0.2.22 )
+ gnome? ( >=gnome-base/gnome-core-1.4.0 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/po
+ cp zh_TW.Big5.po zh_TW.Big5.po.orig
+ sed -e "s:\\\::g" zh_TW.Big5.po.orig > zh_TW.Big5.po
+ rm zh_TW.Big5.po.orig
+}
+
+src_compile() {
+
+ local myconf
+ if [ "`use esd`" ]
+ then
+ myconf="--with-esd"
+ else
+ myconf="--without-esd"
+ fi
+ if [ "`use gnome`" ]
+ then
+ myconf="${myconf} --with-gnome-prefix=/opt/gnome --enable-gnome-widgets --enable-capplet"
+ else
+ myconf="${myconf} --disable-gnome-widgets --disable-capplet --without-gdk-pixbuf"
+ fi
+ if [ "`use readline`" ]
+ then
+ myconf="${myconf} --with-readline"
+ else
+ myconf="${myconf} --without-readline"
+ fi
+ if [ -z "`use nls`" ]
+ then
+ myconf="${myconf} --disable-linguas"
+ fi
+
+ try ./configure --host=${CHOST} --prefix=/usr/X11R6 --infodir=/usr/X11R6/info --libexecdir=/usr/X11R6/lib --with-audiofile ${myconf}
+
+ #pmake doesn't work, stick with make
+ try make
+}
+
+src_install() {
+
+ try make DESTDIR=${D} install
+ dodoc AUTHORS BUGS COPYING ChangeLog DOC FAQ NEWS README THANKS TODO
+
+}
+
+
+