summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-26 22:48:36 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-26 22:48:36 +0000
commit469f2838551e03f068b0ea4f91eb6c40628a8bfa (patch)
tree67f579494ad4479355b2d441409eee22c15c19b0 /x11-wm/sawfish
parent*** empty log message *** (diff)
downloadhistorical-469f2838551e03f068b0ea4f91eb6c40628a8bfa.tar.gz
historical-469f2838551e03f068b0ea4f91eb6c40628a8bfa.tar.bz2
historical-469f2838551e03f068b0ea4f91eb6c40628a8bfa.zip
*** empty log message ***
Diffstat (limited to 'x11-wm/sawfish')
-rw-r--r--x11-wm/sawfish/files/digest-sawfish-0.33.11
-rw-r--r--x11-wm/sawfish/sawfish-0.33.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/x11-wm/sawfish/files/digest-sawfish-0.33.1 b/x11-wm/sawfish/files/digest-sawfish-0.33.1
new file mode 100644
index 000000000000..b05b76e17c9a
--- /dev/null
+++ b/x11-wm/sawfish/files/digest-sawfish-0.33.1
@@ -0,0 +1 @@
+MD5 a2b99f3f9deae419c43504dba16554f0 sawfish-0.33.1.tar.gz
diff --git a/x11-wm/sawfish/sawfish-0.33.1.ebuild b/x11-wm/sawfish/sawfish-0.33.1.ebuild
new file mode 100644
index 000000000000..3518887611e2
--- /dev/null
+++ b/x11-wm/sawfish/sawfish-0.33.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-0.33.1.ebuild,v 1.1 2000/11/26 22:48:36 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Extensible window manager using a Lisp-based scripting language"
+SRC_URI="ftp://sawmill.sourceforge.net/pub/sawmill/"${A}
+HOMEPAGE="http://sawmill.sourceforge.net/"
+DEPEND=">=dev-libs/rep-gtk-0.14
+ >=media-sound/esound-0.2.19
+ >=media-libs/imlib-0.9.8.1
+ gnome? ( >=gnome-base/gnome-core-1.2.2.1
+ >=gnome-base/libglade-0.14 )"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ if [ -n "`use gnome`" ]
+ then
+ try ./configure --host=${CHOST} --prefix=/usr/X11R6 --with-audiofile --with-esd \
+ --with-gnome-prefix=/opt/gnome
+ else
+ try ./configure --host=${CHOST} --prefix=/usr/X11R6 --with-audiofile --with-esd
+ fi
+ #pmake doesn't work, stick with make
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make DESTDIR=${D} install
+ dodoc AUTHORS BUGS COPYING ChangeLog DOC FAQ NEWS README THANKS TODO
+}
+
+
+