summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-07-06 06:24:04 +0000
committerNick Hadaway <raker@gentoo.org>2002-07-06 06:24:04 +0000
commit1c7e87cd7b12f5cf12582b3af6cbd47948d532c5 (patch)
tree137f453ea86ac654ba5358031478aa8fb904e5c0 /x11-wm
parentmasked WindowMaker-0.80.1-r2 which I modified to skip the gnustep-env (diff)
downloadhistorical-1c7e87cd7b12f5cf12582b3af6cbd47948d532c5.tar.gz
historical-1c7e87cd7b12f5cf12582b3af6cbd47948d532c5.tar.bz2
historical-1c7e87cd7b12f5cf12582b3af6cbd47948d532c5.zip
Build that doesn't need gnustep-env :)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/WindowMaker/WindowMaker-0.80.1-r2.ebuild150
-rw-r--r--x11-wm/WindowMaker/files/digest-WindowMaker-0.80.1-r22
2 files changed, 152 insertions, 0 deletions
diff --git a/x11-wm/WindowMaker/WindowMaker-0.80.1-r2.ebuild b/x11-wm/WindowMaker/WindowMaker-0.80.1-r2.ebuild
new file mode 100644
index 000000000000..5ded356f1f00
--- /dev/null
+++ b/x11-wm/WindowMaker/WindowMaker-0.80.1-r2.ebuild
@@ -0,0 +1,150 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/WindowMaker/WindowMaker-0.80.1-r2.ebuild,v 1.1 2002/07/06 06:24:04 raker Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Window Maker"
+SRC_URI="ftp://ftp.windowmaker.org/pub/source/release/${P}.tar.gz
+ ftp://ftp.windowmaker.org/pub/source/release/WindowMaker-extra-0.1.tar.gz"
+HOMEPAGE="http://www.windowmaker.org/"
+
+DEPEND="virtual/x11
+ >=media-libs/tiff-3.5.5
+ gif? ( >=media-libs/giflib-4.1.0-r3
+ >=media-libs/libungif-4.1.0 )
+ png? ( >=media-libs/libpng-1.2.1 )
+ jpeg? ( >=media-libs/jpeg-6b-r2 )"
+
+RDEPEND="nls? ( >=sys-devel/gettext-0.10.39 )"
+
+SLOT="0"
+LICENSE="GPL-2"
+
+#NOTE: the default menu has the wrong path for the WMPrefs utility.
+# Needs fixing.
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${WORKDIR}
+ #patch -p0 < ${FILESDIR}/${P}-gentoo.patch
+}
+
+src_compile() {
+
+ #patch -p1 < ${FILESDIR}/wmfpo-80.patch
+
+ local myconf
+
+ use gnome \
+ && myconf="${myconf} --enable-gnome" \
+ || myconf="${myconf} --disable-gnome"
+
+ use kde \
+ && myconf="${myconf} --enable-kde" \
+ && export KDEDIR=/usr/kde/2 \
+ || myconf="${myconf} --disable-kde"
+
+ if [ "$WITH_MODELOCK" ] ; then
+ myconf="${myconf} --enable-modelock"
+ else
+ myconf="${myconf} --disable-modelock"
+ fi
+
+ use nls \
+ && export LINGUAS="`ls po/*.po | sed 's:po/\(.*\)\.po$:\1:'`" \
+ || myconf="${myconf} --disable-nls --disable-locale"
+
+ use gif \
+ || myconf="${myconf} --disable-gif"
+
+ use jpeg \
+ || myconf="${myconf} --disable-jpeg"
+
+ use png \
+ || myconf="${myconf} --disable-png"
+
+
+ use esd || use alsa || use oss \
+ && myconf="${myconf} --enable-sound" \
+ || myconf="${myconf} --disable-sound"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc/X11 \
+ --localstatedir=/var/state/WindowMaker \
+ --with-x \
+ --enable-newstyle \
+ --enable-superfluous \
+ --enable-usermenu \
+ --with-appspath=/usr/GNUstep \
+ --with-pixmapdir=/usr/share/pixmaps \
+ ${myconf} || die
+
+ cd ${S}/po
+ cp Makefile Makefile.orig
+ sed 's:zh_TW.*::' \
+ Makefile.orig > Makefile
+
+ cd ${S}/WPrefs.app/po
+ cp Makefile Makefile.orig
+ sed 's:zh_TW.*::' \
+ Makefile.orig > Makefile
+
+ cd ${S}
+ emake || die
+
+ # WindowMaker Extra
+ cd ../WindowMaker-extra-0.1
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info || die
+
+ make || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ sysconfdir=${D}/etc/X11 \
+ wprefsdir=${D}/usr/GNUstep/WPrefs.app \
+ wpdatadir=${D}/usr/GNUstep/WPrefs.app \
+ wpexecbindir=${D}/usr/GNUstep/WPrefs.app \
+ install || die
+
+ cp -f WindowMaker/plmenu ${D}/etc/X11/WindowMaker/WMRootMenu
+
+ dodoc AUTHORS BUGFORUM BUGS ChangeLog COPYING* INSTALL* FAQ* \
+ MIRRORS README* NEWS TODO
+
+ # WindowMaker Extra
+ cd ../WindowMaker-extra-0.1
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ newdoc README README.extra
+
+ echo "#!/bin/bash" > wmaker
+ echo "/usr/bin/wmaker" >> wmaker
+
+ exeinto /etc/X11/Sessions/
+ doexe wmaker
+}
+
+pkg_postinst() {
+
+ echo
+ echo '######################################################################'
+ echo '# If do you want trans globes and other trans elements do you need #'
+ echo '# the libxpm (media-libs/xpm). #'
+ echo '######################################################################'
+ }
+
diff --git a/x11-wm/WindowMaker/files/digest-WindowMaker-0.80.1-r2 b/x11-wm/WindowMaker/files/digest-WindowMaker-0.80.1-r2
new file mode 100644
index 000000000000..c05f660bc310
--- /dev/null
+++ b/x11-wm/WindowMaker/files/digest-WindowMaker-0.80.1-r2
@@ -0,0 +1,2 @@
+MD5 b1c88c8ecb8f4484d0ae953b9a730418 WindowMaker-0.80.1.tar.gz 2503965
+MD5 07c7700daaaf232bc490f5abaabef085 WindowMaker-extra-0.1.tar.gz 238018