summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorPrakash Shetty <crux@gentoo.org>2001-07-04 15:28:48 +0000
committerPrakash Shetty <crux@gentoo.org>2001-07-04 15:28:48 +0000
commit24a7a6f588854ec30c8f630fc5e94911b73ff7e1 (patch)
tree052783c95d4ab749f4271e14c36b85d7411c1bb4 /x11-wm
parentNew Maintenance release for bind-9.1.2 with lots of bug-fixes and no new feat... (diff)
downloadhistorical-24a7a6f588854ec30c8f630fc5e94911b73ff7e1.tar.gz
historical-24a7a6f588854ec30c8f630fc5e94911b73ff7e1.tar.bz2
historical-24a7a6f588854ec30c8f630fc5e94911b73ff7e1.zip
Fvwm - Window Manager Newer Version 2.4.0
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/fvwm/files/digest-fvwm-2.4.01
-rw-r--r--x11-wm/fvwm/fvwm-2.4.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/x11-wm/fvwm/files/digest-fvwm-2.4.0 b/x11-wm/fvwm/files/digest-fvwm-2.4.0
new file mode 100644
index 000000000000..1e039188ca46
--- /dev/null
+++ b/x11-wm/fvwm/files/digest-fvwm-2.4.0
@@ -0,0 +1 @@
+MD5 897f7fb2c4f23bc246eeb36d0dd1a2c2 fvwm-2.4.0.tar.bz2
diff --git a/x11-wm/fvwm/fvwm-2.4.0.ebuild b/x11-wm/fvwm/fvwm-2.4.0.ebuild
new file mode 100644
index 000000000000..d4cb1888d451
--- /dev/null
+++ b/x11-wm/fvwm/fvwm-2.4.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Prakash Shetty <crux@gentoo.org>
+
+S=${WORKDIR}/${P}
+DESCRIPTION="an extremely powerful ICCCM-compliant multiple virtual desktop window manager"
+SRC_URI="ftp://ftp.fvwm.org/pub/fvwm/version-2/${P}.tar.bz2"
+HOMEPAGE="http://www.fvwm.org/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/readline-4.1
+ >=x11-libs/gtk+-1.2.10
+ gnome? ( >=gnome-base/gnome-libs-1.2.13 )"
+
+src_compile() {
+ local myconf
+ if [ -n "$( use gnome )" ]
+ then
+ myconf="--with-gnome"
+ else
+ myconf="--without-gnome"
+ fi
+ try ./configure --prefix=/usr/X11R6 --libexecdir=/usr/X11R6/lib \
+ --mandir=/usr/share/man --infodir=/usr/share/info --host=${CHOST} ${myconf}
+ try make
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+ exeinto /usr/X11R6/bin/wm
+ doexe ${FILESDIR}/fvwm
+
+}