summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-29 21:03:10 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-29 21:03:10 +0000
commit382b4b4bea94e475266a3e1532a6f40bf5fadecb (patch)
tree244bc6b2d6f6bbc8182ca18f4f81b92c76840848 /xfce-extra/xfce4-battery-plugin
parentbump to eapi3, use arrays (diff)
downloadhistorical-382b4b4bea94e475266a3e1532a6f40bf5fadecb.tar.gz
historical-382b4b4bea94e475266a3e1532a6f40bf5fadecb.tar.bz2
historical-382b4b4bea94e475266a3e1532a6f40bf5fadecb.zip
bump to eapi3
Package-Manager: portage-2.2.0_alpha19/cvs/Linux x86_64
Diffstat (limited to 'xfce-extra/xfce4-battery-plugin')
-rw-r--r--xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-0.5.1.ebuild24
1 files changed, 15 insertions, 9 deletions
diff --git a/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-0.5.1.ebuild b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-0.5.1.ebuild
index f10eb316891a..53ddf5a23251 100644
--- a/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-0.5.1.ebuild
+++ b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-0.5.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-0.5.1.ebuild,v 1.2 2011/01/06 16:20:45 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-0.5.1.ebuild,v 1.3 2011/01/29 21:03:10 ssuominen Exp $
-EAPI=2
+EAPI=3
inherit xfconf
DESCRIPTION="Battery status panel plugin"
@@ -23,11 +23,17 @@ DEPEND="${RDEPEND}
dev-util/intltool"
pkg_setup() {
- PATCHES=( "${FILESDIR}/${PV}-freebsd.patch"
- "${FILESDIR}/${PV}-libacpi.patch"
- "${FILESDIR}/${PV}-2.6.24-headers.patch"
- "${FILESDIR}/${PV}-sysfs.patch" )
+ PATCHES=(
+ "${FILESDIR}"/${PV}-freebsd.patch
+ "${FILESDIR}"/${PV}-libacpi.patch
+ "${FILESDIR}"/${PV}-2.6.24-headers.patch
+ "${FILESDIR}"/${PV}-sysfs.patch
+ )
+
DOCS="AUTHORS ChangeLog README"
- XFCONF="--disable-dependency-tracking
- $(use_enable debug)"
+
+ XFCONF=(
+ --disable-dependency-tracking
+ $(use_enable debug)
+ )
}