summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xapp-doc/gentoo-web/files/xml/gentoo-howto.xml4
-rw-r--r--files/build-1.0_rc6.packages5
-rw-r--r--net-ftp/lukemftp/lukemftp-1.5-r1.ebuild3
-rw-r--r--net-misc/wget/wget-1.7-r1.ebuild5
-rw-r--r--sys-apps/baselayout/baselayout-1.6.ebuild3
-rw-r--r--sys-apps/diffutils/diffutils-2.7-r4.ebuild19
-rw-r--r--sys-devel/gcc/gcc-2.95.3-r1.ebuild7
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.4.6-r2.ebuild33
-rw-r--r--sys-libs/glibc/glibc-2.2.3-r5.ebuild5
9 files changed, 52 insertions, 32 deletions
diff --git a/app-doc/gentoo-web/files/xml/gentoo-howto.xml b/app-doc/gentoo-web/files/xml/gentoo-howto.xml
index 7e569e313ac7..447eee836dee 100755
--- a/app-doc/gentoo-web/files/xml/gentoo-howto.xml
+++ b/app-doc/gentoo-web/files/xml/gentoo-howto.xml
@@ -1,5 +1,5 @@
<?xml version='1.0'?>
-<!-- $Id: gentoo-howto.xml,v 1.18 2001/08/12 19:33:40 drobbins Exp $ -->
+<!-- $Id: gentoo-howto.xml,v 1.19 2001/08/13 19:20:17 drobbins Exp $ -->
<guide link="/doc/gentoo-howto.html">
<title>Gentoo Linux Developers HOWTO</title>
@@ -334,7 +334,7 @@ exactly the way you want it.
<c>USE</c>), this will only instruct Portage to disable <e>optional</e>
build-time support for GNOME. However, if you <c>emerge</c> an ebuild that
<e>requires</e> GNOME, the package will obviously have GNOME support enabled, as you
-would expect. This also means taht
+would expect. This also means that
GNOME will be automatically installed (as a dependency) if it hasn't been already. That's why
it's always a good idea to do an <c>emerge --pretend</c> before doing the
"real" <c>emerge</c>; that way, you'll always know that you're going to get!
diff --git a/files/build-1.0_rc6.packages b/files/build-1.0_rc6.packages
index cf631bdaee30..5c6784c8e8bc 100644
--- a/files/build-1.0_rc6.packages
+++ b/files/build-1.0_rc6.packages
@@ -1,6 +1,5 @@
./sys-apps/baselayout/baselayout-1.6.ebuild
./sys-libs/glibc/glibc-2.2.3-r5.ebuild
-#done up to here
./sys-apps/bash/bash-2.04-r4.ebuild
./sys-apps/bzip2/bzip2-1.0.1-r4.ebuild
./sys-apps/debianutils/debianutils-1.13.3-r4.ebuild
@@ -23,6 +22,6 @@
./sys-devel/make/make-3.79.1-r3.ebuild
./sys-devel/patch/patch-2.5.4-r3.ebuild
./sys-devel/spython/spython-2.0-r7.ebuild
-./net-misc/wget/wget-1.7-r1.ebuild
+./net-misc/wget-1.7-r1.ebuild
./net-misc/rsync/rsync-2.4.6-r4.ebuild
-./sys-kernel/linux-sources/linux-sources-2.4.6-r2.ebuild
+./sys-kernel/linux-sources/linux-headers-2.4.6-r3.ebuild
diff --git a/net-ftp/lukemftp/lukemftp-1.5-r1.ebuild b/net-ftp/lukemftp/lukemftp-1.5-r1.ebuild
index c845ac328c57..7ac4b2470678 100644
--- a/net-ftp/lukemftp/lukemftp-1.5-r1.ebuild
+++ b/net-ftp/lukemftp/lukemftp-1.5-r1.ebuild
@@ -12,7 +12,6 @@ SRC_URI="ftp://ftp.netbsd.org/pub/NetBSD/misc/lukemftp/${A}"
DEPEND="virtual/glibc
>=sys-libs/ncurses-5.1"
-
src_unpack() {
unpack ${A}
@@ -26,8 +25,6 @@ src_unpack() {
src/main.orig > src/main.c
}
-
-
src_compile() {
try ./configure --host=${CHOST} --prefix=/usr \
--enable-editcomplete --program-prefix=lukemftp
diff --git a/net-misc/wget/wget-1.7-r1.ebuild b/net-misc/wget/wget-1.7-r1.ebuild
index 4f266e42a31f..80de6a257abd 100644
--- a/net-misc/wget/wget-1.7-r1.ebuild
+++ b/net-misc/wget/wget-1.7-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.7-r1.ebuild,v 1.3 2001/08/11 04:53:17 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.7-r1.ebuild,v 1.4 2001/08/13 19:20:17 drobbins Exp $
A="${P}.tar.gz wget-new-percentage-1.7-20010606.diff"
S=${WORKDIR}/${P}
@@ -11,8 +11,7 @@ SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/wget/${P}.tar.gz
http://www.biscom.net/~cade/away/wget-new-percentage/wget-new-percentage-1.7-20010606.diff"
HOMEPAGE="http://www.cg.tuwien.ac.at/~prikryl/wget.html"
-DEPEND="virtual/glibc sys-devel/perl
- nls? ( sys-devel/gettext )"
+DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
RDEPEND="virtual/glibc"
diff --git a/sys-apps/baselayout/baselayout-1.6.ebuild b/sys-apps/baselayout/baselayout-1.6.ebuild
index 5498d6ee24d7..6a1cac22a449 100644
--- a/sys-apps/baselayout/baselayout-1.6.ebuild
+++ b/sys-apps/baselayout/baselayout-1.6.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: System Team <system@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.6.ebuild,v 1.2 2001/08/13 02:38:53 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.6.ebuild,v 1.3 2001/08/13 19:20:17 drobbins Exp $
SV=1.1
S=${WORKDIR}/rc-scripts-${SV}
@@ -143,6 +143,7 @@ src_install()
dosym /usr/sbin/MAKEDEV /dev/MAKEDEV
cd ${D}/dev
#These devices are also needed by many people and should be included
+ echo "Making device nodes... (this could take a minute or so...)"
${S}/sbin/MAKEDEV generic-i386
${S}/sbin/MAKEDEV sg
${S}/sbin/MAKEDEV scd
diff --git a/sys-apps/diffutils/diffutils-2.7-r4.ebuild b/sys-apps/diffutils/diffutils-2.7-r4.ebuild
index 159d4be49251..469f73735e90 100644
--- a/sys-apps/diffutils/diffutils-2.7-r4.ebuild
+++ b/sys-apps/diffutils/diffutils-2.7-r4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/diffutils-2.7-r4.ebuild,v 1.2 2001/08/12 19:20:15 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/diffutils-2.7-r4.ebuild,v 1.3 2001/08/13 19:20:17 drobbins Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -10,7 +10,11 @@ SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/diffutils/${A}
ftp://ftp.gnu.org/gnu/diffutils/${A}"
HOMEPAGE="http://www.gnu.org/software/diffutils/diffutils.html"
-DEPEND="virtual/glibc nls? ( sys-devel/gettext ) sys-apps/texinfo"
+DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
+if [ -z "`use build`" ]
+then
+ DEPEND="$DEPEND sys-apps/texinfo"
+fi
RDEPEND="virtual/glibc"
src_unpack() {
@@ -28,11 +32,18 @@ src_compile() {
fi
try ./configure --host=${CHOST} --prefix=/usr ${myconf}
+ if [ "`use build`" ]
+ then
+ #disable texinfo building so we can remove the dep
+ cp Makefile Makefile.orig
+ sed -e 's/^all: ${PROGRAMS} info/all: ${PROGRAMS}/g' Makefile.orig > Makefile
+ fi
+
if [ -z "`use static`" ]
then
- try pmake
+ try emake
else
- try pmake LDFLAGS=-static
+ try emake LDFLAGS=-static
fi
}
diff --git a/sys-devel/gcc/gcc-2.95.3-r1.ebuild b/sys-devel/gcc/gcc-2.95.3-r1.ebuild
index 9b2a5a8c985d..49e048d5182d 100644
--- a/sys-devel/gcc/gcc-2.95.3-r1.ebuild
+++ b/sys-devel/gcc/gcc-2.95.3-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3-r1.ebuild,v 1.3 2001/07/18 05:20:18 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3-r1.ebuild,v 1.4 2001/08/13 19:20:17 drobbins Exp $
SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/${P}/${P}.tar.gz
@@ -100,12 +100,13 @@ src_compile() {
src_install() {
try make install prefix=${D}${T} mandir=${D}${T}/share/man infodir=${D}${T}/share/info
-
+ [ -e ${D}/usr/bin/gcc ] || die "gcc not found in ${D}"
+ [ -e ${D}/usr/bin/g++ ] || die "g++ not found in ${D}"
FULLPATH=${D}${T}/lib/gcc-lib/${CHOST}/${PV}
cd ${FULLPATH}
dodir /lib
dosym /usr/bin/cpp /lib/cpp
- dosym /usr/bin/gcc /usr/bin/cc
+ dosym gcc /usr/bin/cc
dodir /etc/env.d
echo "LDPATH=${T}/lib/gcc-lib/${CHOST}/${PV}" > ${D}/etc/env.d/05gcc
cd ${S}
diff --git a/sys-kernel/linux-headers/linux-headers-2.4.6-r2.ebuild b/sys-kernel/linux-headers/linux-headers-2.4.6-r2.ebuild
index 3ded26480232..2ffc7d462155 100644
--- a/sys-kernel/linux-headers/linux-headers-2.4.6-r2.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-2.4.6-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.4.6-r2.ebuild,v 1.9 2001/08/08 01:03:33 pete Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.4.6-r2.ebuild,v 1.10 2001/08/13 19:20:17 drobbins Exp $
#OKV=original kernel version, KV=patched kernel version
@@ -9,10 +9,10 @@ OKV=2.4.6
KV=2.4.6
S=${WORKDIR}/linux-${KV}
S2=${WORKDIR}/linux-${KV}-extras
-if [ $PN = "linux-extras" ] || [ $PN = "linux-headers" ]
+if [ $PN = "linux-extras" ]
then
- KS=/usr/src/linux-${KV}
- KS2=/usr/src/linux-${KV}-extras
+ KS=${ROOT}usr/src/linux-${KV}
+ KS2=${ROOT}usr/src/linux-${KV}-extras
else
KS=${S}
KS2=${S2}
@@ -84,22 +84,26 @@ then
#ncurses is required for "make menuconfig"
RDEPEND=">=sys-libs/ncurses-5.2"
fi
-elif [ $PN = "linux-extras" ] || [ $PN = "linux-headers" ]
+elif [ $PN = "linux-extras" ]
then
#linux-extras/headers requires a rev of the current kernel sources to be installed
- DEPEND="~sys-kernel/linux-sources-${PV}"
+ RDEPEND="~sys-kernel/linux-sources-${PV}"
+elif [ $PN = "linux-headers" ]
+then
+ DEPEND=""
+ RDEPEND=""
fi
# this is not pretty...
LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${KS}/include"
src_unpack() {
- if [ "$PN" = "linux-extras" ] || [ "$PN" = "linux-headers" ]
+ if [ "$PN" = "linux-extras" ]
then
return
fi
- mkdir ${S2}
+ mkdir ${S2}
#unpack kernel and apply reiserfs-related patches
cd ${WORKDIR}
@@ -406,10 +410,17 @@ src_install() {
cd ${S}
if [ "`use build`" ] ; then
- dodir /usr/src/linux-${KV}
+
+ #if we install linux-sources in "build" mode, then only kernel headers
+ #are installed. And they are installed to /usr/include as system defaults
+ #rather than to /usr/src/linux-${KV}
+
+ dodir /usr/include/linux
+ dodir /usr/include/asm
#grab includes and documentation only
- echo ">>> Copying includes..."
- cp -ax ${S}/include ${D}/usr/src/linux-${KV}
+ echo ">>> Copying includes to /usr/include..."
+ cp -ax ${KS}/include/linux/* ${D}/usr/include/linux
+ cp -ax ${KS}/include/asm-i386/* ${D}/usr/include/asm
else
echo ">>> Copying sources..."
cp -ax ${WORKDIR}/* ${D}/usr/src
diff --git a/sys-libs/glibc/glibc-2.2.3-r5.ebuild b/sys-libs/glibc/glibc-2.2.3-r5.ebuild
index 3fb2aa2b7ba5..7e7264d326ca 100644
--- a/sys-libs/glibc/glibc-2.2.3-r5.ebuild
+++ b/sys-libs/glibc/glibc-2.2.3-r5.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.2.3-r5.ebuild,v 1.1 2001/08/13 00:35:29 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.2.3-r5.ebuild,v 1.2 2001/08/13 19:20:17 drobbins Exp $
A="$P.tar.gz glibc-linuxthreads-${PV}.tar.gz"
S=${WORKDIR}/${P}
@@ -14,7 +14,8 @@ SRC_URI="ftp://sourceware.cygnus.com/pub/glibc/releases/glibc-${PV}.tar.gz
ftp://ftp.gnu.org/pub/gnu/glibc/glibc-linuxthreads-${PV}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/libc/libc.html"
-DEPEND="nls? ( sys-devel/gettext ) gd? ( media-libs/libgd )"
+#Specific Linux headers are now required so that we build from a stable "base"
+DEPEND="~sys-kernel/linux-headers-2.4.6 nls? ( sys-devel/gettext ) gd? ( media-libs/libgd )"
if [ -z "`use bootstrap`" ] && [ -z "`use bootcd`" ] && [ -z "`use build`" ]
then