summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/highlight/ChangeLog7
-rw-r--r--app-text/highlight/highlight-2.9.ebuild16
-rw-r--r--app-text/texi2html/ChangeLog7
-rw-r--r--app-text/texi2html/texi2html-1.78.ebuild12
-rw-r--r--app-text/xdvik/ChangeLog5
-rw-r--r--app-text/xdvik/xdvik-22.84.16.ebuild31
6 files changed, 46 insertions, 32 deletions
diff --git a/app-text/highlight/ChangeLog b/app-text/highlight/ChangeLog
index d0019840ee9c..4677ede80826 100644
--- a/app-text/highlight/ChangeLog
+++ b/app-text/highlight/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/highlight
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/ChangeLog,v 1.25 2009/05/04 20:14:33 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/ChangeLog,v 1.26 2010/02/22 20:40:49 abcd Exp $
+
+ 22 Feb 2010; Jonathan Callen <abcd@gentoo.org> highlight-2.9.ebuild:
+ Add prefix keywords, support; bump EAPI
*highlight-2.9 (04 May 2009)
diff --git a/app-text/highlight/highlight-2.9.ebuild b/app-text/highlight/highlight-2.9.ebuild
index e191496b0890..83fac8fbbd23 100644
--- a/app-text/highlight/highlight-2.9.ebuild
+++ b/app-text/highlight/highlight-2.9.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/highlight-2.9.ebuild,v 1.3 2009/05/04 20:24:08 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/highlight-2.9.ebuild,v 1.4 2010/02/22 20:40:49 abcd Exp $
-EAPI=2
+EAPI=3
inherit eutils toolchain-funcs
DESCRIPTION="converts source code to formatted text ((X)HTML, RTF, (La)TeX, XSL-FO, XML) with syntax highlight"
@@ -11,7 +11,7 @@ SRC_URI="http://www.andre-simon.de/zip/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="qt4"
RDEPEND="qt4? ( x11-libs/qt-gui:4
@@ -20,16 +20,16 @@ DEPEND="${RDEPEND}"
src_prepare() {
sed -i -e 's:-O2::' -e 's:CFLAGS:CXXFLAGS:g' \
- -e 's:qmake-qt4:/usr/bin/qmake:' \
+ -e 's:qmake-qt4:${EPREFIX}/usr/bin/qmake:' \
src/makefile || die "sed failed"
}
src_compile() {
- emake -f makefile CXX="$(tc-getCXX)" \
+ emake -f makefile PREFIX="${EPREFIX}" conf_dir="${EPREFIX}"/etc/highlight/ CXX="$(tc-getCXX)" \
|| die "emake failed"
if use qt4; then
- emake -j1 -f makefile CXX="$(tc-getCXX)" gui \
+ emake -j1 -f makefile PREFIX="${EPREFIX}" conf_dir="${EPREFIX}"/etc/highlight/ CXX="$(tc-getCXX)" gui \
|| die "emake gui failed"
fi
}
@@ -38,10 +38,12 @@ src_install() {
dodir /usr/bin
emake -f makefile DESTDIR="${D}" \
+ PREFIX="${EPREFIX}" conf_dir="${EPREFIX}"/etc/highlight/ \
install || die "emake install failed"
if use qt4; then
emake -f makefile DESTDIR="${D}" \
+ PREFIX="${EPREFIX}" conf_dir="${EPREFIX}"/etc/highlight/ \
install-gui || die "emake install-gui failed"
doicon src/gui-qt/${PN}.xpm
domenu ${PN}.desktop
diff --git a/app-text/texi2html/ChangeLog b/app-text/texi2html/ChangeLog
index 27dbc1e7cd68..8f471d5cf034 100644
--- a/app-text/texi2html/ChangeLog
+++ b/app-text/texi2html/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/texi2html
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/texi2html/ChangeLog,v 1.41 2009/09/23 16:40:28 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/texi2html/ChangeLog,v 1.42 2010/02/22 20:43:55 abcd Exp $
+
+ 22 Feb 2010; Jonathan Callen <abcd@gentoo.org> texi2html-1.78.ebuild:
+ Add prefix keywords, support; bump EAPI
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> texi2html-1.64-r1.ebuild:
Remove virtual/libc
diff --git a/app-text/texi2html/texi2html-1.78.ebuild b/app-text/texi2html/texi2html-1.78.ebuild
index 298a426f57ed..d78728e748b2 100644
--- a/app-text/texi2html/texi2html-1.78.ebuild
+++ b/app-text/texi2html/texi2html-1.78.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/texi2html/texi2html-1.78.ebuild,v 1.3 2009/03/11 18:40:16 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/texi2html/texi2html-1.78.ebuild,v 1.4 2010/02/22 20:43:55 abcd Exp $
+
+EAPI=3
DESCRIPTION="Perl script that converts Texinfo to HTML"
HOMEPAGE="http://www.nongnu.org/texi2html/"
@@ -8,7 +10,7 @@ SRC_URI="http://download.savannah.gnu.org/releases/texi2html/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE=""
DEPEND=">=dev-lang/perl-5.6.1"
@@ -16,12 +18,12 @@ DEPEND=">=dev-lang/perl-5.6.1"
src_install() {
#yes, htmldir line is correct, no ${D}
emake DESTDIR="${D}" \
- htmldir=/usr/share/doc/${PF}/html \
+ htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
install || die "Installation Failed"
dodoc AUTHORS ChangeLog INTRODUCTION NEWS README TODO
}
pkg_preinst() {
- rm -f "${ROOT}"/usr/bin/texi2html
+ rm -f "${EROOT}"/usr/bin/texi2html
}
diff --git a/app-text/xdvik/ChangeLog b/app-text/xdvik/ChangeLog
index 2a57e2061203..b72f03d4591b 100644
--- a/app-text/xdvik/ChangeLog
+++ b/app-text/xdvik/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/xdvik
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xdvik/ChangeLog,v 1.65 2010/01/09 13:22:12 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xdvik/ChangeLog,v 1.66 2010/02/22 20:48:29 abcd Exp $
+
+ 22 Feb 2010; Jonathan Callen <abcd@gentoo.org> xdvik-22.84.16.ebuild:
+ Add prefix keywords, support; bump EAPI
09 Jan 2010; Alexis Ballier <aballier@gentoo.org> xdvik-22.84.16.ebuild,
+files/xdvik-22.84.16-cvararg.patch:
diff --git a/app-text/xdvik/xdvik-22.84.16.ebuild b/app-text/xdvik/xdvik-22.84.16.ebuild
index 4ea2b6f7e5d4..57e3f9203ef7 100644
--- a/app-text/xdvik/xdvik-22.84.16.ebuild
+++ b/app-text/xdvik/xdvik-22.84.16.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xdvik/xdvik-22.84.16.ebuild,v 1.2 2010/01/09 13:22:12 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xdvik/xdvik-22.84.16.ebuild,v 1.3 2010/02/22 20:48:29 abcd Exp $
+
+EAPI=3
inherit eutils flag-o-matic elisp-common toolchain-funcs
@@ -8,7 +10,7 @@ DESCRIPTION="DVI previewer for X Window System"
HOMEPAGE="http://xdvi.sourceforge.net/"
SRC_URI="mirror://sourceforge/xdvi/${P}.tar.gz"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
SLOT="0"
LICENSE="GPL-2"
IUSE="motif neXt Xaw3d emacs"
@@ -26,9 +28,7 @@ DEPEND="${RDEPEND}"
TEXMF_PATH=/usr/share/texmf
S=${WORKDIR}/${P}/texk/xdvik
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}/${P}-open-mode.patch"
epatch "${FILESDIR}/${P}-cvararg.patch"
# Make sure system kpathsea headers are used
@@ -36,7 +36,7 @@ src_unpack() {
for i in *.h ; do echo "#include_next \"$i\"" > $i; done
}
-src_compile() {
+src_configure() {
cd "${WORKDIR}/${P}"
tc-export CC AR RANLIB
@@ -58,22 +58,23 @@ src_compile() {
--enable-gf \
--with-system-t1lib \
--with-system-kpathsea \
- --with-kpathsea-include=/usr/include/kpathsea \
+ --with-kpathsea-include="${EPREFIX}"/usr/include/kpathsea \
--with-xdvi-x-toolkit="${toolkit}"
+}
- cd "${S}"
- emake kpathsea_dir="/usr/include/kpathsea" texmf="${TEXMF_PATH}" || die
+src_compile() {
+ emake kpathsea_dir="${EPREFIX}/usr/include/kpathsea" texmf="${EPREFIX}${TEXMF_PATH}" || die
use emacs && elisp-compile xdvi-search.el
}
src_install() {
- einstall kpathsea_dir="/usr/include/kpathsea" texmf="${D}${TEXMF_PATH}" || die "install failed"
+ einstall kpathsea_dir="${EPREFIX}/usr/include/kpathsea" texmf="${ED}${TEXMF_PATH}" || die "install failed"
dodir /etc/texmf/xdvi /etc/X11/app-defaults
- mv "${D}${TEXMF_PATH}/xdvi/XDvi" "${D}etc/X11/app-defaults" || die "failed to move config file"
+ mv "${ED}${TEXMF_PATH}/xdvi/XDvi" "${ED}etc/X11/app-defaults" || die "failed to move config file"
dosym {/etc/X11/app-defaults,"${TEXMF_PATH}/xdvi"}/XDvi || die "failed to symlink config file"
- for i in $(find "${D}${TEXMF_PATH}/xdvi" -type f -maxdepth 1) ; do
- mv ${i} "${D}etc/texmf/xdvi" || die "failed to move $i"
+ for i in $(find "${ED}${TEXMF_PATH}/xdvi" -type f -maxdepth 1) ; do
+ mv ${i} "${ED}etc/texmf/xdvi" || die "failed to move $i"
dosym {/etc/texmf,"${TEXMF_PATH}"}/xdvi/$(basename ${i}) || die "failed to symlink $i"
done
@@ -83,13 +84,13 @@ src_install() {
doicon "${FILESDIR}/${PN}.png"
make_desktop_entry xdvi "XDVI" xdvik "Graphics;Viewer"
- echo "MimeType=application/x-dvi;" >> "${D}"usr/share/applications/xdvi-"${PN}".desktop
+ echo "MimeType=application/x-dvi;" >> "${ED}"usr/share/applications/xdvi-"${PN}".desktop
}
pkg_postinst() {
if use emacs; then
elog "Add"
- elog " (add-to-list 'load-path \"${SITELISP}/tex-utils\")"
+ elog " (add-to-list 'load-path \"${EPREFIX}${SITELISP}/tex-utils\")"
elog " (require 'xdvi-search)"
elog "to your ~/.emacs file"
fi