summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/popt/ChangeLog5
-rw-r--r--dev-libs/popt/popt-1.7-r1.ebuild23
2 files changed, 17 insertions, 11 deletions
diff --git a/dev-libs/popt/ChangeLog b/dev-libs/popt/ChangeLog
index c86ee1827825..63fce4ca4862 100644
--- a/dev-libs/popt/ChangeLog
+++ b/dev-libs/popt/ChangeLog
@@ -1,10 +1,13 @@
# ChangeLog for dev-libs/popt
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/popt/ChangeLog,v 1.16 2003/03/28 06:27:20 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/popt/ChangeLog,v 1.17 2003/03/28 07:07:30 seemant Exp $
*popt-1.7-r1 (20 Mar 2003)
27 Mar 2003; Seemant Kulleen <seemant@gentoo.org> popt-1.7-r1.ebuild:
+ ok, this one actually does disable nls and also has a mips fix
+
+ 27 Mar 2003; Seemant Kulleen <seemant@gentoo.org> popt-1.7-r1.ebuild:
gettext is no longer a REQUIRED dependency, though it's a quirky way of
disabling it -- tsk tsk @ the upstream authors
diff --git a/dev-libs/popt/popt-1.7-r1.ebuild b/dev-libs/popt/popt-1.7-r1.ebuild
index 68abfa5cafc7..861917013b62 100644
--- a/dev-libs/popt/popt-1.7-r1.ebuild
+++ b/dev-libs/popt/popt-1.7-r1.ebuild
@@ -1,28 +1,31 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/popt/popt-1.7-r1.ebuild,v 1.3 2003/03/28 06:27:42 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/popt/popt-1.7-r1.ebuild,v 1.4 2003/03/28 07:07:30 seemant Exp $
-inherit libtool
+inherit libtool gnuconfig
+
+IUSE="nls"
DESCRIPTION="Parse Options - Command line parser"
-SRC_URI="ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.1.x/${P}.tar.gz"
HOMEPAGE="http://www.rpm.org/"
+SRC_URI="ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.1.x/${P}.tar.gz"
SLOT="0"
LICENSE="as-is"
-KEYWORDS="x86 ppc sparc alpha hppa arm"
-IUSE="nls"
+KEYWORDS="x86 ppc sparc alpha mips hppa arm"
DEPEND="nls? ( sys-devel/gettext )"
src_compile() {
+ gnuconfig_update
elibtoolize
- local myconf="--with-gnu-ld"
- use nls || ( \
- myconf="${myconf} --disable-nls"
+
+ if [ -z "`use nls`" ]
+ then
touch ../rpm.c
- )
- econf ${myconf} || die
+ fi
+
+ econf `use_enable nls` --with-gnu-ld || die
make || die
}