summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-www/netscape-plugger/ChangeLog9
-rw-r--r--net-www/netscape-plugger/files/digest-netscape-plugger-4.0-r11
-rw-r--r--net-www/netscape-plugger/netscape-plugger-4.0-r1.ebuild28
3 files changed, 37 insertions, 1 deletions
diff --git a/net-www/netscape-plugger/ChangeLog b/net-www/netscape-plugger/ChangeLog
index 249973aeef0e..8c5103dc7925 100644
--- a/net-www/netscape-plugger/ChangeLog
+++ b/net-www/netscape-plugger/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-www/netscape-plugger
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-plugger/ChangeLog,v 1.2 2002/03/09 08:45:54 guidob Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-plugger/ChangeLog,v 1.3 2002/04/05 04:31:41 tod Exp $
+
+*netscape-plugger-4.0-r1 (4 Apr 2002)
+
+ 9 Mar 2002; Tod Neidt <tod@gentoo.org> ebuild:
+
+ Added 'use mozilla' check to add symlink to /usr/lib/mozilla/plugins
+ if true. Enables plugin for moz and galeon users. Syntax and tabs update.
*netscape-plugger-4.0 (9 Mar 2002)
diff --git a/net-www/netscape-plugger/files/digest-netscape-plugger-4.0-r1 b/net-www/netscape-plugger/files/digest-netscape-plugger-4.0-r1
new file mode 100644
index 000000000000..7e8899b76ecc
--- /dev/null
+++ b/net-www/netscape-plugger/files/digest-netscape-plugger-4.0-r1
@@ -0,0 +1 @@
+MD5 037229f1f0924d6c3cafdcd00646a404 plugger-4.0-linux-x86-glibc.tar.gz 36409
diff --git a/net-www/netscape-plugger/netscape-plugger-4.0-r1.ebuild b/net-www/netscape-plugger/netscape-plugger-4.0-r1.ebuild
new file mode 100644
index 000000000000..0f0466df8fa5
--- /dev/null
+++ b/net-www/netscape-plugger/netscape-plugger-4.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+
+MYP=${P#netscape-}-linux-x86-glibc
+S=${WORKDIR}/plugger-4.0
+DESCRIPTION="Plugger 4.0 streaming media plugin"
+SRC_URI="http://fredrik.hubbe.net/plugger/"${MYP}.tar.gz
+HOMEPAGE="http://fredrik.hubbe.net/plugger.html"
+
+src_install() {
+ cd ${S}
+ dodir /opt/netscape/plugins /etc /usr/local/bin
+ insinto /opt/netscape/plugins
+ doins plugger.so
+ insinto /etc
+ doins pluggerrc
+ dodoc README COPYING
+ doman plugger.7
+ insinto /usr/bin
+ dobin plugger-4.0
+ dosym plugger-4.0 /usr/bin/plugger
+
+ use mozilla && \
+ into /usr/lib/mozilla/plugins;
+ dosym /opt/netscape/plugins/plugger.so /usr/lib/mozilla/plugins/plugger.so
+
+}