summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/alsa-lib/ChangeLog18
-rw-r--r--media-libs/alsa-lib/alsa-lib-0.9.0_rc3.ebuild34
2 files changed, 30 insertions, 22 deletions
diff --git a/media-libs/alsa-lib/ChangeLog b/media-libs/alsa-lib/ChangeLog
index 96555f046969..d1faae364a7c 100644
--- a/media-libs/alsa-lib/ChangeLog
+++ b/media-libs/alsa-lib/ChangeLog
@@ -1,32 +1,33 @@
# ChangeLog for media-libs/alsa-lib
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.5 2002/08/16 02:47:34 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.6 2002/09/14 15:41:13 raker Exp $
*alsa-lib-0.9.0_rc3 (15 Aug 2002)
- 15 Aug 2002; Arcady Genkin <agenkin@thpoon.com>
- alsa-lib-0.9.0_rc3.ebuild :
+ 14 Sep 2002; Nick Hadaway <raker@gentoo.org>
+ alsa-lib-0.9.0_rc3.ebuild, files/configure.diff :
+ Changed ebuild to econf and einstall. Patched configure to squash
+ the -I/usr/include gcc3 warnings.
+ 15 Aug 2002; Arcady Genkin <agenkin@thpoon.com>
+ alsa-lib-0.9.0_rc3.ebuild :
Quick update to version 0.9.0rc3.
*alsa-lib-0.9.0_rc2 (20 Jun 2002)
20 Jun 2002; Arcady Genkin <agenkin@thpoon.com>
- alsa-lib-0.9.0_rc2.ebuild :
-
+ alsa-lib-0.9.0_rc2.ebuild :
Quick update to version 0.9.0rc2.
*alsa-lib-0.9.0_rc1 (27 Apr 2002)
17 Feb 2002; Arcady Genkin <agenkin@thpoon.com>
- alsa-lib-0.9.0_rc1.ebuild :
-
+ alsa-lib-0.9.0_rc1.ebuild :
Quick update to version 0.9.0rc1.
*alsa-lib-0.9.0.1_beta10 (3 Feb 2002)
3 Feb 2002; T.Neidt <tod@gentoo.org> ChangeLog :
-
Upgraded version to latest beta.
The issue below seems to be fixable by creating a link in the alsa-lib
ebuild from libasound.so.2 to libasound.so.1, but I'm leaving the warning
@@ -42,7 +43,6 @@
*alsa-lib-0.5.10b (1 Feb 2002)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
Added initial ChangeLog which should be updated whenever the package is
updated in any way. This changelog is targetted to users. This means that the
comments should well explained and written in clean English. The details about
diff --git a/media-libs/alsa-lib/alsa-lib-0.9.0_rc3.ebuild b/media-libs/alsa-lib/alsa-lib-0.9.0_rc3.ebuild
index 5e043147eb91..f6e4c541915c 100644
--- a/media-libs/alsa-lib/alsa-lib-0.9.0_rc3.ebuild
+++ b/media-libs/alsa-lib/alsa-lib-0.9.0_rc3.ebuild
@@ -1,32 +1,40 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-0.9.0_rc3.ebuild,v 1.1 2002/08/16 02:43:53 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-0.9.0_rc3.ebuild,v 1.2 2002/09/14 15:41:13 raker Exp $
+
+MY_P=${P/_rc/rc}
+S=${WORKDIR}/${MY_P}
DESCRIPTION="Advanced Linux Sound Architecture Library"
HOMEPAGE="http://www.alsa-project.org/"
-LICENSE="GPL"
+SRC_URI="ftp://ftp.alsa-project.org/pub/lib/${MY_P}.tar.bz2"
DEPEND="virtual/glibc
~media-sound/alsa-driver-0.9.0_rc3"
-
-MY_P=${P/_rc/rc}
-S=${WORKDIR}/${MY_P}
-
-SRC_URI="ftp://ftp.alsa-project.org/pub/lib/${MY_P}.tar.bz2"
+RDEPEND="${DEPEND}"
SLOT="0"
KEYWORDS="x86 ppc sparc sparc64"
+LICENSE="GPL"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/configure.diff || die "patch failed"
+
+}
src_compile() {
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- || die "./configure failed"
- make || die "Parallel Make Failed"
+
+ econf || die "./configure failed"
+
+ make || die "make failed"
}
src_install() {
- make DESTDIR=${D} install || die "Installation Failed"
+
+ einstall || die "Installation Failed"
#This alsa version does not provide libasound.so.1
#Without this library just about everything even remotely