summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-base/arts/arts-1.0.6.ebuild36
-rw-r--r--kde-base/arts/files/digest-arts-1.0.61
-rw-r--r--kde-base/kde/files/digest-kde-3.1_alpha10
-rw-r--r--kde-base/kde/kde-3.0.1.20020604.ebuild4
-rw-r--r--kde-base/kde/kde-3.0.2.ebuild4
-rw-r--r--kde-base/kde/kde-3.1_alpha1.ebuild9
-rw-r--r--kde-base/kdeaddons/files/digest-kdeaddons-3.1_alpha11
-rw-r--r--kde-base/kdeaddons/kdeaddons-3.1_alpha1.ebuild16
-rw-r--r--kde-base/kdeadmin/files/digest-kdeadmin-3.1_alpha11
-rw-r--r--kde-base/kdeadmin/kdeadmin-3.1_alpha1.ebuild14
-rw-r--r--kde-base/kdeartwork/files/digest-kdeartwork-3.1_alpha11
-rw-r--r--kde-base/kdeartwork/kdeartwork-3.1_alpha1.ebuild26
-rw-r--r--kde-base/kdebase/files/digest-kdebase-3.1_alpha11
-rw-r--r--kde-base/kdebase/kdebase-3.1_alpha1.ebuild86
-rw-r--r--kde-base/kdebindings/files/digest-kdebindings-3.1_alpha11
-rw-r--r--kde-base/kdebindings/kdebindings-3.1_alpha1.ebuild37
-rw-r--r--kde-base/kdeedu/files/digest-kdeedu-3.1_alpha11
-rw-r--r--kde-base/kdeedu/kdeedu-3.1_alpha1.ebuild36
-rw-r--r--kde-base/kdegames/files/digest-kdegames-3.1_alpha11
-rw-r--r--kde-base/kdegames/kdegames-3.1_alpha1.ebuild6
-rw-r--r--kde-base/kdegraphics/files/digest-kdegraphics-3.1_alpha11
-rw-r--r--kde-base/kdegraphics/kdegraphics-3.1_alpha1.ebuild22
-rw-r--r--kde-base/kdelibs/files/digest-kdelibs-3.1_alpha11
-rw-r--r--kde-base/kdelibs/kdelibs-3.1_alpha1.ebuild95
-rw-r--r--kde-base/kdemultimedia/files/digest-kdemultimedia-3.1_alpha11
-rw-r--r--kde-base/kdemultimedia/kdemultimedia-3.1_alpha1.ebuild61
-rw-r--r--kde-base/kdenetwork/files/digest-kdenetwork-3.1_alpha11
-rw-r--r--kde-base/kdenetwork/kdenetwork-3.1_alpha1.ebuild30
-rw-r--r--kde-base/kdepim/files/digest-kdepim-3.1_alpha11
-rw-r--r--kde-base/kdepim/kdepim-3.1_alpha1.ebuild18
-rw-r--r--kde-base/kdesdk/files/digest-kdesdk-3.1_alpha11
-rw-r--r--kde-base/kdesdk/kdesdk-3.1_alpha1.ebuild8
-rw-r--r--kde-base/kdetoys/files/digest-kdetoys-3.1_alpha11
-rw-r--r--kde-base/kdetoys/kdetoys-3.1_alpha1.ebuild8
-rw-r--r--kde-base/kdeutils/files/digest-kdeutils-3.1_alpha11
-rw-r--r--kde-base/kdeutils/kdeutils-3.1_alpha1.ebuild8
36 files changed, 536 insertions, 4 deletions
diff --git a/kde-base/arts/arts-1.0.6.ebuild b/kde-base/arts/arts-1.0.6.ebuild
new file mode 100644
index 000000000000..3948664c097e
--- /dev/null
+++ b/kde-base/arts/arts-1.0.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.0.6.ebuild,v 1.1 2002/07/12 22:07:34 danarmak Exp $
+inherit kde-base kde.org flag-o-matic
+
+SRC_URI="ftp://ftp.kde.org/pub/kde/unstable/3.1-alpha1/src/${P}.tar.bz2"
+DESCRIPTION="KDE 3.x Sound Server"
+set-kdedir 3.1
+need-qt 3.0.3
+
+if [ "${COMPILER}" == "gcc3" ]; then
+ # GCC 3.1 kinda makes arts buggy and prone to crashes when compiled with
+ # these.. Even starting a compile shuts down the arts server
+ filter-flags "-fomit-frame-pointer -fstrength-reduce"
+fi
+
+SLOT="1.1"
+
+use alsa && myconf="$myconf --enable-alsa" || myconf="$myconf --disable-alsa"
+
+src_unpack() {
+
+ base_src_unpack
+
+ kde_sandbox_patch ${S}/soundserver
+
+}
+
+src_install() {
+
+ kde_src_install
+ # fix root exploit
+ chmod ug-s ${D}${KDEDIR}/bin/artswrapper
+ dodoc ${S}/doc/{NEWS,README,TODO}
+
+}
diff --git a/kde-base/arts/files/digest-arts-1.0.6 b/kde-base/arts/files/digest-arts-1.0.6
new file mode 100644
index 000000000000..d6e8a8e7685a
--- /dev/null
+++ b/kde-base/arts/files/digest-arts-1.0.6
@@ -0,0 +1 @@
+MD5 e84d7ce468e016bd047e8f5dabfb03e5 arts-1.0.6.tar.bz2 920326
diff --git a/kde-base/kde/files/digest-kde-3.1_alpha1 b/kde-base/kde/files/digest-kde-3.1_alpha1
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/kde-base/kde/files/digest-kde-3.1_alpha1
diff --git a/kde-base/kde/kde-3.0.1.20020604.ebuild b/kde-base/kde/kde-3.0.1.20020604.ebuild
index 012234af96d1..0e40a110c6ee 100644
--- a/kde-base/kde/kde-3.0.1.20020604.ebuild
+++ b/kde-base/kde/kde-3.0.1.20020604.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kde/kde-3.0.1.20020604.ebuild,v 1.2 2002/07/11 06:30:26 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde/kde-3.0.1.20020604.ebuild,v 1.3 2002/07/12 22:07:34 danarmak Exp $
-DESCRIPTION="KDE 3.0 - merge this to pull in all non-developer kde-base/* packages"
+DESCRIPTION="KDE 3.0.1 - merge this to pull in all non-developer kde-base/* packages"
HOMEPAGE="http://www.kde.org/"
# removed: kdebindings, kdesdk, kdoc since these are developer-only packages
RDEPEND=`echo ~kde-base/kde{libs,base,addons,admin,artwork,edu,games,graphics,multimedia,network,pim,toys,utils}-${PV}`
diff --git a/kde-base/kde/kde-3.0.2.ebuild b/kde-base/kde/kde-3.0.2.ebuild
index 663c0f2c8e5c..5972a02b6b5e 100644
--- a/kde-base/kde/kde-3.0.2.ebuild
+++ b/kde-base/kde/kde-3.0.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kde/kde-3.0.2.ebuild,v 1.2 2002/07/11 06:30:26 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde/kde-3.0.2.ebuild,v 1.3 2002/07/12 22:07:34 danarmak Exp $
-DESCRIPTION="KDE 3.0 - merge this to pull in all non-developer kde-base/* packages"
+DESCRIPTION="KDE 3.0.2 - merge this to pull in all non-developer kde-base/* packages"
HOMEPAGE="http://www.kde.org/"
# removed: kdebindings, kdesdk, kdoc since these are developer-only packages
RDEPEND=`echo ~kde-base/kde{libs,base,addons,admin,artwork,edu,games,graphics,multimedia,network,pim,toys,utils}-${PV}`
diff --git a/kde-base/kde/kde-3.1_alpha1.ebuild b/kde-base/kde/kde-3.1_alpha1.ebuild
new file mode 100644
index 000000000000..c03723116b4e
--- /dev/null
+++ b/kde-base/kde/kde-3.1_alpha1.ebuild
@@ -0,0 +1,9 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde/kde-3.1_alpha1.ebuild,v 1.1 2002/07/12 22:07:34 danarmak Exp $
+
+DESCRIPTION="KDE 3.1-alpha1 - merge this to pull in all non-developer kde-base/* packages"
+HOMEPAGE="http://www.kde.org/"
+# removed: kdebindings, kdesdk, kdoc since these are developer-only packages
+RDEPEND=`echo ~kde-base/kde{libs,base,addons,admin,artwork,edu,games,graphics,multimedia,network,pim,toys,utils}-${PV}`
+
diff --git a/kde-base/kdeaddons/files/digest-kdeaddons-3.1_alpha1 b/kde-base/kdeaddons/files/digest-kdeaddons-3.1_alpha1
new file mode 100644
index 000000000000..23d4813a7242
--- /dev/null
+++ b/kde-base/kdeaddons/files/digest-kdeaddons-3.1_alpha1
@@ -0,0 +1 @@
+MD5 cf98fd1c1f434d9e48eaf3e57a38f3b0 kdeaddons-3.0.6.tar.bz2 977572
diff --git a/kde-base/kdeaddons/kdeaddons-3.1_alpha1.ebuild b/kde-base/kdeaddons/kdeaddons-3.1_alpha1.ebuild
new file mode 100644
index 000000000000..c84e429930fc
--- /dev/null
+++ b/kde-base/kdeaddons/kdeaddons-3.1_alpha1.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons/kdeaddons-3.1_alpha1.ebuild,v 1.1 2002/07/12 22:07:34 danarmak Exp $
+inherit kde-dist || die
+
+DESCRIPTION="${DESCRIPTION}Addons"
+
+newdepend "~kde-base/kdebase-${PV}
+ ~kde-base/kdenetwork-${PV}
+ ~kde-base/kdemultimedia-${PV}
+ sdl? ( >=media-libs/libsdl-1.2 )
+ svga? ( media-libs/svgalib )"
+
+use sdl && myconf="$myconf --with-sdl --with-sdl-prefix=/usr" || myconf="$myconf --without-sdl --disable-sdltest"
+
+
diff --git a/kde-base/kdeadmin/files/digest-kdeadmin-3.1_alpha1 b/kde-base/kdeadmin/files/digest-kdeadmin-3.1_alpha1
new file mode 100644
index 000000000000..0a748419aa83
--- /dev/null
+++ b/kde-base/kdeadmin/files/digest-kdeadmin-3.1_alpha1
@@ -0,0 +1 @@
+MD5 bbfd60b5c196c470d676e73d0a808677 kdeadmin-3.0.6.tar.bz2 1356161
diff --git a/kde-base/kdeadmin/kdeadmin-3.1_alpha1.ebuild b/kde-base/kdeadmin/kdeadmin-3.1_alpha1.ebuild
new file mode 100644
index 000000000000..78cc1203f96c
--- /dev/null
+++ b/kde-base/kdeadmin/kdeadmin-3.1_alpha1.ebuild
@@ -0,0 +1,14 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeadmin/kdeadmin-3.1_alpha1.ebuild,v 1.1 2002/07/12 22:07:34 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="${DESCRIPTION}Administration"
+
+newdepend ">=app-arch/rpm-4.0.4-r1
+ dev-libs/popt
+ pam? ( >=sys-libs/pam-0.72 )"
+
+use pam && myconf="$myconf --with-pam" || myconf="$myconf --without-pam --with-shadow"
+myconf="$myconf --with-rpm"
+
diff --git a/kde-base/kdeartwork/files/digest-kdeartwork-3.1_alpha1 b/kde-base/kdeartwork/files/digest-kdeartwork-3.1_alpha1
new file mode 100644
index 000000000000..64c60248c42b
--- /dev/null
+++ b/kde-base/kdeartwork/files/digest-kdeartwork-3.1_alpha1
@@ -0,0 +1 @@
+MD5 5d77747480da10bca894317533bb6eb2 kdeartwork-3.0.6.tar.bz2 12258106
diff --git a/kde-base/kdeartwork/kdeartwork-3.1_alpha1.ebuild b/kde-base/kdeartwork/kdeartwork-3.1_alpha1.ebuild
new file mode 100644
index 000000000000..05f322a48dfd
--- /dev/null
+++ b/kde-base/kdeartwork/kdeartwork-3.1_alpha1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeartwork/kdeartwork-3.1_alpha1.ebuild,v 1.1 2002/07/12 22:07:34 danarmak Exp $
+inherit kde-dist
+
+newdepend "opengl? ( virtual/opengl ) >=kde-base/kdebase-${PV}"
+
+DESCRIPTION="${DESCRIPTION}Artwork"
+
+myconf="$myconf --with-dpms"
+use opengl && myconf="$myconf --with-gl" || myconf="$myconf --without-gl"
+
+#src_unpack() {
+#
+# base_src_unpack
+#
+# cd ${S}
+# # added to fix GL problems within xscreensavers
+# patch -p1 < ${FILESDIR}/kdeartwork-screensaver.patch
+#
+#}
+#
+#src_install() {
+# dodir ${KDEDIR}/share/apps/kthememgr/Themes
+# kde_src_install all
+#}
diff --git a/kde-base/kdebase/files/digest-kdebase-3.1_alpha1 b/kde-base/kdebase/files/digest-kdebase-3.1_alpha1
new file mode 100644
index 000000000000..17be38c283e2
--- /dev/null
+++ b/kde-base/kdebase/files/digest-kdebase-3.1_alpha1
@@ -0,0 +1 @@
+MD5 feef9da060d4ce425b1ce046dffc4f2b kdebase-3.0.6.tar.bz2 13123850
diff --git a/kde-base/kdebase/kdebase-3.1_alpha1.ebuild b/kde-base/kdebase/kdebase-3.1_alpha1.ebuild
new file mode 100644
index 000000000000..205802f40e23
--- /dev/null
+++ b/kde-base/kdebase/kdebase-3.1_alpha1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.1_alpha1.ebuild,v 1.1 2002/07/12 22:07:34 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="${DESCRIPTION}Base"
+
+newdepend ">=media-sound/cdparanoia-3.9.8
+ ldap? ( >=net-nds/openldap-1.2 )
+ pam? ( >=sys-libs/pam-0.73 )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ encode? ( >=media-sound/lame-3.89b )
+ oggvorbis? ( >=media-libs/libvorbis-1.0_beta1 )
+ cups? ( net-print/cups )
+ ssl? ( >=dev-libs/openssl-0.9.6b )
+ opengl? ( virtual/opengl )
+ samba? ( net-fs/samba )"
+# lm_sensors? ( ?/lm_sensors ) # ebuild doesn't exist yet
+
+myconf="$myconf --with-dpms --with-cdparanoia"
+
+use ldap && myconf="$myconf --with-ldap" || myconf="$myconf --without-ldap"
+use pam && myconf="$myconf --with-pam" || myconf="$myconf --with-shadow"
+use motif && myconf="$myconf --with-motif" || myconf="$myconf --without-motif"
+use encode && myconf="$myconf --with-lame" || myconf="$myconf --without-lame"
+use cups && myconf="$myconf --with-cups" || myconf="$myconf --disable-cups"
+use oggvorbis && myconf="$myconf --with-vorbis" || myconf="$myconf --without-vorbis"
+use opengl && myconf="$myconf --with-gl" || myconf="$myconf --without-gl"
+use ssl && myconf="$myconf --with-ssl" || myconf="$myconf --without-ssl"
+use pam && myconf="$myconf --with-pam=yes" || myconf="$myconf --with-pam=no --with-shadow"
+
+src_install() {
+
+ kde_src_install
+
+ insinto /etc/pam.d
+ newins ${FILESDIR}/kscreensaver.pam kscreensaver
+ newins kde.pamd kde
+
+ # startkde script
+ cd ${D}/${KDEDIR}/bin
+ patch -p0 < ${FILESDIR}/startkde-${PVR}-gentoo.diff || die
+ mv startkde startkde.orig
+ sed -e "s:_KDEDIR_:${KDEDIR}:" startkde.orig > startkde
+ rm startkde.orig
+ chmod a+x startkde
+
+ # x11 session script
+ cd ${T}
+ echo "#!/bin/sh
+${KDEDIR}/bin/startkde" > kde-${PV}
+ chmod a+x kde-${PV}
+ # old scheme - compatibility
+ exeinto /usr/X11R6/bin/wm
+ doexe kde-${PV}
+ # new scheme - for now >=xfree-4.2-r3 only
+ exeinto /etc/X11/Sessions
+ doexe kde-${PV}
+
+ cd ${D}/${KDEDIR}/share/config/kdm || die
+ mv kdmrc kdmrc.orig
+ sed -e 's:SessionTypes=:SessionTypes=kde-${PV},:' kdmrc.orig > kdmrc
+ rm kdmrc.orig
+
+ #backup splashscreen images, so they can be put back when unmerging
+ #mosfet or so.
+ if [ ! -d ${KDEDIR}/share/apps/ksplash.default ]
+ then
+ cd ${D}/${KDEDIR}/share/apps
+ cp -rf ksplash/ ksplash.default
+ fi
+
+ # Show gnome icons when choosing new icon for desktop shortcut
+ mkdir -p ${D}/usr/share/pixmaps
+ mv ${D}/${KDEDIR}/share/apps/kdesktop/pics/* ${D}/usr/share/pixmaps/
+ rm -rf ${D}/${KDEDIR}/share/apps/kdesktop/pics/
+ cd ${D}/${KDEDIR}/share/apps/kdesktop/
+ ln -sf /usr/share/pixmaps/ pics
+
+ rmdir ${D}/${KDEDIR}/share/templates/.source/emptydir
+
+}
+
+pkg_postinst() {
+ mkdir -p ${KDEDIR}/share/templates/.source/emptydir
+}
diff --git a/kde-base/kdebindings/files/digest-kdebindings-3.1_alpha1 b/kde-base/kdebindings/files/digest-kdebindings-3.1_alpha1
new file mode 100644
index 000000000000..de4ac8f3102f
--- /dev/null
+++ b/kde-base/kdebindings/files/digest-kdebindings-3.1_alpha1
@@ -0,0 +1 @@
+MD5 a3f18d02c2a567fb8c17aadef7e1ee84 kdebindings-3.0.6.tar.bz2 6142681
diff --git a/kde-base/kdebindings/kdebindings-3.1_alpha1.ebuild b/kde-base/kdebindings/kdebindings-3.1_alpha1.ebuild
new file mode 100644
index 000000000000..00ab2520a2fd
--- /dev/null
+++ b/kde-base/kdebindings/kdebindings-3.1_alpha1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings/kdebindings-3.1_alpha1.ebuild,v 1.1 2002/07/12 22:07:34 danarmak Exp $
+
+# TODO: add gnustep, objc bindings
+inherit kde-dist
+
+DESCRIPTION="${DESCRIPTION}Bindings"
+
+newdepend "~kde-base/kdebase-${PV}
+ =x11-libs/gtk+-1.2*
+ sys-devel/perl
+ python? ( dev-lang/python )
+ java? ( virtual/jdk )
+ =x11-libs/gtk+-1.2*
+ =dev-libs/glib-1.2*
+ ~kde-base/kdenetwork-${PV}
+ mozilla? ( net-www/mozilla )"
+
+use python || myconf="$myconf --without-python"
+use java && myconf="$myconf --with-java=$(java-config --jdk-home)" || myconf="$myconf --without-java"
+#myconf="$myconf --enable-objc"
+
+export LIBPYTHON="`python-config`"
+
+src_unpack()
+{
+ base_src_unpack
+
+ if [ -z "`use mozilla`" ]; then
+ # disable mozilla bindings/xpart
+ cd ${S}
+ cp configure configure.orig
+ sed -e 's:mozilla_incldirs=:# mozilla_incldirs=:' configure.orig > configure
+ chmod +x configure
+ fi
+}
diff --git a/kde-base/kdeedu/files/digest-kdeedu-3.1_alpha1 b/kde-base/kdeedu/files/digest-kdeedu-3.1_alpha1
new file mode 100644
index 000000000000..497ddff458b5
--- /dev/null
+++ b/kde-base/kdeedu/files/digest-kdeedu-3.1_alpha1
@@ -0,0 +1 @@
+MD5 d4ef008f28c644a97aa4d4d7bdb177ef kdeedu-3.0.6.tar.bz2 17553553
diff --git a/kde-base/kdeedu/kdeedu-3.1_alpha1.ebuild b/kde-base/kdeedu/kdeedu-3.1_alpha1.ebuild
new file mode 100644
index 000000000000..08989e737f43
--- /dev/null
+++ b/kde-base/kdeedu/kdeedu-3.1_alpha1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeedu/kdeedu-3.1_alpha1.ebuild,v 1.1 2002/07/12 22:07:34 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="${DESCRIPTION}Educational"
+
+myconf="$myconf --disable-final"
+#src_unpack() {
+#
+# base_src_unpack
+#
+# kde_sandbox_patch ${S}/klettres/klettres
+#
+#}
+
+#src_compile() {
+#
+# # build fails with -fomit-frame-pointer optimization in kgeo
+#
+# CFLAGS2="$CFLAGS"
+# CXXFLAGS2="$CXXFLAGS"
+# CFLAGS=${CFLAGS/-fomit-frame-pointer}
+# CXXFLAGS=${CXXFLAGS/-fomit-frame-pointer}
+#
+# kde_src_compile myconf configure
+#
+# cd ${S}/kgeo
+# emake || die
+#
+# CFLAGS="$CFLAGS2"
+# CXXFLAGS="$CXXFLAGS2"
+#
+# kde_src_compile all
+#
+#}
diff --git a/kde-base/kdegames/files/digest-kdegames-3.1_alpha1 b/kde-base/kdegames/files/digest-kdegames-3.1_alpha1
new file mode 100644
index 000000000000..1f161100faa0
--- /dev/null
+++ b/kde-base/kdegames/files/digest-kdegames-3.1_alpha1
@@ -0,0 +1 @@
+MD5 5101afd324eec09fd474ad64f117ff76 kdegames-3.0.6.tar.bz2 7707594
diff --git a/kde-base/kdegames/kdegames-3.1_alpha1.ebuild b/kde-base/kdegames/kdegames-3.1_alpha1.ebuild
new file mode 100644
index 000000000000..257df03cd05e
--- /dev/null
+++ b/kde-base/kdegames/kdegames-3.1_alpha1.ebuild
@@ -0,0 +1,6 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegames/kdegames-3.1_alpha1.ebuild,v 1.1 2002/07/12 22:07:34 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="${DESCRIPTION}Games"
diff --git a/kde-base/kdegraphics/files/digest-kdegraphics-3.1_alpha1 b/kde-base/kdegraphics/files/digest-kdegraphics-3.1_alpha1
new file mode 100644
index 000000000000..f792acb8f251
--- /dev/null
+++ b/kde-base/kdegraphics/files/digest-kdegraphics-3.1_alpha1
@@ -0,0 +1 @@
+MD5 ab509f4f923ab3242f0a35e4884cbc19 kdegraphics-3.0.6.tar.bz2 3321376
diff --git a/kde-base/kdegraphics/kdegraphics-3.1_alpha1.ebuild b/kde-base/kdegraphics/kdegraphics-3.1_alpha1.ebuild
new file mode 100644
index 000000000000..a11f3c84a20d
--- /dev/null
+++ b/kde-base/kdegraphics/kdegraphics-3.1_alpha1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/kdegraphics-3.1_alpha1.ebuild,v 1.1 2002/07/12 22:07:34 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="${DESCRIPTION}Graphics"
+
+newdepend "gphoto2? ( >=media-gfx/gphoto2-2.0_beta1 >=media-libs/libgpio-20010607 )
+ sys-devel/perl
+ media-gfx/sane-backends
+ tetex? ( >=app-text/tetex-1.0.7 )
+ media-libs/imlib"
+
+use gphoto2 && myconf="$myconf --with-kamera --with-gphoto2-includes=/usr/include/gphoto2 \
+ --with-gphoto2-libraries=/usr/lib/gphoto2 \
+ --with-gpio --with-gpio-includes=/usr/include \
+ --with-gpio-libraries=/usr/lib" || myconf="$myconf --without-kamera"
+
+use tetex && myconf="$myconf --with-system-kpathsea --with-tex-datadir=/usr/share"
+
+myconf="$myconf --with-imlib --with-imlib-config=/usr/bin"
+
diff --git a/kde-base/kdelibs/files/digest-kdelibs-3.1_alpha1 b/kde-base/kdelibs/files/digest-kdelibs-3.1_alpha1
new file mode 100644
index 000000000000..67ed274571f2
--- /dev/null
+++ b/kde-base/kdelibs/files/digest-kdelibs-3.1_alpha1
@@ -0,0 +1 @@
+MD5 c5b17936a30cf7fbed07e4a1939db5de kdelibs-3.0.6.tar.bz2 7993291
diff --git a/kde-base/kdelibs/kdelibs-3.1_alpha1.ebuild b/kde-base/kdelibs/kdelibs-3.1_alpha1.ebuild
new file mode 100644
index 000000000000..dd595ac2e845
--- /dev/null
+++ b/kde-base/kdelibs/kdelibs-3.1_alpha1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.1_alpha1.ebuild,v 1.1 2002/07/12 22:07:34 danarmak Exp $
+inherit kde kde.org
+#don't inherit kde-base or kde-dist! it calls need-kde which adds kdelibs to depend!
+
+# check need for glib >=1.3.3 (we have 1.2.10 only; configure has no glib flag but searches for it)
+
+DESCRIPTION="KDE ${PV} - Libraries"
+HOMEPAGE="http//www.kde.org/"
+S=${WORKDIR}/kdelibs-3.0.6
+SLOT="3"
+
+# kde.eclass has kdelibs in DEPEND, and we can't have that in here. so we recreate the entire
+# DEPEND from scratch.
+DEPEND=""
+RDEPEND=""
+newdepend "sys-devel/perl
+ >=media-libs/audiofile-0.1.9
+ >=sys-apps/bzip2-1.0.1
+ >=dev-libs/libxslt-1.0.7
+ >=dev-libs/libpcre-3.5
+ >=dev-libs/libxml2-2.4.10
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ alsa? ( >=media-libs/alsa-lib-0.5.9 )
+ cups? ( >=net-print/cups-1.1.14 )
+ >=media-libs/tiff-3.5.5
+ app-admin/fam-oss
+ >=kde-base/arts-1.1.0
+ app-text/ghostscript"
+
+newdepend "/c"
+newdepend "/autotools"
+
+RDEPEND="$RDEPEND
+ app-text/sgml-common
+ cups? ( net-print/cups )
+ dev-lang/python"
+
+myconf="$myconf --enable-final --with-distribution=Gentoo --enable-libfam --enable-dnotify "
+
+qtver-from-kdever ${PV}
+need-qt $selected_version
+
+set-kdedir $PV
+
+src_unpack() {
+
+ base_src_unpack
+ kde_sandbox_patch ${S}/kio/misc/kpac
+
+}
+
+src_compile() {
+
+ kde_src_compile myconf
+
+ use ipv6 || myconf="$myconf --with-ipv6-lookup=no"
+ use ssl && myconf="$myconf --with-ssl-dir=/usr" || myconf="$myconf --without-ssl"
+ use alsa && myconf="$myconf --with-alsa" || myconf="$myconf --without-alsa"
+ use cups && myconf="$myconf --enable-cups" || myconf="$myconf --disable-cups"
+
+ [ "$ARCH" != "ppc" ] && \
+ [ "$ARCH" != "sparc" ] && [ "$ARCH" != "sparc64" ] && \
+ myconf="$myconf --enable-fast-malloc=full"
+
+ kde_src_compile configure make
+
+}
+
+src_install() {
+
+ kde_src_install
+
+ dohtml *.html
+
+ dodir /etc/env.d
+
+ if [ "$PREFIX" != "/usr/kde/3" ]; then
+echo "PATH=${PREFIX}/bin:/usr/kde/3/bin
+ROOTPATH=${PREFIX}/sbin:${PREFIX}/bin:/usr/kde/3/sbin:/usr/kde/3/bin
+LDPATH=${PREFIX}/lib:/usr/kde/3/lib
+KDEDIRS=${PREFIX}:/usr/kde/3" > ${D}/etc/env.d/50kdelibs-${PV}
+ else
+echo "PATH=${PREFIX}/bin
+ROOTPATH=${PREFIX}/sbin:${PREFIX}/bin
+LDPATH=${PREFIX}/lib
+KDEDIRS=${PREFIX}:/usr/kde/3" > ${D}/etc/env.d/50kdelibs-${PV}
+ fi
+
+ echo "KDEDIR=$PREFIX" > ${D}/etc/env.d/55kdedir-${PV}
+
+}
+
+
diff --git a/kde-base/kdemultimedia/files/digest-kdemultimedia-3.1_alpha1 b/kde-base/kdemultimedia/files/digest-kdemultimedia-3.1_alpha1
new file mode 100644
index 000000000000..d7c075931456
--- /dev/null
+++ b/kde-base/kdemultimedia/files/digest-kdemultimedia-3.1_alpha1
@@ -0,0 +1 @@
+MD5 4e133e15b387031d8edace876d39ea6b kdemultimedia-3.0.6.tar.bz2 5683421
diff --git a/kde-base/kdemultimedia/kdemultimedia-3.1_alpha1.ebuild b/kde-base/kdemultimedia/kdemultimedia-3.1_alpha1.ebuild
new file mode 100644
index 000000000000..f8993c21d03a
--- /dev/null
+++ b/kde-base/kdemultimedia/kdemultimedia-3.1_alpha1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia/kdemultimedia-3.1_alpha1.ebuild,v 1.1 2002/07/12 22:07:34 danarmak Exp $
+inherit kde-dist flag-o-matic
+
+DESCRIPTION="${DESCRIPTION}Multimedia"
+
+newdepend ">=sys-libs/ncurses-5.2
+ >=media-sound/cdparanoia-3.9.8
+ >=media-libs/libvorbis-1.0_beta4
+ >=media-video/xanim-2.80.1
+ nas? ( >=media-libs/nas-1.4.1 )
+ esd? ( >=media-sound/esound-0.2.22 )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ gtk? ( =x11-libs/gtk+-1.2* )
+ slang? ( >=sys-libs/slang-1.4.4 )
+ app-cdr/cdrtools
+ >=app-cdr/cdrdao-1.1.5
+ >=media-sound/mpg123-0.59r
+ tcltk? ( >=dev-lang/tk-8.0.5-r2 )
+ >=dev-libs/glib-1.3.3
+ >=media-libs/xine-lib-0.9.9
+ oggvorbis? ( media-ilbs/libvorbis )"
+# alsa? ( >=media-libs/alsa-lib-0.5.9 )"
+
+replace-flags "-O3" "-O2"
+
+myaudio="--enable-audio=oss"
+myinterface="--enable-interface=xaw,ncurses"
+myconf="$myconf --enable-xaw --enable-ncurses --with-xine-prefix=/usr"
+
+#use alsa && myconf="$myconf --with-alsa --with-arts-alsa" && myaudio="$myaudio,alsa" ||
+myconf="$myconf --without-alsa --disable-alsa"
+use nas && myaudio="$myaudio,nas --with-nas-library=/usr/X11R6/lib/libaudio.so --with-nas-includes=/usr/X11R6/include" || myconf="$myconf --disable-nas"
+use esd && myaudio="$myaudio,esd" || myconf="$myconf --disable-esd"
+use motif && myinterface="$myinterface,motif" && myconf="$myconf --enable-motif"
+use gtk && myinterface="$myinterface,gtk" && myconf="$myconf --enable-gtk"
+use slang && myinterface="$myinterface,slang" && myconf="$myconf --enable-slang"
+use tcltk && myinterface="$myinterface,tcltk" && myconf="$myconf --enable-tcltk"
+use oggvorbis && myconf="$myconf --with-vorbis=/usr" || myconf="$myconf --without-vorbis"
+
+myconf="$myconf $myaudio $myinterface --disable-final"
+
+src_unpack() {
+
+ base_src_unpack
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-gentoo-timidity.diff || die
+
+}
+
+pkg_postinst() {
+
+ if [ -n "`use alsa`" ]; then
+ einfo "WARNING: alsa support has been removed becuase of a bug in kdemm sources.
+For further information see bug #2324 on bugs.gentoo.org and bug #39574 on bugs.kde.org.
+Meanwhile, you can use the alsa oss emulation."
+ fi
+ return 0
+
+}
diff --git a/kde-base/kdenetwork/files/digest-kdenetwork-3.1_alpha1 b/kde-base/kdenetwork/files/digest-kdenetwork-3.1_alpha1
new file mode 100644
index 000000000000..af30a334dfc2
--- /dev/null
+++ b/kde-base/kdenetwork/files/digest-kdenetwork-3.1_alpha1
@@ -0,0 +1 @@
+MD5 9eeaf67cb70d0db9964a86cc83c3d451 kdenetwork-3.0.6.tar.bz2 4701489
diff --git a/kde-base/kdenetwork/kdenetwork-3.1_alpha1.ebuild b/kde-base/kdenetwork/kdenetwork-3.1_alpha1.ebuild
new file mode 100644
index 000000000000..64d74b1396e0
--- /dev/null
+++ b/kde-base/kdenetwork/kdenetwork-3.1_alpha1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/kdenetwork-3.1_alpha1.ebuild,v 1.1 2002/07/12 22:07:34 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="${DESCRIPTION}Network"
+
+myconf="$myconf --disable-final"
+
+src_install() {
+
+ kde_src_install
+
+ chmod +s ${D}/${KDEDIR}/bin/reslisa
+
+ # empty config file needed for lisa to work with default settings
+ touch ${D}/etc/lisarc
+
+ # lisa, reslisa initscripts
+ dodir /etc/init.d
+ sed -e "s:_KDEDIR_:${KDEDIR}:g" ${FILESDIR}/lisa > ${D}/etc/init.d/lisa
+ sed -e "s:_KDEDIR_:${KDEDIR}:g" ${FILESDIR}/reslisa > ${D}/etc/init.d/reslisa
+ chmod +x ${D}/etc/init.d/*
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/lisa.conf lisa
+ newins ${FILESDIR}/reslisa.conf reslisa
+
+}
+
diff --git a/kde-base/kdepim/files/digest-kdepim-3.1_alpha1 b/kde-base/kdepim/files/digest-kdepim-3.1_alpha1
new file mode 100644
index 000000000000..72ea7a9f9772
--- /dev/null
+++ b/kde-base/kdepim/files/digest-kdepim-3.1_alpha1
@@ -0,0 +1 @@
+MD5 cbe6fb333fa1e44903e19e9220bad687 kdepim-3.0.6.tar.bz2 3547444
diff --git a/kde-base/kdepim/kdepim-3.1_alpha1.ebuild b/kde-base/kdepim/kdepim-3.1_alpha1.ebuild
new file mode 100644
index 000000000000..d277938d6039
--- /dev/null
+++ b/kde-base/kdepim/kdepim-3.1_alpha1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim/kdepim-3.1_alpha1.ebuild,v 1.1 2002/07/12 22:07:34 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="${DESCRIPTION}PIM"
+
+DEPEND="$DEPEND sys-devel/perl"
+
+newdepend "pda? ( >=dev-libs/pilot-link-0.9.0 )"
+
+use pda && myconf="$myconf --with-extra-includes=/usr/include/libpisock"
+
+src_install() {
+ kde_src_install
+ docinto html
+ dodoc *.html
+}
diff --git a/kde-base/kdesdk/files/digest-kdesdk-3.1_alpha1 b/kde-base/kdesdk/files/digest-kdesdk-3.1_alpha1
new file mode 100644
index 000000000000..de383199596c
--- /dev/null
+++ b/kde-base/kdesdk/files/digest-kdesdk-3.1_alpha1
@@ -0,0 +1 @@
+MD5 40b7df5eab17635bf563868d49697a78 kdesdk-3.0.6.tar.bz2 1925772
diff --git a/kde-base/kdesdk/kdesdk-3.1_alpha1.ebuild b/kde-base/kdesdk/kdesdk-3.1_alpha1.ebuild
new file mode 100644
index 000000000000..1a9625766eac
--- /dev/null
+++ b/kde-base/kdesdk/kdesdk-3.1_alpha1.ebuild
@@ -0,0 +1,8 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesdk/kdesdk-3.1_alpha1.ebuild,v 1.1 2002/07/12 22:07:34 danarmak Exp $
+
+inherit kde-dist
+
+DESCRIPTION="${DESCRIPTION}SDK"
+
diff --git a/kde-base/kdetoys/files/digest-kdetoys-3.1_alpha1 b/kde-base/kdetoys/files/digest-kdetoys-3.1_alpha1
new file mode 100644
index 000000000000..4669c6b94311
--- /dev/null
+++ b/kde-base/kdetoys/files/digest-kdetoys-3.1_alpha1
@@ -0,0 +1 @@
+MD5 76e0050189550573d5b6fab924e2392f kdetoys-3.0.6.tar.bz2 1387926
diff --git a/kde-base/kdetoys/kdetoys-3.1_alpha1.ebuild b/kde-base/kdetoys/kdetoys-3.1_alpha1.ebuild
new file mode 100644
index 000000000000..3d1baf093d03
--- /dev/null
+++ b/kde-base/kdetoys/kdetoys-3.1_alpha1.ebuild
@@ -0,0 +1,8 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdetoys/kdetoys-3.1_alpha1.ebuild,v 1.1 2002/07/12 22:07:34 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="${DESCRIPTION}Toys"
+
+
diff --git a/kde-base/kdeutils/files/digest-kdeutils-3.1_alpha1 b/kde-base/kdeutils/files/digest-kdeutils-3.1_alpha1
new file mode 100644
index 000000000000..c2dadbf367a6
--- /dev/null
+++ b/kde-base/kdeutils/files/digest-kdeutils-3.1_alpha1
@@ -0,0 +1 @@
+MD5 026ea8a9f5a4063921aa148f6a9bf3f1 kdeutils-3.0.6.tar.bz2 1716427
diff --git a/kde-base/kdeutils/kdeutils-3.1_alpha1.ebuild b/kde-base/kdeutils/kdeutils-3.1_alpha1.ebuild
new file mode 100644
index 000000000000..3b525f55c16a
--- /dev/null
+++ b/kde-base/kdeutils/kdeutils-3.1_alpha1.ebuild
@@ -0,0 +1,8 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeutils/kdeutils-3.1_alpha1.ebuild,v 1.1 2002/07/12 22:07:35 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="${DESCRIPTION}Utilities"
+
+echo SLOT=$SLOT \ No newline at end of file