summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/portage/Manifest18
-rw-r--r--sys-apps/portage/files/digest-portage-2.0.51_rc71
-rw-r--r--sys-apps/portage/portage-2.0.51_rc6.ebuild8
-rw-r--r--sys-apps/portage/portage-2.0.51_rc7.ebuild349
4 files changed, 369 insertions, 7 deletions
diff --git a/sys-apps/portage/Manifest b/sys-apps/portage/Manifest
index a9f6b8942c47..0c752b27386a 100644
--- a/sys-apps/portage/Manifest
+++ b/sys-apps/portage/Manifest
@@ -1,7 +1,19 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 6e9543fc4a21271f3c86ae745a8dde2e portage-2.0.51_rc6.ebuild 11806
+MD5 c88fcc450a11b1fb9667ff06e20e032a portage-2.0.51_rc7.ebuild 11806
+MD5 b72e7a2808265094e34eada672e50240 portage-2.0.50-r11.ebuild 11577
MD5 ba4ae80e5e6cf58aac9c5aa1cc5f777e ChangeLog 411
MD5 4ec0f0ae9676b9d2d227d737d508306b metadata.xml 165
-MD5 e1e2fe6098da06378ce8820eeacaf7ff portage-2.0.51_rc6.ebuild 11793
-MD5 b72e7a2808265094e34eada672e50240 portage-2.0.50-r11.ebuild 11577
-MD5 a754ca9e2eea9f8484bf5f93d339043a files/README.RESCUE 1911
MD5 5375f0805d4d56dc961ad81162854790 files/digest-portage-2.0.50-r11 71
MD5 0280081c01fecc4602a8cccf02abff6a files/digest-portage-2.0.51_rc6 71
+MD5 3da3469e2b40b9a6b37fd54b2e6c7b98 files/digest-portage-2.0.51_rc7 71
+MD5 a754ca9e2eea9f8484bf5f93d339043a files/README.RESCUE 1911
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.6 (GNU/Linux)
+
+iD8DBQFBW3dhBDOEqLMd+jQRAtovAKCqcZjbmojUU6c+Q+n/Xb8EseVujwCdHQFj
+VO/xKQLBNY+VtR7smoC3wJo=
+=MBJh
+-----END PGP SIGNATURE-----
diff --git a/sys-apps/portage/files/digest-portage-2.0.51_rc7 b/sys-apps/portage/files/digest-portage-2.0.51_rc7
new file mode 100644
index 000000000000..98e9d74c5bc2
--- /dev/null
+++ b/sys-apps/portage/files/digest-portage-2.0.51_rc7
@@ -0,0 +1 @@
+MD5 a2059069096ef268c4dccdabb0e4c299 portage-2.0.51_rc7.tar.bz2 274572
diff --git a/sys-apps/portage/portage-2.0.51_rc6.ebuild b/sys-apps/portage/portage-2.0.51_rc6.ebuild
index 04b45ee111f0..948cceff05fb 100644
--- a/sys-apps/portage/portage-2.0.51_rc6.ebuild
+++ b/sys-apps/portage/portage-2.0.51_rc6.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51_rc6.ebuild,v 1.3 2004/09/27 19:26:10 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51_rc6.ebuild,v 1.4 2004/09/30 03:02:10 carpaski Exp $
IUSE="build selinux"
-inherit eutils flag-o-matic
+inherit flag-o-matic
# If the old /lib/sandbox.so is in /etc/ld.so.preload, it can
# cause everything to segfault !!
@@ -120,8 +120,8 @@ src_install() {
dosym emake /usr/lib/portage/bin/pmake
doexe ${S}/src/tbz2tool
- if use macos || use ppc-macos ; then
- ewarn "Not installing sandbox on Mac OS X"
+ if use macos || use ppc-macos || use x86-fbsd; then
+ ewarn "Not installing sandbox on ${ARCH}"
else
#install sandbox
cd ${S}/src/sandbox-1.1
diff --git a/sys-apps/portage/portage-2.0.51_rc7.ebuild b/sys-apps/portage/portage-2.0.51_rc7.ebuild
new file mode 100644
index 000000000000..8f4d225c9612
--- /dev/null
+++ b/sys-apps/portage/portage-2.0.51_rc7.ebuild
@@ -0,0 +1,349 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51_rc7.ebuild,v 1.1 2004/09/30 03:02:10 carpaski Exp $
+
+IUSE="build selinux"
+inherit flag-o-matic
+
+# If the old /lib/sandbox.so is in /etc/ld.so.preload, it can
+# cause everything to segfault !!
+export SANDBOX_DISABLED="1"
+
+S=${WORKDIR}/${PF}
+SLOT="0"
+DESCRIPTION="The Portage Package Management System (Similar to BSD's ports). The primary package management and distribution system for Gentoo."
+SRC_URI="http://zarquon.twobit.net/gentoo/portage/${PF}.tar.bz2 http://gentoo.twobit.net/portage/${PF}.tar.bz2 mirror://gentoo/${PF}.tar.bz2"
+HOMEPAGE="http://www.gentoo.org"
+RESTRICT="nomirror mirror"
+
+# Contact carpaski with a reason before you modify any of these.
+#KEYWORDS=" alpha amd64 arm hppa ia64 macos mips ppc ppc-macos ppc64 s390 sparc x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~macos ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sparc ~x86"
+
+LICENSE="GPL-2"
+RDEPEND="!build? ( >=sys-apps/sed-4.0.5 dev-python/python-fchksum >=dev-lang/python-2.2.1 sys-apps/debianutils >=app-shells/bash-2.05a ) selinux? ( >=dev-python/python-selinux-2.15 )"
+
+python_version() {
+ local tmpstr="$(/usr/bin/python -V 2>&1 )"
+ export PYVER_ALL="${tmpstr#Python }"
+
+ export PYVER_MAJOR=$(echo ${PYVER_ALL} | cut -d. -f1)
+ export PYVER_MINOR=$(echo ${PYVER_ALL} | cut -d. -f2)
+ export PYVER_MICRO=$(echo ${PYVER_ALL} | cut -d. -f3-)
+ export PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
+}
+
+check_multilib() {
+ has_m32
+ if [ "$?" == 0 ]; then
+ einfo "Found valid multilib environment."
+ einfo "Building with multilib support."
+ export MULTILIB="1"
+ else
+ ewarn "No valid multilib environment found!"
+ ewarn "Building without multilib support. If"
+ ewarn "you want to have multilib support,"
+ ewarn "emerge gcc with \"multilib\" in your"
+ ewarn "useflags."
+ sleep 5
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ cd ${S}/src; ${CC:-gcc} ${CFLAGS} tbz2tool.c -o tbz2tool
+ cd ${S}/src/sandbox-1.1
+ case ${ARCH} in
+ "x86")
+ make CFLAGS="-march=i386 -O1 -pipe" || die
+ ;;
+ "amd64")
+ check_multilib
+ make CFLAGS="-O2 -pipe" HAVE_64BIT_ARCH="${MULTILIB}" || die
+ ;;
+ *)
+ if useq macos || useq ppc-macos || useq x86-fbsd; then
+ ewarn "NOT BUILDING SANDBOX ON $ARCH"
+ else
+ make || die
+ fi
+ ;;
+ esac
+ cd ${S}/bin
+}
+
+src_install() {
+ #config files
+ cd ${S}/cnf
+ insinto /etc
+ if [ -f "make.globals.${ARCH}" ]; then
+ newins make.globals.${ARCH} make.globals
+ newins make.conf.${ARCH} make.conf.example
+ else
+ eerror ""
+ eerror "Portage does not have an arch-specific configuration for this arch."
+ eerror "Please notify the arch maintainer about this issue. Using generic."
+ eerror ""
+ sleep 3
+ doins make.globals
+ newins make.conf make.conf.example
+ fi
+
+ doins etc-update.conf dispatch-conf.conf
+
+ #python modules
+ if [ -x "$(type -p python2.2)" ] || [ -x /usr/bin/python2.2 ]; then
+ cd ${S}/src/python-missingos
+ chmod +x setup.py
+ if [ -x "$(type -p python2.3)" ]; then
+ ./setup.py install --root ${D} || eerror "Failed to install missingos module -- python2.2 broken?"
+ else
+ ./setup.py install --root ${D} || die "Failed to install missingos module"
+ fi
+ fi
+
+
+ dodir /usr/lib/portage/pym
+ cd ${S}/pym
+ insinto /usr/lib/portage/pym
+ doins *.py
+
+ #binaries, libraries and scripts
+ dodir /usr/lib/portage/bin
+ cd ${S}/bin
+ exeinto /usr/lib/portage/bin
+ doexe *
+ dosym emake /usr/lib/portage/bin/pmake
+ doexe ${S}/src/tbz2tool
+
+ if use macos || use ppc-macos || use x86-fbsd; then
+ ewarn "Not installing sandbox on ${ARCH}"
+ else
+ #install sandbox
+ cd ${S}/src/sandbox-1.1
+ make DESTDIR=${D} HAVE_64BIT_ARCH="${MULTILIB}" \
+ install || die "Failed to compile sandbox"
+ fi
+
+ #symlinks
+ dodir /usr/bin /usr/sbin
+ dosym ../lib/portage/bin/emerge /usr/bin/emerge
+ dosym ../lib/portage/bin/pkgmerge /usr/sbin/pkgmerge
+ dosym ../lib/portage/bin/ebuild /usr/sbin/ebuild
+ dosym ../lib/portage/bin/ebuild.sh /usr/sbin/ebuild.sh
+
+ dosym ../lib/portage/bin/etc-update /usr/sbin/etc-update
+ dosym ../lib/portage/bin/dispatch-conf /usr/sbin/dispatch-conf
+ dosym ../lib/portage/bin/archive-conf /usr/sbin/archive-conf
+ dosym ../lib/portage/bin/fixpackages /usr/sbin/fixpackages
+
+ dosym ../lib/portage/bin/env-update /usr/sbin/env-update
+ dosym ../lib/portage/bin/xpak /usr/bin/xpak
+ dosym ../lib/portage/bin/repoman /usr/bin/repoman
+ dosym ../lib/portage/bin/tbz2tool /usr/bin/tbz2tool
+ dosym ../lib/portage/bin/portageq /usr/bin/portageq
+
+ dosym ../lib/portage/bin/g-cpan.pl /usr/bin/g-cpan.pl
+ dosym ../lib/portage/bin/quickpkg /usr/bin/quickpkg
+ dosym ../lib/portage/bin/regenworld /usr/sbin/regenworld
+ dosym ../lib/portage/bin/emerge-webrsync /usr/sbin/emerge-webrsync
+
+ dosym newins /usr/lib/portage/bin/donewins
+
+ # man pages
+ doman ${S}/man/*.[0-9]
+
+ # temp dir creation
+ dodir /var/tmp
+ chmod 1777 ${D}/var/tmp
+ touch ${D}/var/tmp/.keep
+
+ #documentation
+ dodoc ${S}/ChangeLog
+}
+
+
+pkg_preinst() {
+ if has livecvsportage $FEATURES; then
+ if [ "$ROOT" == "/" ]; then
+ rm -Rf "${IMAGE}"/usr/lib/portage/pym/*
+
+ mv "${IMAGE}"/usr/lib/portage/bin/{sandbox,tbz2tool} ${T}
+ rm -Rf "${IMAGE}"/usr/lib/portage/bin/*
+ mv "${T}"/{sandbox,tbz2tool} "${IMAGE}"/usr/lib/portage/bin/
+ fi
+ fi
+}
+
+pkg_postinst() {
+ local x
+
+ [ -f "${ROOT}etc/make.conf" ] || touch ${ROOT}etc/make.conf
+
+ #disable global sandbox if it's active (it's been deprecated)
+ if [ -f /etc/ld.so.preload ] ; then
+ cp /etc/ld.so.preload ${T}
+ grep -v libsandbox ${T}/ld.so.preload > /etc/ld.so.preload
+ fi
+
+ #remove possible previous sandbox files that could cause conflicts
+ if [ -d /usr/lib/sandbox ]; then
+ rm -f ${ROOT}/usr/lib/portage/bin/ebuild.sh.orig
+ rm -f ${ROOT}/usr/lib/portage/pym/portage.py.orig
+ rm -f ${ROOT}/usr/bin/sandbox
+ rm -rf ${ROOT}/usr/lib/sandbox
+ fi
+
+ #yank old cache files
+ if [ -d /var/cache/edb ]
+ then
+ rm -f /var/cache/edb/xcache.p
+ rm -f /var/cache/edb/mtimes
+ fi
+
+ install -o root -g portage -m 0755 -d "${ROOT}/etc/portage"
+ install -o root -g portage -m 2775 -d "${ROOT}/etc/portage/sets"
+ # u+rwx,g+srwx --- This is a secure directory for temp files.
+
+ install -o root -g portage -m 2770 -d "${ROOT}/var/lib/portage"
+ einfo "Checking ${ROOT}/var/lib/portage for bad/illegal files:"
+ find "${ROOT}/var/lib/portage" ! -group portage -o -perm -002 -print0 | ${XARGS} -0n 500 rm -Rvf
+
+ OLDWORLD="${ROOT}/var/cache/edb/world"
+ NEWWORLD="${ROOT}/var/lib/portage/world"
+
+ if [ ! -f "${NEWWORLD}" ]; then
+ cp "${OLDWORLD}" "${NEWWORLD}" && \
+ rm -f "${OLDWORLD}" && \
+ ln ../../lib/portage/world "${NEWWORLD}"
+ fi
+
+ if [ ! -f "/etc/portage/package.mask" ]; then
+ if [ -f "/etc/portage/profile/package.mask" ]; then
+ ln /etc/portage/profile/package.mask /etc/portage/package.mask
+ einfo "/etc/portage/profile/package.mask is now /etc/portage/package.mask"
+ einfo "a hardlink has been created to the new location if it exists in profiles"
+ einfo "already."
+ echo
+ fi
+ fi
+ echo
+
+ einfo "Feature additions are noted in help and make.conf descriptions."
+ echo
+ einfo "Update configs using 'etc-update' please. Maintaining current configs"
+ einfo "for portage and other system packages is fairly important for the"
+ einfo "continued health of your system."
+ echo
+ ewarn "NOTICE: There have been changes in the location of some internal files"
+ ewarn " to better match the FHS. The changes do not directly affect users"
+ ewarn " but please be advised that changing between versions of portage"
+ ewarn " with and without these changes may introduce some inconsistencies"
+ ewarn " in package data regarding 'world' and 'virtuals' (provides)."
+ echo
+ einfo " /var/cache/edb/world has moved to /var/lib/portage/world"
+ echo
+ einfo " /var/cache/edb/virtuals has been deprecated and is now calculated"
+ einfo " on demand. Strictly _USER_ modifications to virtuals may go into"
+ einfo " /etc/portage/profile/virtuals and will not be modified by portage."
+ echo
+
+ if [ -z "$PORTAGE_TEST" ]; then
+ for TICKER in 1 2 3 4 5 6 7 8 9 10; do
+ echo -ne "\a" ; sleep 0.$(( $RANDOM % 9 + 1)) &>/dev/null ; sleep 0,$(( $RANDOM % 9 + 1)) &>/dev/null
+ done
+ sleep 5
+
+ # Kill the existing counter and generate a new one.
+ echo -n "Recalculating the counter... "
+ mv /var/cache/edb/counter /var/cache/edb/counter.old
+ python -c 'import sys; sys.path = ["/usr/lib/portage/pym"]+sys.path; import portage; portage.db["/"]["vartree"].dbapi.counter_tick("/")' &>/dev/null
+ if [ -f /var/cache/edb/counter ] ; then
+ echo "Counter updated successfully."
+ rm -f /var/cache/edb/counter.old
+ else
+ echo "FAILED to update counter."
+ ls -l /var/cache/edb/counter.old
+ echo "!!! This is a problem."
+ mv /var/cache/edb/counter.old /var/cache/edb/counter
+ fi
+ fi # PORTAGE_TESTING
+
+ if [ ! -d "${ROOT}var/cache/edb/dep" ]
+ then
+ install -d -m2755 ${ROOT}var/cache/edb
+ install -d -m2775 -o root -g portage ${ROOT}var/cache/edb/dep
+ fi
+
+ # Old place of install
+ rm -f ${ROOT}usr/lib/python2.2/site-packages/portage.py[co]
+ rm -f ${ROOT}usr/lib/python2.2/site-packages/xpak.py[co]
+ rm -f ${ROOT}usr/lib/python2.2/site-packages/output.py[co]
+ rm -f ${ROOT}usr/lib/python2.2/site-packages/cvstree.py[co]
+ rm -f ${ROOT}usr/lib/python2.2/site-packages/getbinpkg.py[co]
+ rm -f ${ROOT}usr/lib/python2.2/site-packages/emergehelp.py[co]
+ rm -f ${ROOT}usr/lib/python2.2/site-packages/dispatch_conf.py[co]
+
+ # New old place of install
+ rm -f ${ROOT}usr/lib/portage/pym/*.py[co]
+
+ # we gotta re-compile these modules and deal with systems with clock skew (stale compiled files)
+ einfo "Compiling python modules..."
+ python -c 'import compileall; compile_path()' &> /dev/null
+ python -c "import compileall; compile_dir('${ROOT}usr/lib/portage/pym')" &> /dev/null
+
+ if has ccache $FEATURES && has userpriv $FEATURES; then
+ chown -R portage:portage /var/tmp/ccache &> /dev/null
+ chmod -R g+rws /var/tmp/ccache &>/dev/null
+ fi
+
+ if [ -d "${ROOT}usr/portage/distfiles" ]; then
+ find "${ROOT}usr/portage/distfiles" -type f -maxdepth 1 -print0 | \
+ ${XARGS} -0 -n 500 chgrp portage &> /dev/null
+
+ find "${ROOT}usr/portage/distfiles" -type f -maxdepth 1 -print0 | \
+ ${XARGS} -0 -n 500 chmod 0644 &> /dev/null
+
+ find "${ROOT}usr/portage/distfiles/cvs-src" -type f -maxdepth 1 -print0 | \
+ ${XARGS} -0 -n 500 chown portage &> /dev/null
+
+ find "${ROOT}usr/portage/distfiles/cvs-src" -type f -maxdepth 1 -print0 | \
+ ${XARGS} -0 -n 500 chmod u+w &> /dev/null
+
+ chmod 2775 "${ROOT}usr/portage/distfiles"
+ chmod 2775 "${ROOT}usr/portage/distfiles/cvs-src"
+ fi
+ if [ -d "${ROOT}/${PORTDIR}/distfiles" ]; then
+ find "${ROOT}/${PORTDIR}/distfiles" -type f -maxdepth 1 -print0 | \
+ ${XARGS} -0 -n 500 chgrp portage &> /dev/null
+
+ find "${ROOT}/${PORTDIR}/distfiles" -type f -maxdepth 1 -print0 | \
+ ${XARGS} -0 -n 500 chmod 0644 &> /dev/null
+
+ find "${ROOT}/${PORTDIR}/distfiles/cvs-src" -type f -maxdepth 1 -print0 | \
+ ${XARGS} -0 -n 500 chown portage &> /dev/null
+
+ find "${ROOT}/${PORTDIR}/distfiles/cvs-src" -type f -maxdepth 1 -print0 | \
+ ${XARGS} -0 -n 500 chmod u+w &> /dev/null
+
+ chmod 2775 "${ROOT}/${PORTDIR}/distfiles"
+ chmod 2775 "${ROOT}/${PORTDIR}/distfiles/cvs-src"
+ fi
+
+ chown -R root:portage ${ROOT}var/cache/edb
+ find ${ROOT}var/cache/edb -type f -print0 | ${XARGS} -0 -n 500 chmod 664
+
+ for X in ${ROOT}etc/._cfg????_make.globals; do
+ # Overwrite the globals file automatically.
+ [ -e "${X}" ] && mv -f "${X}" "${ROOT}etc/make.globals"
+ done
+
+ einfo "You may run 'emerge metadata' to perform cache updates if you have"
+ einfo "changed versions of portage. This will provide a fairly dramatic"
+ einfo "speedup. Alternatively, you may 'emerge sync' if it has been more"
+ einfo "than 30 minutes since your last sync."
+}