summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-puzzle/drod-bin/Manifest8
-rw-r--r--games-puzzle/drod-bin/drod-bin-1.6.5.ebuild11
2 files changed, 10 insertions, 9 deletions
diff --git a/games-puzzle/drod-bin/Manifest b/games-puzzle/drod-bin/Manifest
index d5215f4cd280..36ff6eac6f1b 100644
--- a/games-puzzle/drod-bin/Manifest
+++ b/games-puzzle/drod-bin/Manifest
@@ -1,7 +1,7 @@
-MD5 35563c9ef364dd0037bd40483d78636f drod-bin-1.6.3.ebuild 1037
-MD5 664b3e5e1eb4f00d7cb51530eebabd4d drod-bin-1.6.5.ebuild 1215
-MD5 d5f38c7f7a985bc78f85f44ca8c7b954 ChangeLog 788
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 da1e0cc0f61832593d45d38a7c04e852 files/install.patch 695
+MD5 d5f38c7f7a985bc78f85f44ca8c7b954 ChangeLog 788
+MD5 35563c9ef364dd0037bd40483d78636f drod-bin-1.6.3.ebuild 1037
+MD5 fdceebb6567ae485ca9dae5b5a3a39a5 drod-bin-1.6.5.ebuild 1244
MD5 1d60558af7a36a55cb912df26fd8f3c4 files/digest-drod-bin-1.6.3 71
+MD5 da1e0cc0f61832593d45d38a7c04e852 files/install.patch 695
MD5 2e4c7a4449b6f2e69b6ed3930ece8878 files/digest-drod-bin-1.6.5 71
diff --git a/games-puzzle/drod-bin/drod-bin-1.6.5.ebuild b/games-puzzle/drod-bin/drod-bin-1.6.5.ebuild
index d6cede720883..ab1b3c6482db 100644
--- a/games-puzzle/drod-bin/drod-bin-1.6.5.ebuild
+++ b/games-puzzle/drod-bin/drod-bin-1.6.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/drod-bin/drod-bin-1.6.5.ebuild,v 1.5 2004/06/24 23:03:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/drod-bin/drod-bin-1.6.5.ebuild,v 1.6 2004/09/23 09:54:51 mr_bones_ Exp $
inherit games eutils
@@ -23,14 +23,14 @@ S="${WORKDIR}"
src_unpack() {
unpack_makeself ${A}
- cd ${S}
- epatch ${FILESDIR}/install.patch
+ cd "${S}"
+ epatch "${FILESDIR}/install.patch"
}
src_install() {
./install.sh -R "${D}" -g -rl -pg -I || die "install.sh failed"
- dodir ${GAMES_BINDIR}
- dosym /opt/drod/bin/drod ${GAMES_BINDIR}/drod
+ dodir "${GAMES_BINDIR}"
+ dosym /opt/drod/bin/drod "${GAMES_BINDIR}/drod"
prepgamesdirs
fperms 770 /opt/drod/bin/Data
}
@@ -42,6 +42,7 @@ pkg_preinst() {
}
pkg_postinst() {
+ games_pkg_postinst
if [ -d ${ROOT}/opt/drod/bin/Data.backup ] ; then
ewarn "Your saved games have been backed up to"
ewarn "/opt/drod/bin/Data.backup"