summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-libs/wxGTK/ChangeLog8
-rw-r--r--x11-libs/wxGTK/files/digest-wxGTK-2.2.9-r11
-rw-r--r--x11-libs/wxGTK/files/wxGTK-2.2.9.diff.gzbin0 -> 269 bytes
-rw-r--r--x11-libs/wxGTK/wxGTK-2.2.9-r1.ebuild93
4 files changed, 101 insertions, 1 deletions
diff --git a/x11-libs/wxGTK/ChangeLog b/x11-libs/wxGTK/ChangeLog
index 569207085e17..fddeb5d84d0b 100644
--- a/x11-libs/wxGTK/ChangeLog
+++ b/x11-libs/wxGTK/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/wxGTK
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.6 2002/07/16 03:12:03 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.7 2002/08/09 18:32:11 raker Exp $
+
+*wxGTK-2.2.9-r1 (09 Aug 2002)
+
+ 09 Aug 2002; Nick Hadaway <raker@gentoo.org> wxGTK-2.2.9-r1.ebuild,
+ files/digest-wxGTK-2.2.9-r1, files/wxGTK-2.2.9.diff.gz :
+ Thanks to Francisco Gimeno for fixing the joystick code compile problem.
*wxGTK-2.3.2-r2 (13 Jun 2002)
diff --git a/x11-libs/wxGTK/files/digest-wxGTK-2.2.9-r1 b/x11-libs/wxGTK/files/digest-wxGTK-2.2.9-r1
new file mode 100644
index 000000000000..176a5207dbac
--- /dev/null
+++ b/x11-libs/wxGTK/files/digest-wxGTK-2.2.9-r1
@@ -0,0 +1 @@
+MD5 f9bf738050fca93e33a65081b1c55905 wxGTK-2.2.9.tar.bz2 3829283
diff --git a/x11-libs/wxGTK/files/wxGTK-2.2.9.diff.gz b/x11-libs/wxGTK/files/wxGTK-2.2.9.diff.gz
new file mode 100644
index 000000000000..306ecb30ed47
--- /dev/null
+++ b/x11-libs/wxGTK/files/wxGTK-2.2.9.diff.gz
Binary files differ
diff --git a/x11-libs/wxGTK/wxGTK-2.2.9-r1.ebuild b/x11-libs/wxGTK/wxGTK-2.2.9-r1.ebuild
new file mode 100644
index 000000000000..abe70ae46e5b
--- /dev/null
+++ b/x11-libs/wxGTK/wxGTK-2.2.9-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.2.9-r1.ebuild,v 1.1 2002/08/09 18:32:11 raker Exp $
+
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="GTK+ version of wxWindows, a cross-platform C++ GUI toolkit."
+
+SRC_URI="mirror://sourceforge/wxwindows/${P}.tar.bz2"
+
+HOMEPAGE="http://www.wxwindows.org/"
+
+LICENSE="GPL"
+
+SLOT="0"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ dev-libs/libunicode
+ media-libs/libpng
+ media-libs/jpeg
+ media-libs/tiff
+ media-libs/netpbm
+ nls? ( sys-devel/gettext )
+ odbc? ( dev-db/unixODBC )
+ gif? ( media-libs/giflib )
+ opengl? ( virtual/opengl )"
+
+#Possible future dependancies
+# motif? ( x11-libs/openmotif )
+# ungif? ( media-libs/libungif )
+
+RDEPEND="${DEPEND}"
+
+KEYWORDS="x86 -ppc -sparc -sparc64"
+
+src_compile() {
+
+
+ #cp configure.in configure.in.orig
+ #sed '1610i\ /usr/include/freetype2 \\' configure.in.orig > configure.in
+
+
+ local myconf
+ #--with-gtk enabled by default, if you want to build against motif,
+ #replace --with-gtk with --with-motif and --without-gtk. You will
+ #also need openmotif installed. Unfortunately, the package build tools
+ #only support installation of one currently.
+
+ myconf="--with-gtk"
+
+ #Build static library too, shared library is enabled by default.
+ #Enable useful config options that don't have USE flags
+ myconf="$myconf --enable-static --with-zlib --with-unicode"
+
+ #Note: png,jpeg,tiff,pnm, and pcx image support enabled by default if found.
+ #Also, all wxWindows gui features are enabled by default. If you
+ #want to build a smaller library you can disable features by adding
+ #the appropriate flags to myconf (see INSTALL.txt).
+
+ #The build tools include a --with-freetype option, however it doesn't
+ #seem to be implemented in the source yet.
+
+ #configure options that have corresponding USE variable.
+
+ use odbc && myconf="$myconf --with-odbc" #disabled by default
+ use gif || myconf="$myconf --disable-gif" #enabled by default
+ use opengl && myconf="$myconf --with-opengl" #disabled by default
+
+ #apply the patch to get compiled with GCC-3.1
+ gunzip < ${FILESDIR}/${P}.diff.gz | patch -p1
+ ./configure --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --host=${CHOST} \
+ ${myconf}|| die
+
+ make || die
+
+}
+
+src_install () {
+
+ make infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ prefix=${D}/usr \
+ install || die
+
+ dodoc CHANGES.txt COPYING.LIB INSTALL.txt \
+ LICENCE.txt README.txt SYMBOLS.txt TODO.txt
+
+}
+