summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/prokyon3/ChangeLog5
-rw-r--r--media-sound/prokyon3/prokyon3-0.9.6.ebuild7
-rw-r--r--media-sound/qmbtagger/ChangeLog7
-rw-r--r--media-sound/qmbtagger/qmbtagger-0.07.ebuild12
4 files changed, 25 insertions, 6 deletions
diff --git a/media-sound/prokyon3/ChangeLog b/media-sound/prokyon3/ChangeLog
index 03f74051e016..957363a03498 100644
--- a/media-sound/prokyon3/ChangeLog
+++ b/media-sound/prokyon3/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/prokyon3
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/prokyon3/ChangeLog,v 1.29 2007/11/18 22:06:20 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/prokyon3/ChangeLog,v 1.30 2007/11/18 22:09:13 aballier Exp $
+
+ 18 Nov 2007; Alexis Ballier <aballier@gentoo.org> prokyon3-0.9.6.ebuild:
+ add a check for flac cxx use flag, FLAC++ is needed here
18 Nov 2007; Alexis Ballier <aballier@gentoo.org>
-files/prokyon3-0.9.4-gcc41.patch, -prokyon3-0.9.4-r1.ebuild:
diff --git a/media-sound/prokyon3/prokyon3-0.9.6.ebuild b/media-sound/prokyon3/prokyon3-0.9.6.ebuild
index de20f624561a..33b6fd1af98c 100644
--- a/media-sound/prokyon3/prokyon3-0.9.6.ebuild
+++ b/media-sound/prokyon3/prokyon3-0.9.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/prokyon3/prokyon3-0.9.6.ebuild,v 1.5 2007/11/01 16:35:56 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/prokyon3/prokyon3-0.9.6.ebuild,v 1.6 2007/11/18 22:09:13 aballier Exp $
inherit qt3 eutils autotools
@@ -22,6 +22,11 @@ DEPEND="$(qt_min_version 3.2)
flac? ( media-libs/flac ) )"
pkg_setup() {
+ if use flac && use musicbrainz && ! built_with_use --missing true media-libs/flac cxx; then
+ eerror "To build ${PN} with flac support you need the C++ bindings for flac."
+ eerror "Please enable the cxx USE flag for media-libs/flac"
+ die "Missing FLAC C++ bindings."
+ fi
if ! built_with_use =x11-libs/qt-3* mysql; then
eerror "You have installed Qt without MySQL support."
eerror "Please reemerge x11-libs/qt-3* with "mysql" in USE."
diff --git a/media-sound/qmbtagger/ChangeLog b/media-sound/qmbtagger/ChangeLog
index ec572b5456c8..e1c950c41dc4 100644
--- a/media-sound/qmbtagger/ChangeLog
+++ b/media-sound/qmbtagger/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/qmbtagger
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qmbtagger/ChangeLog,v 1.18 2006/12/10 15:58:24 aballier Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qmbtagger/ChangeLog,v 1.19 2007/11/18 22:13:36 aballier Exp $
+
+ 18 Nov 2007; Alexis Ballier <aballier@gentoo.org> qmbtagger-0.07.ebuild:
+ add a check for flac cxx use flag, FLAC++ is needed here
10 Dec 2006; Alexis Ballier <aballier@gentoo.org>
+files/qmbtagger-0.07+flac-1.1.3.patch, qmbtagger-0.07.ebuild:
diff --git a/media-sound/qmbtagger/qmbtagger-0.07.ebuild b/media-sound/qmbtagger/qmbtagger-0.07.ebuild
index ada22bff3513..05825128748b 100644
--- a/media-sound/qmbtagger/qmbtagger-0.07.ebuild
+++ b/media-sound/qmbtagger/qmbtagger-0.07.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qmbtagger/qmbtagger-0.07.ebuild,v 1.11 2006/12/10 15:58:24 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qmbtagger/qmbtagger-0.07.ebuild,v 1.12 2007/11/18 22:13:36 aballier Exp $
inherit eutils kde-functions
@@ -25,6 +25,14 @@ DEPEND="${RDEPEND}
=sys-devel/automake-1.9*
>=sys-devel/autoconf-2.50"
+pkg_setup() {
+ if ! built_with_use --missing true media-libs/flac cxx; then
+ eerror "To build ${PN} you need the C++ bindings for flac."
+ eerror "Please enable the cxx USE flag for media-libs/flac"
+ die "Missing FLAC C++ bindings."
+ fi
+}
+
src_unpack() {
unpack ${A}
cd "${S}"