summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-process/htop/ChangeLog7
-rw-r--r--sys-process/htop/Manifest4
-rw-r--r--sys-process/htop/files/digest-htop-0.61
-rw-r--r--sys-process/htop/htop-0.6.ebuild24
4 files changed, 34 insertions, 2 deletions
diff --git a/sys-process/htop/ChangeLog b/sys-process/htop/ChangeLog
index 0ffc4ebd8ad3..5610bac9067a 100644
--- a/sys-process/htop/ChangeLog
+++ b/sys-process/htop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/htop
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/ChangeLog,v 1.12 2005/11/26 14:47:55 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/ChangeLog,v 1.13 2005/12/28 22:50:21 wschlich Exp $
+
+*htop-0.6 (28 Dec 2005)
+
+ 28 Dec 2005; Wolfram Schlich <wschlich@gentoo.org> +htop-0.6.ebuild:
+ version bump
*htop-0.5.4 (26 Nov 2005)
diff --git a/sys-process/htop/Manifest b/sys-process/htop/Manifest
index e62d0631e0e6..d68b190a426a 100644
--- a/sys-process/htop/Manifest
+++ b/sys-process/htop/Manifest
@@ -1,8 +1,10 @@
-MD5 3d0f58f84d8ae6800256f590cfc1d942 ChangeLog 3478
+MD5 93aaac476722b020a06b2dd098e939c0 ChangeLog 3590
MD5 eb4bbf8601e9cc359a1f91d669379c1a metadata.xml 568
MD5 297e7dd22f01831ea69638fed611171a htop-0.5.3.ebuild 703
MD5 8797004e103673ced2d2ae04946c02d4 htop-0.5.2.ebuild 690
MD5 debcf747824f0a4feea1a09e556762b6 htop-0.5.4.ebuild 694
+MD5 2c14c90b0aa912306aaa4c4d0aa33b38 htop-0.6.ebuild 692
+MD5 9bf9db981fa03184a2133184d9f9a3b3 files/digest-htop-0.6 60
MD5 8554a62ab326b2764855f3a4f435c8ad files/digest-htop-0.5.2 62
MD5 ff4b42c2affe2c064ba6cc787a47df15 files/digest-htop-0.5.3 62
MD5 3414d63f5c375dbab769897e4ea9383a files/digest-htop-0.5.4 62
diff --git a/sys-process/htop/files/digest-htop-0.6 b/sys-process/htop/files/digest-htop-0.6
new file mode 100644
index 000000000000..a04326e9142a
--- /dev/null
+++ b/sys-process/htop/files/digest-htop-0.6
@@ -0,0 +1 @@
+MD5 c00b1dba101569a055ed260e06a25596 htop-0.6.tar.gz 128136
diff --git a/sys-process/htop/htop-0.6.ebuild b/sys-process/htop/htop-0.6.ebuild
new file mode 100644
index 000000000000..72ca43a21e4c
--- /dev/null
+++ b/sys-process/htop/htop-0.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-0.6.ebuild,v 1.1 2005/12/28 22:50:21 wschlich Exp $
+
+inherit debug flag-o-matic
+
+DESCRIPTION="interactive process viewer"
+HOMEPAGE="http://htop.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+DEPEND="sys-libs/ncurses"
+
+src_compile() {
+ useq debug && append-flags -O -ggdb -DDEBUG
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README ChangeLog TODO
+}