summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-news/slrn/ChangeLog11
-rw-r--r--net-news/slrn/files/digest-slrn-0.9.7.43
-rw-r--r--net-news/slrn/slrn-0.9.7.4.ebuild50
3 files changed, 62 insertions, 2 deletions
diff --git a/net-news/slrn/ChangeLog b/net-news/slrn/ChangeLog
index f2a33fa9c4c2..ee287c0fd8b6 100644
--- a/net-news/slrn/ChangeLog
+++ b/net-news/slrn/ChangeLog
@@ -1,6 +1,13 @@
-# ChangeLog for net-news/slrn
+# ChangeLog for usr/slrn
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-news/slrn/ChangeLog,v 1.1 2002/02/01 21:53:36 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/slrn/ChangeLog,v 1.2 2002/06/23 16:46:43 lamer Exp $
+
+*slrn-slrn-0.7.7.4 (23 Jun 2002)
+
+ 23 Jun 2002; Ben Lutgens <lamer@gentoo.org> ChangeLog :
+
+ Latest version from upstream. Included two new patches and removed the
+ deprecated ones (ssl support is included now)
*slrn-0.9.7.3 (1 Feb 2002)
diff --git a/net-news/slrn/files/digest-slrn-0.9.7.4 b/net-news/slrn/files/digest-slrn-0.9.7.4
new file mode 100644
index 000000000000..1bce31bd09ba
--- /dev/null
+++ b/net-news/slrn/files/digest-slrn-0.9.7.4
@@ -0,0 +1,3 @@
+MD5 da944c58f301cf07a41f996d91de8431 slrn-0.9.7.4.tar.bz2 824593
+MD5 835ac527bb0653b1850b095ba1ea1ebc slrn-0.9.7.4-mem_leak.diff 3463
+MD5 32c3203c07449d310c6edbb5c06f8cbf slrn-0.9.7.4-popup_win.diff 329
diff --git a/net-news/slrn/slrn-0.9.7.4.ebuild b/net-news/slrn/slrn-0.9.7.4.ebuild
new file mode 100644
index 000000000000..feaa639e8b5d
--- /dev/null
+++ b/net-news/slrn/slrn-0.9.7.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer Ben Lutgens <lamer@gentoo.org>
+# Maintainer Terry Chan <tchan@enteract.com>
+# Added ssl support and new patches
+# $Header $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="s-lang Newsreader"
+PATCH_URI="http://slrn.sourceforge.net/patches"
+SRC_URI="mirror://sourceforge/slrn/${P}.tar.bz2
+${PATCH_URI}/${P}-mem_leak.diff
+${PATCH_URI}/${P}-popup_win.diff"
+LICENSE="GPL-2"
+SLOT=""
+
+HOMEPAGE="http://slrn.sourceforge.net/"
+DEPEND="virtual/glibc
+ virtual/mta
+ >=sys-apps/sharutils-4.2.1
+ >=sys-libs/slang-1.4.4
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ cd ${S}
+ for i in ${P}-{mem_leak,popup_win}.diff ; do
+ patch -p1 < ${DISTDIR}/${i}
+ done
+}
+
+src_compile() {
+ local myconf
+ use ssl && myconf="--with-ssl=/usr" \
+ || myconf="--without-ssl"
+ ./configure --infodir=/usr/share/info \
+ --mandir=/usr/share/man --prefix=/usr \
+ --with-slrnpull --host=${CHOST} $myconf \
+ || die "./configure failed (myconf=$myconf)"
+ emake || die
+}
+
+src_install () {
+
+ make DESTDIR=${D} DOCDIR=/usr/share/doc/${P} install || die
+ find $D/usr/share/doc -type f | xargs gzip
+}
+
+
+