summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/kflog/ChangeLog7
-rw-r--r--x11-misc/kflog/Manifest14
-rw-r--r--x11-misc/kflog/files/digest-kflog-2.1.1-r11
-rw-r--r--x11-misc/kflog/kflog-2.1.1-r1.ebuild89
4 files changed, 109 insertions, 2 deletions
diff --git a/x11-misc/kflog/ChangeLog b/x11-misc/kflog/ChangeLog
index d34ad6cf42e1..d767323d68f6 100644
--- a/x11-misc/kflog/ChangeLog
+++ b/x11-misc/kflog/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/kflog
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/kflog/ChangeLog,v 1.12 2005/07/28 21:11:06 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/kflog/ChangeLog,v 1.13 2005/08/25 05:04:51 smithj Exp $
+
+*kflog-2.1.1-r1 (25 Aug 2005)
+
+ 25 Aug 2005; Jonathan Smith <smithj@gentoo.org> +kflog-2.1.1-r1.ebuild:
+ #100512: fixed alsa dependency
28 Jul 2005; Caleb Tennis <caleb@gentoo.org> kflog-2.1.1.ebuild:
Fix qt dep per bug #100235
diff --git a/x11-misc/kflog/Manifest b/x11-misc/kflog/Manifest
index bb890e50fc26..310733c8f9e3 100644
--- a/x11-misc/kflog/Manifest
+++ b/x11-misc/kflog/Manifest
@@ -1,4 +1,16 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 9fb9f9216c0ab7f27d9bb0882e01103f kflog-2.1.1.ebuild 1545
-MD5 8976947e52252befa0f2bcb2b4d54ce2 ChangeLog 1395
+MD5 023a6c2ee8796554cf53b0ed6a76ead4 ChangeLog 1535
MD5 8dad4c602e8fc48cf21cf32d762b9af0 metadata.xml 231
+MD5 118251c0be693c2e398d6780f265d004 kflog-2.1.1-r1.ebuild 2235
+MD5 98254d123c609c4e7d9d142e43da91c9 files/digest-kflog-2.1.1-r1 64
MD5 98254d123c609c4e7d9d142e43da91c9 files/digest-kflog-2.1.1 64
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDDVGgl5AvwDPiUowRAl9oAKDAjVTUnwz/cQzSA0u0Axxg4nFzYQCglXmC
+b3pLuS+IBU4fqj5Do3YHqG8=
+=96Td
+-----END PGP SIGNATURE-----
diff --git a/x11-misc/kflog/files/digest-kflog-2.1.1-r1 b/x11-misc/kflog/files/digest-kflog-2.1.1-r1
new file mode 100644
index 000000000000..f1310a6166b2
--- /dev/null
+++ b/x11-misc/kflog/files/digest-kflog-2.1.1-r1
@@ -0,0 +1 @@
+MD5 266b9f8d4551b9926d9848fb0f28139e kflog-2.1.1.tar.bz2 878288
diff --git a/x11-misc/kflog/kflog-2.1.1-r1.ebuild b/x11-misc/kflog/kflog-2.1.1-r1.ebuild
new file mode 100644
index 000000000000..be1c67f9c69c
--- /dev/null
+++ b/x11-misc/kflog/kflog-2.1.1-r1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/kflog/kflog-2.1.1-r1.ebuild,v 1.1 2005/08/25 05:04:51 smithj Exp $
+
+inherit kde
+
+DESCRIPTION="A flight logger/analyser for KDE aimed at glider pilots"
+HOMEPAGE="http://www.kflog.org/kflog/"
+SRC_URI="http://www.kflog.org/download/src/${P}.tar.bz2"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-apps/gawk
+ sys-devel/gettext
+ sys-apps/grep
+ sys-devel/gcc
+ virtual/libc
+ sys-libs/zlib
+ arts? ( kde-base/arts )"
+
+RDEPEND="dev-libs/expat
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/jpeg
+ media-libs/libart_lgpl
+ media-libs/libmng
+ media-libs/libpng
+ media-libs/nas
+ sys-devel/gcc
+ virtual/libc
+ sys-libs/zlib
+ =x11-libs/qt-3*"
+
+need-kde 3
+
+src_unpack() {
+ unpack ${A}
+ if ! use arts; then
+ einfo "Removing arts checks..."
+ cd ${S}
+ sed -i -e '488,489d' -e '508,509d' acinclude.m4
+ einfo "Running autotools..."
+ aclocal
+ automake
+ autoconf
+ einfo "Fixing all Makefile.in..."
+ perl admin/am_edit \
+ po/Makefile.in \
+ doc/en/Makefile.in \
+ doc/Makefile.in \
+ kflog/pics/Makefile.in \
+ kflog/map-icons/small/Makefile.in \
+ kflog/map-icons/Makefile.in \
+ kflog/Makefile.in \
+ kflog/guicontrols/Makefile.in \
+ kflog/kfrfil/Makefile.in \
+ kflog/kfrgcs/Makefile.in \
+ kflog/kfrgmn/Makefile.in \
+ kflog/kfrxcu/Makefile.in \
+ kflog/kfrxsp/Makefile.in \
+ Makefile.in
+ fi
+}
+
+src_install() {
+ kde_src_install
+ rm -rf ${D}/usr/share/doc/HTML
+ chown -R root:users ${D}/usr/share/apps/kflog/mapdata
+ chmod -R ug+rw ${D}/usr/share/apps/kflog/mapdata
+}
+
+pkg_postinst() {
+ einfo "Note: Maps are not included. KFlog can download required data"
+ einfo "for you, or you may obtain map/airspace/airfield data at:"
+ einfo
+ einfo "http://maproom.kflog.org/"
+ einfo
+ einfo "and untar them in /usr/share/apps/kflog/mapdata"
+ einfo "Visiting http://www.kflog.org/ is generally a good idea."
+}
+
+pkg_postrm() {
+ einfo "Note: If you installed any maps, airspace or airfield data -"
+ einfo "DO NOT FORGET to remove it manually! (/usr/share/apps/kflog/mapdata"
+ einfo
+ einfo "Browsing though /usr/share/apps/kflog might be a good idea."
+}