summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-office/lyx/Manifest4
-rw-r--r--app-office/lyx/files/digest-lyx-1.3.2-r13
-rw-r--r--app-office/lyx/lyx-1.3.2-r1.ebuild100
3 files changed, 105 insertions, 2 deletions
diff --git a/app-office/lyx/Manifest b/app-office/lyx/Manifest
index fee21c3aeb3e..5eb3a4caff0a 100644
--- a/app-office/lyx/Manifest
+++ b/app-office/lyx/Manifest
@@ -3,8 +3,8 @@ MD5 de865463e736f9da5b8217931c633d42 lyx-1.2.1.ebuild 1721
MD5 66c6c064cc5fb697e51b69219c1c989e lyx-1.2.0.20020705.ebuild 1800
MD5 37f1a8579945ee147f5d4dc79aed4e72 lyx-1.2.3.ebuild 1721
MD5 f24529f32e1d66b46f2b97cd834c0b35 lyx-1.3.1.ebuild 2552
-MD5 c04c28820fd6d6005a84eb527dac282e lyx-1.3.2-r1.ebuild 3205
-MD5 e2af6134b147287f54f94d614cc29b2d ChangeLog 4839
+MD5 49f70071a23ae72306b281f0a978edfe lyx-1.3.2-r1.ebuild 3255
+MD5 520615bbe14ddc92ef89b94469e87d1b ChangeLog 4842
MD5 b3ebf86b8b554d919e6d1904ce505045 lyx-1.3.0.ebuild 2608
MD5 23edc3b998f98c60c164b9afd311b7b5 files/lyx-1.3.0-autogen.sh.diff 487
MD5 5bd1551a209feb15ad54144e16964096 files/digest-lyx-1.2.0.20020705 72
diff --git a/app-office/lyx/files/digest-lyx-1.3.2-r1 b/app-office/lyx/files/digest-lyx-1.3.2-r1
new file mode 100644
index 000000000000..2028cdfa4661
--- /dev/null
+++ b/app-office/lyx/files/digest-lyx-1.3.2-r1
@@ -0,0 +1,3 @@
+MD5 e33cf84f7c5be4ab9bbcc6ea587d4fdc lyx-1.3.2.tar.bz2 5469070
+MD5 f1df2f1426cca24c0dafa1dc1a832e6a hebrew.bind 45
+MD5 a0e3948595801a90d32d8b712596a5fe preferences 1669
diff --git a/app-office/lyx/lyx-1.3.2-r1.ebuild b/app-office/lyx/lyx-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..7abad57e9be0
--- /dev/null
+++ b/app-office/lyx/lyx-1.3.2-r1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.3.2-r1.ebuild,v 1.1 2003/06/11 09:17:43 danarmak Exp $
+
+DESCRIPTION="WYSIWYM frontend for LaTeX"
+SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${P}.tar.bz2
+ http://www.math.tau.ac.il/~dekelts/lyx/files/hebrew.bind
+ http://www.math.tau.ac.il/~dekelts/lyx/files/preferences"
+HOMEPAGE="http://www.lyx.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~alpha"
+IUSE="nls cups qt"
+
+DEPEND="virtual/x11
+ app-text/tetex
+ >=dev-lang/perl-5
+ nls? ( sys-devel/gettext )
+ app-text/aiksaurus
+ qt? ( >=x11-libs/qt-3 ) !qt? ( =x11-libs/xforms-1* )"
+RDEPEND="${DEPEND}
+ app-text/ghostscript
+ app-text/xpdf
+ virtual/aspell-dict
+ app-text/gv
+ dev-tex/latex2html
+ media-gfx/imagemagick
+ cups? ( virtual/lpr )
+ app-text/rcs
+ dev-util/cvs
+ app-text/sgmltools-lite
+ app-text/noweb
+ dev-tex/chktex"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 < $FILESDIR/$P-configure.diff
+}
+
+src_compile() {
+ use nls || myconf="${myconf} --disable-nls"
+ if [ -n "`use qt`" ]; then
+ inherit kde-functions
+ set-qtdir 3
+ myconf="$myconf --with-frontend=qt --with-qt-dir=${QTDIR}"
+ else
+ myconf="$myconf --with-frontend=xforms"
+ fi
+ [ -n "$DEBUG" ] && myconf="$myconf --enable-debug" || myconf="$myconf --disable-debug"
+
+ export WANT_AUTOCONF_2_5=1
+
+ flags="${CFLAGS}"
+ unset CFLAGS
+ unset CXXFLAGS
+ econf ${myconf} --enable-optimization="$flags"
+
+ emake || die "emake failed"
+
+}
+
+src_install() {
+ einstall
+ dodoc README* UPGRADING INSTALL* ChangeLog NEWS COPYING ANNOUNCE ABOUT-NLS $DISTDIR/preferences
+ insinto /usr/share/lyx/bind
+ doins $DISTDIR/hebrew.bind
+}
+
+pkg_postinst() {
+
+ if [ -n "`use qt`" ]; then
+ einfo "WARNING: the QT gui, together with xft2+fontconfig (which you"
+ einfo "almost certainly have), suffer from one infamous bug that causes"
+ einfo "the matheditor not to display any special characters (the ones from"
+ einfo "the Computer Modern font family). Generated documents (.dvi, .ps...)"
+ einfo "are ok, since tex has right fonts from the bluesky package."
+ einfo "A proper solution was being worked on. Meanwhile you can install the"
+ einfo "BaKoMa fonts package; however they are not licensed for redistribution"
+ einfo "(not even embedded inside generated documents) and cannot be used in"
+ einfo "commercial environments (without a special agreement from the author)."
+ einfo "If that suits you, you can get them on CTAN or at ftp.lyx.org as"
+ einfo "latex-ttf-fonts-0.1.tar.gz. I was working on an alternative, free"
+ einfo "fonts package derived from bluesky, but got stuck; wuold be glad"
+ einfo "to see someone continuing the effort (see the relevant threads on the"
+ einfo "lyx-devel mailing list or mail me if you want to know more)."
+ fi
+ einfo ""
+ einfo "================"
+ einfo ""
+ einfo "How to use Hebrew in LyX:"
+ einfo "1. emerge app-text/ivritex."
+ einfo "2. unzip /usr/share/doc/${P}/preferences.gz into ~/.lyx/preferences"
+ einfo "or, read http://www.math.tau.ac.il/~dekelts/lyx/instructions2.html"
+ einfo "for instructions on using lyx's own preferences dialog to equal effect."
+ einfo "3. use lyx's qt interface (compile with USE=qt) for maximum effect."
+
+}
+