summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/rpm2targz/rpm2targz-9.0.0.2g.ebuild')
-rw-r--r--app-arch/rpm2targz/rpm2targz-9.0.0.2g.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-arch/rpm2targz/rpm2targz-9.0.0.2g.ebuild b/app-arch/rpm2targz/rpm2targz-9.0.0.2g.ebuild
new file mode 100644
index 000000000000..3351ad41d442
--- /dev/null
+++ b/app-arch/rpm2targz/rpm2targz-9.0.0.2g.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm2targz/rpm2targz-9.0.0.2g.ebuild,v 1.1 2008/08/29 04:12:56 vapier Exp $
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Convert a .rpm file to a .tar.gz archive"
+HOMEPAGE="http://www.slackware.com/config/packages.php"
+SRC_URI="mirror://gentoo/${P}.tar.lzma"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="userland_GNU"
+
+# NOTE: rpm2targz autodetects rpm2cpio at runtime, and uses it if available,
+# so we don't explicitly set it as a dependency.
+RDEPEND="app-arch/cpio"
+DEPEND="${DEPEND}
+ app-arch/lzma-utils"
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc *.README*
+}