summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/i7z/files/i7z-0.27.1-gentoo.patch')
-rw-r--r--app-benchmarks/i7z/files/i7z-0.27.1-gentoo.patch59
1 files changed, 59 insertions, 0 deletions
diff --git a/app-benchmarks/i7z/files/i7z-0.27.1-gentoo.patch b/app-benchmarks/i7z/files/i7z-0.27.1-gentoo.patch
new file mode 100644
index 000000000000..f50f7c9effbb
--- /dev/null
+++ b/app-benchmarks/i7z/files/i7z-0.27.1-gentoo.patch
@@ -0,0 +1,59 @@
+ Makefile | 21 ++++++++++-----------
+ 1 files changed, 10 insertions(+), 11 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index df50bde..a8da026 100644
+--- a/Makefile
++++ b/Makefile
+@@ -17,18 +17,18 @@
+
+ #makefile updated from patch by anestling
+
+-CFLAGSANY = -g -O0 -fomit-frame-pointer -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -DBUILD_MAIN
++CFLAGS += -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -DBUILD_MAIN
+
+ LBITS := $(shell getconf LONG_BIT)
+ ifeq ($(LBITS),64)
+- CFLAGS = $(CFLAGSANY) -Dx64_BIT
++ CFLAGS += -Dx64_BIT
+ else
+- CFLAGS = $(CFLAGSANY) -Dx86
++ CFLAGS += -Dx86
+ endif
+
+-CC = gcc
++CC ?= gcc
+
+-LDFLAGS = -lncurses -lpthread -lrt
++LIBS = -lncurses -lpthread -lrt
+ INCLUDEFLAGS =
+
+ OBJS = helper_functions
+@@ -36,15 +36,15 @@ OBJS = helper_functions
+ BIN = i7z
+ SRC = i7z.c helper_functions.c i7z_Single_Socket.c i7z_Dual_Socket.c
+
+-sbindir = /usr/sbin
++sbindir = $(DESTDIR)/usr/sbin
+
+-all: clean message bin test_exist
++all: bin
+
+ message:
+ @echo "If the compilation complains about not finding ncurses.h, install ncurses (libncurses5-dev on ubuntu/debian)"
+
+ bin:
+- $(CC) $(CFLAGS) $(INCLUDEFLAGS) $(SRC) $(LDFLAGS) -o $(BIN)
++ $(CC) $(CFLAGS) $(LDFLAGS) $(INCLUDEFLAGS) $(SRC) -o $(BIN) $(LIBS)
+
+ test_exist:
+ @test -f i7z && echo 'Succeeded, now run sudo ./i7z' || echo 'Compilation failed'
+@@ -55,6 +55,5 @@ clean:
+ distclean: clean
+ rm -f *~ \#*
+
+-install: all
+- install -m 755 $(BIN) $(sbindir)
+-
++install:
++ install -D -m 755 $(BIN) $(sbindir)/$(BIN)