summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/cdemu/cdemu-1.4.0.ebuild')
-rw-r--r--app-cdr/cdemu/cdemu-1.4.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-cdr/cdemu/cdemu-1.4.0.ebuild b/app-cdr/cdemu/cdemu-1.4.0.ebuild
new file mode 100644
index 000000000000..012cc205d2b4
--- /dev/null
+++ b/app-cdr/cdemu/cdemu-1.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdemu/cdemu-1.4.0.ebuild,v 1.1 2011/11/23 10:14:26 tetromino Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+
+inherit python
+
+DESCRIPTION="Command-line tool for controlling the CDEmu daemon (cdemud)"
+HOMEPAGE="http://cdemu.org"
+SRC_URI="mirror://sourceforge/cdemu/cdemu-client-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cdemud"
+
+RDEPEND="dev-python/dbus-python
+ cdemud? ( >=app-cdr/cdemud-1.4.0 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.21"
+
+S=${WORKDIR}/cdemu-client-${PV}
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 src
+}