summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/pam_ssh/pam_ssh-1.9.ebuild')
-rw-r--r--app-crypt/pam_ssh/pam_ssh-1.9.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-crypt/pam_ssh/pam_ssh-1.9.ebuild b/app-crypt/pam_ssh/pam_ssh-1.9.ebuild
new file mode 100644
index 000000000000..1a35d01931dc
--- /dev/null
+++ b/app-crypt/pam_ssh/pam_ssh-1.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+DESCRIPTION="Uses ssh-agent to provide single sign-on"
+HOMEPAGE="http://pam-ssh.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pam-ssh/${P}.tar.bz2"
+
+LICENSE="BSD as-is"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="sys-libs/pam"
+RDEPEND="${DEPEND}
+ virtual/ssh"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-standard-prompt.patch
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO ${FILESDIR}/system-auth.example
+}
+
+pkg_postinst() {
+ einfo "You can find an example system-auth file that uses this"
+ einfo "library in /usr/share/doc/${PF}"
+}