summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/emacs/emacs-23.2-r3.ebuild')
-rw-r--r--app-editors/emacs/emacs-23.2-r3.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/app-editors/emacs/emacs-23.2-r3.ebuild b/app-editors/emacs/emacs-23.2-r3.ebuild
index 4776f5409274..28fb87fff88e 100644
--- a/app-editors/emacs/emacs-23.2-r3.ebuild
+++ b/app-editors/emacs/emacs-23.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-23.2-r3.ebuild,v 1.5 2011/02/20 19:38:32 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-23.2-r3.ebuild,v 1.6 2011/03/08 08:30:00 ulm Exp $
EAPI=4
WANT_AUTOMAKE="none"
@@ -170,10 +170,6 @@ src_configure() {
myconf="${myconf} --without-x --without-ns"
fi
- myconf="${myconf} $(use_with hesiod)"
- myconf="${myconf} $(use_with kerberos) $(use_with kerberos kerberos5)"
- myconf="${myconf} $(use_with gpm) $(use_with dbus)"
-
# According to configure, this option is only used for GNU/Linux
# (x86_64 and s390). For Gentoo Prefix we have to explicitly spell
# out the location because $(get_libdir) does not necessarily return
@@ -186,6 +182,10 @@ src_configure() {
--infodir="${EPREFIX}"/usr/share/info/${EMACS_SUFFIX} \
--with-crt-dir="${crtdir}" \
--with-gameuser="${GAMES_USER_DED:-games}" \
+ $(use_with hesiod) \
+ $(use_with kerberos) $(use_with kerberos kerberos5) \
+ $(use_with gpm) \
+ $(use_with dbus) \
${myconf}
}