summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/gvim/gvim-6.2_pre5.ebuild')
-rw-r--r--app-editors/gvim/gvim-6.2_pre5.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-editors/gvim/gvim-6.2_pre5.ebuild b/app-editors/gvim/gvim-6.2_pre5.ebuild
new file mode 100644
index 000000000000..d14225bedeb6
--- /dev/null
+++ b/app-editors/gvim/gvim-6.2_pre5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-6.2_pre5.ebuild,v 1.1 2003/05/24 02:18:03 agriffis Exp $
+
+inherit vim
+
+VIM_VERSION="6.2e"
+VIM_GENTOO_PATCHES="vim-6.2d-gentoo-patches.tar.bz2"
+VIM_ORG_PATCHES="" # no patches available
+
+SRC_URI="${SRC_URI}
+ ftp://ftp.vim.org/pub/vim/unstable/unix/vim-6.2e.tar.bz2
+ nls? ( ftp://ftp.vim.org/pub/vim/unstable/extra/vim-6.2e-lang.tar.gz )
+ mirror://gentoo/${VIM_GENTOO_PATCHES}"
+# mirror://gentoo/${VIM_ORG_PATCHES}"
+
+S=${WORKDIR}/vim${VIM_VERSION/.}
+DESCRIPTION="Graphical Vim"
+KEYWORDS="~alpha ~ppc ~sparc ~x86"
+PROVIDE="virtual/editor"
+DEPEND="${DEPEND}
+ ~app-editors/vim-core-6.2_pre5
+ x11-base/xfree
+ gtk2? ( >=x11-libs/gtk+-2.1 virtual/xft ) :
+ ( gnome? ( gnome-base/gnome-libs ) :
+ ( gtk? ( =x11-libs/gtk+-1.2* ) :
+ ( motif? ( virtual/motif ) ) ) )"