summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/zile/zile-2.4.1.ebuild')
-rw-r--r--app-editors/zile/zile-2.4.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-editors/zile/zile-2.4.1.ebuild b/app-editors/zile/zile-2.4.1.ebuild
new file mode 100644
index 000000000000..e3c3ed9b14a2
--- /dev/null
+++ b/app-editors/zile/zile-2.4.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/zile-2.4.1.ebuild,v 1.1 2011/09/25 15:56:32 ulm Exp $
+
+EAPI=4
+
+DESCRIPTION="Zile is a small Emacs clone"
+HOMEPAGE="http://www.gnu.org/software/zile/"
+SRC_URI="mirror://gnu/zile/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="acl livecd test valgrind"
+
+RDEPEND="dev-libs/boehm-gc
+ sys-libs/ncurses
+ acl? ( virtual/acl )"
+
+DEPEND="${RDEPEND}
+ test? ( valgrind? ( dev-util/valgrind ) )"
+
+src_configure() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ --disable-silent-rules \
+ $(use_enable acl) \
+ $(use test && use_with valgrind || echo --without-valgrind)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # AUTHORS, FAQ, and NEWS are installed by the build system
+ dodoc README THANKS
+
+ # Zile should never install charset.alias (even on non-glibc arches)
+ rm -f "${ED}"/usr/lib/charset.alias
+}
+
+pkg_postinst() {
+ if use livecd; then
+ [[ -e ${EROOT}/usr/bin/emacs ]] || ln -s zile "${EROOT}"/usr/bin/emacs
+ fi
+}