summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vim/ChangeLog5
-rw-r--r--app-editors/vim/vim-6.1-r17.ebuild7
2 files changed, 10 insertions, 2 deletions
diff --git a/app-editors/vim/ChangeLog b/app-editors/vim/ChangeLog
index a280c1e13f66..8c71cc888507 100644
--- a/app-editors/vim/ChangeLog
+++ b/app-editors/vim/ChangeLog
@@ -1,11 +1,14 @@
# ChangeLog for app-editors/vim
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.30 2002/12/13 10:56:06 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.31 2002/12/15 00:11:25 rphillips Exp $
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
*vim-6.1-r17.ebuild (06 Dec 2002)
+ 15 Dec 2002; Ryan Phillips <rphillips@gentoo.org> vim-6.1-r17.ebuild :
+ Added ex, rview, rvim, and others to ebuild
+
12 Dec 2002; Seemant Kulleen <seemant@gentoo.org> vim-6.1-r17.ebuild :
Added to sparc testing profile.
diff --git a/app-editors/vim/vim-6.1-r17.ebuild b/app-editors/vim/vim-6.1-r17.ebuild
index d5b2d06c59c6..2f156af2d729 100644
--- a/app-editors/vim/vim-6.1-r17.ebuild
+++ b/app-editors/vim/vim-6.1-r17.ebuild
@@ -1,6 +1,6 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-6.1-r17.ebuild,v 1.6 2002/12/12 09:38:53 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-6.1-r17.ebuild,v 1.7 2002/12/15 00:11:26 rphillips Exp $
VIMPATCH="vimpatch-1-263.tar.bz2"
inherit vim
@@ -58,6 +58,11 @@ src_compile() {
src_install() {
dobin src/vim
ln -s vim ${D}/usr/bin/vimdiff
+ ln -s vim ${D}/usr/bin/rvim
+ ln -s vim ${D}/usr/bin/ex
+ ln -s vim ${D}/usr/bin/view
+ ln -s vim ${D}/usr/bin/rview
+
# Default vimrc
insinto /etc/vim/
doins ${FILESDIR}/vimrc