summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/auctex/auctex-11.54.ebuild')
-rw-r--r--app-emacs/auctex/auctex-11.54.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/app-emacs/auctex/auctex-11.54.ebuild b/app-emacs/auctex/auctex-11.54.ebuild
index 9cfc45ddc047..0688221cd6de 100644
--- a/app-emacs/auctex/auctex-11.54.ebuild
+++ b/app-emacs/auctex/auctex-11.54.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/auctex-11.54.ebuild,v 1.3 2005/04/09 20:52:01 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/auctex-11.54.ebuild,v 1.4 2005/04/12 14:32:00 usata Exp $
-inherit elisp
+inherit elisp eutils
DESCRIPTION="AUCTeX is an extensible package that supports writing and formatting TeX files"
HOMEPAGE="http://www.gnu.org/software/auctex"
@@ -15,8 +15,18 @@ IUSE=""
DEPEND="virtual/tetex"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # skip XEmacs detection. this is a workaround for emacs23
+ epatch ${FILESDIR}/${P}-configure.diff
+}
+
src_compile() {
- econf --with-auto-dir=${D}/var/lib/auctex \
+ econf \
+ --disable-build-dir-test \
+ --with-auto-dir=${D}/var/lib/auctex \
--with-lispdir=${D}/usr/share/emacs/site-lisp \
--with-tex-input-dirs="/usr/share/texmf/tex/;/usr/share/texmf/bibtex/bst/" || die "econf failed"
emake || die