summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/ess/ess-5.2.8.ebuild')
-rw-r--r--app-emacs/ess/ess-5.2.8.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-emacs/ess/ess-5.2.8.ebuild b/app-emacs/ess/ess-5.2.8.ebuild
new file mode 100644
index 000000000000..b782f9046993
--- /dev/null
+++ b/app-emacs/ess/ess-5.2.8.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ess/ess-5.2.8.ebuild,v 1.1 2005/06/30 16:56:40 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Emacs Speaks Statistics"
+HOMEPAGE="http://stat.ethz.ch/ESS/"
+SRC_URI="http://stat.ethz.ch/ESS/downloads/ess/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~sparc ~amd64 ~ppc ~ppc-macos"
+
+DEPEND="app-text/texi2html
+ sys-apps/sed
+ virtual/tetex"
+RDEPEND=""
+
+SITEFILE=50ess-gentoo.el
+
+src_compile() {
+ # The -glossary option doesn't work with Gentoo texi2html.
+ sed "s:-glossary::g" ${S}/doc/Makefile > ${T}/Makefile;
+ make PREFIX=/usr \
+ INFODIR=/usr/share/info \
+ LISPDIR=/usr/share/emacs/site-lisp/ess \
+ || die
+}
+
+src_install() {
+ make PREFIX=${D}/usr \
+ INFODIR=${D}/usr/share/info \
+ LISPDIR=${D}/usr/share/emacs/site-lisp/ess \
+ install || die
+ elisp-site-file-install ${FILESDIR}/${SITEFILE};
+ elisp-install ${PN} lisp/*.el
+ dodir /usr/share/emacs/etc/ess
+ cp -a etc/* ${D}/usr/share/emacs/etc/ess
+ dohtml ${S}/doc/html/*.html
+ dodoc ${S}/doc/{NEWS,README,TODO}
+ insinto /usr/share/doc/${P}
+ doins ${S}/doc/ess-intro.pdf
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see /usr/share/doc/${P} for the complete documentation."
+ einfo "Usage hints are in /usr/share/emacs/site-lisp/${PN}/ess-site.el."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}